Wireless Client

Discussion in 'Tomato Firmware' started by Mojonba, Sep 23, 2017.

  1. Mojonba

    Mojonba Network Guru Member

    Hello Guys,

    I am trying to set up my Asus RT-68 as a wireless client to my phone's hotspot. It is however unable to get an IP address and therefore connect. Below a screenshot of my config. Any ideas? I have an Asus RT-68 with Shibby 140


    Attached Files:

  2. cloneman

    cloneman Addicted to LI Member

    You probably want Wireless Ethernet Bridge to retain the phone as the DHCP server
    Sean B. likes this.
  3. Mojonba

    Mojonba Network Guru Member

    That is an option, but it will leave my Lan inoperative whenever I take my phone out. From what I have read wireless client mode is broken on Shibby. Can anybody confirm? Or am I doing something wrong?
  4. Client Mode is broken in both Toastman and Shibby variants including Advanced Tomato and Kille72's build =(. If you need a working Client Mode, you will need to switch over to dd-wrt for now which is what I had to do or use Wireless Ethernet Bridge as suggested. With limited resources and developers, fixing Tomato's Client Mode seems to be a low priority at this point. It may be best to disable the option altogether until it can be fixed.
    Last edited by a moderator: Sep 24, 2017
  5. Gurgel

    Gurgel Reformed Router Member

    Actually Wireless Client Mode works in Tomato, but not on all routers. It works on older stuff like the WRT54GL and it works on the Asus RT-16N and on the Asus RT-N12D1. But not on the RT-N18U, not on the R7000.

    It will probably work on the Asus RT-68, with security disabled. Meaning it doesn't work..
  6. I'm wondering what dd-wrt does that makes it work in the newer routers that Tomato doesn't? Would this be merely a coding, wireless driver issue, network protocol issue, all of the above? I don't think it would be a router hardware issue since dd-wrt seems to have Client Mode working regardless of router model.

    Whatever is causing the problem, as I mentioned above, I don't think there is enough of a priority to work on it. I applause Kille72's having it on his list to try and fix. However, as he has stated, he is not a programmer and unfortunately, neither am I. =( I think it will take a Shibby or Toastman type person to look at this and try to figure out.
  7. Monk E. Boy

    Monk E. Boy Network Guru Member

    Works on 54GL, N16, N12 but not on N18 or R7000? So it works on MIPS but not on ARM?
  8. I think you are on to something here. Come to think of it, the last router that I had Tomato Client Mode successfully working was an RT-N66 which is MIPS based. Since switching over to ARM, I've never gotten it to work. I have to admit that I've tried several different ARM routers since then thinking the problem was me. Looks like something in the porting over to the ARM branch broke it.
  9. linkuser

    linkuser New Member Member

    I am having a problem with the wireless client mode. The thing is it was absolutely working on the asus RT-N16 for like a few days and than suddenly it completely stop wanting to connect to the ssid it was connecting no problem for like 5 days. I tried resetting/ complete reflash and it will have 0 signal. It only has signal when I use ubuntu laptop and clone the wireless mac connecting at the same time which will somehow activate the signal back up but unfortunately the udhcp doesn't work so it still won't connect. The ubuntu laptop with clone mac connects no problem.

    Is there something written to the nvram that isn't clear with a format? I cannot understand how the wireless client can stop working when it was working for days. No problem as an access point.
  10. Sean B.

    Sean B. LI Guru Member

    What makes you certain the problem is with the RT-N16/Tomato rather than the AP it was connecting to? The fact other clients ( that are full operating system clients, rather than embedded mini-systems ) can connect does not exclude something having changed that the RT-N16/Tomato isn't configured for/compatible with.
  11. loop123

    loop123 New Member Member

    I got "wireless client mode" working to my phone on a RT-N66U (1.28.0000 MIPSR2-138 K26 USB AIO-64K), but not on the R7000 (1.28.0000 -140 K26ARM USB AIO-64K). Same setup. Maybe MIPS vs. ARM? One thing I noticed on the RT-N66U, to get it working, I had to got through every dropdown in the wireless client configuration to make sure it was updated. My guess is that is where the problem lies - the security settings are not updated properly from the interface.
  12. Yea, the problem is something in the ARM builds. I encountered the same when switched from a MIPS router to an ARM one. The Tomato Client mode settings worked fine in the MIPS but I have never been able to get it working in ARM. I think it's something with the security settings but I am not talented enough to figure it out. =( Sadly, the power developers Tomato once had are gone. We only have a few handful of wonderful enthusiasts like Kille72 keeping Tomato alive. I think it is going to take another power developer willing to donate their time and dive into the ARM build code and see if Client Mode can be fixed. If someone talented enough wanted to step up to the plate, I would gladly donate but I don't think there is enough interest. =(

    DD-WRT is the only third party firmware for ARM routers that I know of with a working Client Mode and it what I have to use at this time if I want this feature.
  13. Monk E. Boy

    Monk E. Boy Network Guru Member

    The problem with a major architectural change like going from MIPS to ARM is that you spend a lot of your time reinventing the wheel. Code that worked fine on one architecture won't necessarily work fine on a different architecture. So you end up having to replace old nonfunctional code with new code, and sometimes the new architecture simply doesn't support the methods or tricks the old code used to implement that feature, requiring a whole new mindset to implement (assuming its even possible). It's a lot of work, which is why I was surprised that Shibby & Toastman were able to get so much of it working on ARM.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice