Wireless connection getting slow after some days on RT-N16 (Toastman)

Discussion in 'Tomato Firmware' started by supertoast, Jun 24, 2013.

  1. supertoast

    supertoast Reformed Router Member


    I'm using an Asus RT-N16 with Tomato v1.28.7501 MIPSR2Toastman-RT K26 USB Std and my wireless connection is getting slow after some days of operation (every ~5 days).
    Streamed videos start stuttering and browse speed is getting noticeable slow (~ <1mb/s). The speed get's normal after a reboot of the router and I can reach about 10mb/s again (for the next 5 days).

    Here are some of my network settings:
    Channel width: 40MHz
    Control Sideband: Upper
    Security: WPA2-Personal

    QoS is disabled. I am running a pretty default setup using DHCP and some NAT settings.
  2. Planiwa

    Planiwa Network Guru Member

    What wifi-connected clients, and what do they do?
    Any P2P?
    Any Macs? (They facilitate monitoring and diagnosing)

    Might want to look at these pages, when it gets slow:


    see if you have many connections, especially UDP.

    Depending on above results, there are further diagnostics. . . .

    (When it gets bad, celebrate the opportunity to observe.)
  3. supertoast

    supertoast Reformed Router Member

    Hi Planiwa,
    there are nothing but linux clients in this wifi and no P2P. I observed the incoming/outgoing traffic at this time and there was nothing special. I'll take a deeper look if it happens again.
  4. Planiwa

    Planiwa Network Guru Member

    Linux may be better than Mac -- while both run Unix, Linux users typically don't need to be shown how to run a command. :)

    There are two approaches to problem solving:

    1. Reboot! (Or the more sophisticated variation: Reboot regularly!)
    2. Diagnose until I understand the cause.

    (I consider the former approach barbaric, but I acknowledge that it is the common approach on this planet, and that others have other priorities and interests.)

    So, when the system is in the "slow" state,

    1. What can I measure that clearly distinguishes the "slow" state from the normal state?

    2. Is only WiFi affected, or wired as well?

    3. What possible causes can I imagine?

    For #1 -- Subjective observations (videos stutter) are not as useful as quantitative measurements.

    There are two kinds of measures:

    1.a WiFi parameters -- RSSI, Noise, TX/RX rate; other observables -- connections
    1.b performance measures -- throughput, latency, latency variance, packet loss. (client to router)

    #2 -- this may inform #3.

    #3 --

    3.1 something goes wrong with the wireless.
    3.3 something goes wrong with the router apart from the wireless.

    Here is an example of a performance measure that I might do when the system is normal, and when it is slow, and contrast the results of repeated measurements at intervals:

    set -- $(sudo ping -i.001 -s1000 -c1000 -q router | tr '/' ' ') ;  echo ${15}: ${27%.*} ${28%.*} ${29%.*} $2
    Output should look like:

    1000: 0 0 2 router.mydomain

    (That's for Darwin -- need to adjust for Linux. Adjust parameters as appropriate.)

    Once I have measures that are clearly different for the "slow" state and the "normal" state, then I can do this every 5 minutes and see when and how it changes. etc.

    Or, I might scp a large file between the router and a client host. (Making the target /dev/null).
  5. supertoast

    supertoast Reformed Router Member

    Now my connection is getting slow again :)

    Here some general router stats:
    Uptime: 4 days, 17:20:24
    CPU Load (1 / 5 / 15 mins): 0.00 / 0.00 / 0.00
    CPU Usage: 0.66%
    Total / Free Memory: 124.31 MB / 115.93 MB (93.25%)

    Ping from LAN connected PC:
    --- ping statistics ---
    40 packets transmitted, 40 received, 0% packet loss, time 38997ms
    rtt min/avg/max/mdev = 0.269/0.288/0.304/0.024 ms

    Ping from Wifi connected Laptop1:
    --- ping statistics ---
    40 packets transmitted, 40 received, 0% packet loss, time 39060ms
    rtt min/avg/max/mdev = 1.244/10.047/91.350/17.528 ms

    Ping from Wifi connected Laptop2:
    --- ping statistics ---
    40 packets transmitted, 40 received, 0% packet loss, time 39056ms
    rtt min/avg/max/mdev = 1.150/31.379/145.215/33.392 ms

    Laptop1 Wifi stats:
    RSSI: -48dbm
    Quality: 57
    RX/TX Rate: 48 / 6

    Laptop2 Wifi stats:
    RSSI: -32dbm
    Quality: 67
    RX/TX Rate: 14 / -

    SCP transferrate from LAN PC to router /dev/null
    about constant: 2.6MB/s

    SCP transferrate from Wifi Laptop 1 to router /dev/null
    started at 600KB/s and getting slower. After 28MB of file transfer it was about 50KB/s. After that it went up to 400KB/s.

    I remember getting transfer speeds from NAS to Laptop1 (Wifi connection) at up to 10MB/s constantly. And from NAS to LAN PC at about 90MB/s (gigabit LAN).
    Now it is from NAS to Laptop1 at 1,6MB/s and getting slower. And from NAS to LAN PC 85MB/s. So the Wifi is clearly more affected than LAN.

    Your command isn't working and I can't figure out how to get it working in linux.

    What else can I do to track this issue down? The router is still in this "slow-state".
  6. Elfew

    Elfew Network Guru Member

    Man, I have same problem about 6months ago... Same problem with shibby and toastman - speed was low after some days of uptime. It solved Victek build, just try
  7. supertoast

    supertoast Reformed Router Member

    Thanks Elfew, I'll try Victeks (RAF) version!
  8. Planiwa

    Planiwa Network Guru Member

    (I may regeret having posted the following.)

    This may work for a Linux host. Run as root because of the short intervals.


     set -- $(ping -i.001 -s1462 -c10000 -q | tr '/' ' ') ;  echo  ${16}: ${29%.*} ${30%.*} ${31%.*} $2 ${22}
    (If your hosts are too slow (i.e. packets are lost under ideal conditions), increase the interval.)

    Since you have multiple Linux hosts, you might also send data between 2 hosts, which leaves the router free to just route (and radio).

    It's probably worth reading the ping man page, to realize what the above command does, and how it measures data transfer performance.
  9. Elfew

    Elfew Network Guru Member

    I reported this issue in Toastman and Shiby topic repeately, but noone helped me. So I just try reflash Toastman build -> after 3days problems with wifi performance and speed. I flashed Shibby -> same problems after 3-4days... I always erase my NVRAM and configure by hand.

    So I was lost, I didnt want to stay with stock buggy fw. So I flashed Victek build. Problems gone and I am happy.

    Flash last beta version of Victek and let us know about results
  10. Planiwa

    Planiwa Network Guru Member

    I wonder if anyone has ever provided any data --
    1. That distinguishes the "normal" state from the "slow" state.
    2. That would therefore enable someone to say "5 minutes ago it was normal, now it is slow".
    3. That might be useful in diagnosing the (cause of the) problem.
    3. That could be used to see if any measures other than rebooting would return to the normal state.

    Rebooting seems quite acceptable to many, and certainly much easier than providing data that might help diagnose the problem so that it might be recognized, diagnose, and solved.

    Surely rebooting cannot be regarded as a solution, and neither can abandoning the software for another brand.

    Yesterday I went to a site where one person had complained "internet really bad". With absolutely no data at all, not even a time when "it" was supposdly "bad", or *what* was supposedly bad. I did very thorough tests, and everything checked out perfect. Then someone else stopped by to say that the network had beed excellent for the past few days!

    The only data I have is that the one whose "internet was bad" generates 20 times as many connections than the others. Mostly UDP.
  11. supertoast

    supertoast Reformed Router Member

    For now the output of the above command is:
    10000: 0 0 0 9998ms
    I'll see what it looks like when the connection is getting slow again (rebooted last night).
    Since I don't want to fiddle around too much, I'll consider flashing to the Victek version some time.
  12. Planiwa

    Planiwa Network Guru Member

    That looks very perfect.
    You might try replacing -s1462 with -s2900.
    And if that's still perfect, try -s4300.

    (Of course you'll want to run this a few times to make sure the results are stable, and also you'll want to make sure nothing else is running.)
  13. HiFiR

    HiFiR Network Newbie Member

    Old thread, but was top of google search.

    @supertoast Did you have a chance to solve this problem? My Asus RT-N16 runs on stock firmware and is having similar problem of yours. I had it for two years with no problem, now it happens. I suspect it's the hardware itself, maybe the antenna gets bad.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice