Wireless connection: Yes, Wired connection: No

Discussion in 'Cisco/Linksys Wireless Routers' started by jan404, Mar 30, 2006.

  1. jan404

    jan404 LI Guru Member

    Hello all,

    I have this weird thing with my WRT54g (V1.1)

    I have used it for at least a year without problems, running HyperWRT.

    Now, I can't connect to it anymore through ethernet. No ping response, nothing.

    Wireless everything works fine. I even updated the firmware without any problems. But I also need a wired connection to it.

    Does anyone have an idea of what might be wrong?

  2. jgutz20

    jgutz20 Network Guru Member

    does it show that its connecting? or does it just show network cable unplugged?
  3. jan404

    jan404 LI Guru Member

    Yes, it shows that it is connecting.

    But no response. I don't get an IP Address assigned.

    I also tried a port scan for addresses .... but all addresses are dead.
  4. RTSAnime

    RTSAnime Network Guru Member

    try connecting your computer to the internet port of the router. Sometimes things get messed up.
  5. jan404

    jan404 LI Guru Member

    Yeah, sometime things do get messed up:

    I connected my computer to the internet port and, to my suprise, I do get a connection, I can ping, I can browse the administration pages, etc.

    But now: what do I do to restore a working situation? I already tried restoring the factory settings and that works fine but it doesn't solve anything: I still can't get a connection on the other 4 ports.
  6. Thibor

    Thibor Super Moderator Staff Member Member

    you are using Hyperwrt so in the Diagnostics page you should be able to type a command on the command line. try "nvram erase; reboot"
    if that doesn't work, flash to the latest official linksys firmware(4.20.7 i believe) and that should rectify matters for you, from there you can go back to hyperwrt
  7. Toxic

    Toxic Administrator Staff Member

    try a ping to the router like so:

    ping -t "routers IP"

    but turn of and then back one the router

    if you able to ping the router for about 5 seconds before it goes dead, then boot wait is on. the you cna try using the linksys tftp and reflash the router again.

    it sounds like the routers firmware has become corrupt or a failed firmware upgrade tbh.
  8. jan404

    jan404 LI Guru Member

    Thanks for your answers!

    I've done the following:
    - nvram erase and reboot from HyperWRT --> works fine, but still no connection through ports 1-4
    - installed the latest Linksys firmware (4.20.7) --> works fine, but still no connection though ports 1-4

    So my problem still isn't solved yet... any other suggestions?
  9. ramkitty

    ramkitty Guest

    how possible is it that your port driver ic failed?
  10. RTSAnime

    RTSAnime Network Guru Member

    your vlan settings got messed up. I am too much of a newbie to know how to rectify those though. Hopefully someone with more experience can help you fix those.

    EDIT: THis is a common problem with V1x G's My 54G 1.0 also has the same problem if I try to use any firmware other than DD-WRT. Its really weird.
  11. Toxic

    Toxic Administrator Staff Member

    what commands did you use for nvram erase?

    try this one from telnet if possible.

    erase nvram;reboot
  12. jan404

    jan404 LI Guru Member

    @ramkitty: it doesn't really sound like a hardware failure to me, as far as I know the WRT actually has a 6 port switch (four utp ports, one internet port, one for wireless) and the wireless and internet ports work fine. Also, if i connect to one of the four ports, the router switches on the corresponding led for that port. But there could be hardware failure 'somewhere inside', that would be hard to detect.

    @RTSAnime: sounds like we have the same problem! I never used the DD-WRT software; I'll try it as soon as I can. Thanks for the tip!

    @Toxic: that's exactly what I did, nvram erase and reboot from telnet.
  13. jan404

    jan404 LI Guru Member

    Well... like RTSAnime suggested, I flashed DD-WRT and tadaa... it's working flawless now!

    I'm really happy with this! Thanks all!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice