Wireless drops connection WAG354G

Discussion in 'Other Linksys Equipment' started by chris77, Mar 1, 2006.

  1. chris77

    chris77 Network Guru Member

    Mine’s a WAG354G through a 2mb Pipex account. I lose the connection downstairs on the wireless laptop after about half an hour. The Linksys is upstairs and hard wired to the main computer. The main computer is perfect. When it fails I also lose the file sharing so it must be a wireless problem. Tried many different channel settings and invested in an aerial.
    The funny thing is that I can take the laptop upstairs and stand it beside the Linksys and still it won't reconnect. XP reports the signal is excellent during all this. Turning off and on the radio button many times on the laptop usually works but I'm not convinced that this is just a co-incidence.
    All settings are the default as delivered and not even any security settings
  2. Advis

    Advis Network Guru Member

    Having the same problems and have been in contact with Linksys. They've forwarded it to their product engineers for 'further investigation'. Try pinging the router (start>run>type 'cmd' then hit enter>'ping -t' in the command prompt then hit enter), notice how the wireless connection sometimes either drops a packet or gives very high ping whilst the wired connection gives all responses at 1ms or even less. There's clearly a problem with WAG354G as the wireless is laggy and very weak. All we can do is wait and hope Linksys produce a fix.

    I've noticed that there is new German 1.01.07 and European 'V2' 1.01.54 firmware code for download on Linksys's GPL centre. New firmware should be on it's way but if someone knows how to compile them please be my guest.
  3. chris77

    chris77 Network Guru Member

    I'll try your suggestion when I get home. This laptop is currently at work and connected through its modem to a normal phone line. I guess your check will confirm absolutely the difference between wireless and non-wireless.
  4. Still2complicated

    Still2complicated Network Guru Member

    What firewall are you running?
    The reason I ask is that for the last 2 months I have been losing my wireless signal- it goes from excellent to off line and then back to good then poor then off again.
    After 2 months of goggling and trying everything I called Linksys tech support suspecting a hardware issue and they had me change a few settings but the one that I think fixed it was shutting down my firewall- it's CA's EZ firewall BTW. How the firewall affects the wireless signal I can't even begin to guess but it seems to have worked, but I now don't run a firewall.
  5. chris77

    chris77 Network Guru Member

    Just the XP software firewall!!
  6. chris77

    chris77 Network Guru Member

    Yes the ping test is interesting.
    First I didn't get any dropped packets.
    Some made 2ms (not many) but most were in the region of 17ms 18ms 19ms.
    So why every so often dropping to 2ms?
  7. chris77

    chris77 Network Guru Member

    Then I went back and did it again.....
    REQUEST TIMED OUT - 10 times
    So I turned wireless off and on...
    HARDWARE ERROR - 5 times
    then back to...
    17ms to 18ms and some 2ms for 18 pings
    then REQUEST TIMED OUT again before I aborted it.
    So looks like you are right!!
  8. Advis

    Advis Network Guru Member

    Well it's good to see that I'm not the only one, though bad that we're having it in the first place. Email Linksys and explain what the problem is and the steps you've taken here. They know about my issues and surely they will have more ; if we keep plugging them they will fix it.
  9. chris77

    chris77 Network Guru Member

    Just put a mail through to support.uk@linksys.com
    Thanks for your help. Perhaps they have new firmware.
    Found this on wired.com.....

    There is a way of getting lost Wi-Fi connections going again, but it involves going deep into XP's settings every time the problem arises, Fleishman said. And the fix could be a nightmare for people like Gilmore, who don't want less-advanced users mucking around with the guts of the operating system.

    With advance apologies to Gilmore and other network administrators, here's Fleishman's workaround:

    • Go to Control Panel.
    • Choose Administrative Tools.
    • Select Services. A two-pane window comes up.
    • In the right-hand pane, scroll down and click Wireless Zero Configuration.
    • Click Stop the Service. A progress bar may come up briefly.
    • Click Start the Service. Again, a progress bar may come up.
    • Close the Services window. At this point, Fleishman said, the connection should come back.
  10. Advis

    Advis Network Guru Member

    I don't think they have any newer firmware, even when I asked for compiled versions of what code I've found under the GPL centre all I get back from Linksys is 'it's been escelated to our product engineers'. But I'm hoping we'll get something soon.

    By the way, how come your using WZC? Try using the utility that comes with your wireless card and disable WZC. WZC is pants.
  11. chris77

    chris77 Network Guru Member

    I'm using a Dell Latitude D610. Configured entirely as it arrived from Dell with XP Professional.
    Pentium M 1.86 GHz Processor
    Intel PRO Wireless 2200BG
  12. dannyboy1121

    dannyboy1121 Network Guru Member

    Hmm - sometimes I've found the WZC utility works better than the card specific utility (*thinks back to his 3com card*)

    Seems a bit odd to say that its a problem with the router when the fix is to cycle a service on the client ... no? I mean - if it was the router then disabling the card (or pulling it) and re enabling it would be the same from the routers perspective.

    I've just picked up a WAG354G so I'm sincerely hoping that this isn't turkey time.

    So far - I think it looks rather sexy next to my NSLU2.
  13. dannyboy1121

    dannyboy1121 Network Guru Member

    errr hmmm ..

    well I've just run a lil test on a couple of laptops and cards here with my new WAG354G.

    Firstly - my xp home laptop with my 3com card (using WZC) started up - got IP almost straight away - then dropped it within a minute and failed to re-establish a connection. Re-installed the 3com card management software and then I got an IP and some stability (i.e. I didn't get kicked).

    With XP Pro and a netgear card - I didn't have the netgear card software running so I had to use windows config. It wouldn't accept a passphrase but it's not the first time I've seen this. After putting in the hex value I managed to get an IP assigned.

    So - a bit picky but not killer.

    The good news is that even without a twig fitted - the coverage seems excellent all over the house so it seems pretty cool (so far anyway .. you wait - I'll be back on the forums crying about something sooner or later).

    Chris .. going back to your original post you mention cycling your radio button on an off a number of times to try and re-establish connection. What happens if you power cycle your router instead?
  14. Advis

    Advis Network Guru Member

    If you do a ping test as I've described you may see abnormal packet response times, my theory is that this is whats causing the wireless to disconnect as it 'times out' the connection. The reason why it doesn't reconnect is because the latency is still high I presume. This is a router issue for definate.
  15. chris77

    chris77 Network Guru Member

    If I reboot the Router It comes back again. But I don't know this proves anything. Going upstairs and rebooting takes some time (establishing the connection to the IP) and I haven't seen the laptop getting back its connection at exactly that time. It seems to me the wireless will sort itself after a period without my help!
    This is what Linksys have replied.....

    Thank you for contacting Linksys Technical Support.

    You might be getting wireless interference on the network that’s why the wireless connection is intermittent. You can still try the other channels available on the gateway and even adjust the advanced wireless settings of the gateway. Try to move the laptop closer to the first when doing the test for us to check whether the router is capable of providing stable wireless connection even if the laptop is close to it or not. In terms of the dropping packets when doing the ping test, it is possible that although the signal strength is excellent the negotiation between wireless router and the adapter is failing. Getting a request timed out means there is no connection to the router. Hardware error can be a failure with the wireless adapter or the connection to the wireless network already dropped. Getting a destination host unreachable can be due an invalid IP address or the laptop is no longer receiving any IP address from the gateway. Make sure to disable any firewall installed on the computer as well. You may want to try the following steps:

    1. Launch your Internet Explorer 5 or later version or Netscape Navigator 4 or later version. On the Address, Search or URL, type:, then hit Enter or Return. A login screen will appear. Type admin for the password and username then hit “Okâ€.
    2. Click on the wireless tab and check for the SSID. If it is still set to Linksys, change it to your name or any name you want to call the wireless network.
    3. Change the channel on the router. You can try other channels like 11, 1 or 9 then save the settings.
    4. Click on the Advanced Wireless Settings sub-tab.
    Set the following:
    “RTS Threshold†– 2304
    “Fragmentation Threshold†– 2304
    “Beacon Interval†– 50
    5. After adjusting the “Advanced Wireless Settings†as prescribed above, click on the Save Settings or Apply button.

    You can also upgrade the firmware just incase you will get the same results after performing the above steps. To upgrade the firmware:

    1. You can download the firmware from www.linksys.com/international.
    2. Select your country then hit the next button.
    3. Click on the Support tab> Downloads
    4. Select the model number of the Linksys device then click on downloads for this product.
    5. Click on Firmware and save the file on the computer.
    6. Open the web-based utility of the router by accessing
    7. Click on the Administration tab > Firmware Upgrade sub-tab.
    8. Browse for the firmware file (normally code.bin) then hit open or upgrade.

    Note: You need to reset the device after the firmware upgrade.

    To reset the device:

    1. Press and hold the reset button for 10 seconds and then let it go.
    2. Unplug the power adapter for 10 seconds then plug it back in.

    I’ll be glad if this helps. Thank you.

    If you have further questions, you may visit our knowledge base at www.linksys.com/kb or email us at support@linksys.com so that we may further assist you.
  16. Advis

    Advis Network Guru Member

    Practically the same what they sent to me :grin:. Didn't help me mcuh though.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice