"Wireless Ethernet Bridge" mode does not work

Discussion in 'Tomato Firmware' started by BastiM, Oct 14, 2009.

  1. BastiM

    BastiM Addicted to LI Member

    Hi guys,
    i have a WRT54G (lets call it "router_1", running Tomato 1.23) and a brandnew WRT54GL ("router_2", running Tomato 1.25).

    I've been using "router_1 "for over one year without any problems as normal router.
    Now, i want to connect my satellite receiver and my xbox to the Network, using "router_2" as wireless ethernet bridge.
    So connected my macbook to the the brandnew WRT54GL by cable and flashed it with Tomato 1.25, set the mode to "wireless ethernet bridge" and set the configuration according to the settings on router_1.

    But it just wont work. Yesterday, i tried 4 hours, but no success.

    Here are my settings on both devices:

    DHCP on

    Mode: Access point
    "g only"
    SSID Name: "default"
    Channel 11
    Security: I tried both WEP and WPA2_Persoanal+TKIP


    Mode: Wireless Ethernet Bridge
    SSID: default
    g only
    Channel 11
    Security: as above...

    In the device-list on both routers, i cannot see the other one.
    The wireless site-survey on "router_2" shows my network "default" with good signal strength.
    From the macbook (connected to the bridge), i neither can ping the other part of the network, nor will i get any ip by dhcp.

    Actually, i am quite experienced with routers and network things, but i have no idea what i could be doing wrong.

    any help is welcome.


  2. Engineer

    Engineer Network Guru Member

    I'm not home right now so I cannot check all of my settings but I just set up (over the weekend) something similar but used Tomato 1.23 on both. I set both Gateway and DNS to on the bridge and all is working fine (WPA/WPA2 AES). Not sure if there are any incompatabilities between 1.23 and 1.25.

    Did you do a NVRAM clear after flashing with 1.25?
  3. BastiM

    BastiM Addicted to LI Member

    no, i did not do a NVRAM clear. (Why) Should I?
    And thanks for you reply, i will try those settings when i am at home.
  4. TexasFlood

    TexasFlood Network Guru Member

    According to the Tomato FAQ, "If you upgraded from another firmware, a complete reset is recommended. Go to Administration/Configuration and select "Erase all NVRAM..." after installing Tomato."
  5. gawd0wns

    gawd0wns Network Guru Member

    I wrote a small howto on this, perhaps it will help you:


    All in all, I think your config is ok. I would personally change the SSID to something different, and use AES over WEP and TKIP. Also, you can leave the Static DNS box on router 2 blank.

    From my experience, using two different versions of Tomato can sometimes cause problems. If possible, I would recommend you flash both routers with the same version (1.25).
  6. ifican

    ifican Network Guru Member

    First off and this is not intended to slam anyone because there is a time and place for it, but it drives me absolutely crazy when the first T/Sing step that gets recommended is clear nvram. It is becoming far to common place for my tastes.

    Now to the issue, if it were me i would run the second router as a "wireless client" let it pull dhcp on the wan link from the first router. If you have a networking back ground managing double nat wont be an issue and the segmentation it gives you is alot more flexible in my opinion. Just make sure your internal network hanging off the second router is different from the first and you'll be all set.
  7. Engineer

    Engineer Network Guru Member

    So you think going from a stock firmware to any version of Tomato without clearing NVRAM is NEVER an issue? Fine, I will make sure not to offend you in any way by trying to help someone by asking the simple question of NVRAM being cleared (even though it is recommended and was not done by the OP). No wonder people give up trying to help others on the net...too many asses.

    To the OP: Good luck and hope you were not offended by my asking if you had cleared NVRAM after installing Tomato over your stock firmware.
  8. TexasFlood

    TexasFlood Network Guru Member

    My two cents. This past week I recommended clearing NVRAM as part of some advice on troubleshooting another issue posted elsewhere. He initially took part of my advice (but not the clearing NVRAM part) and resolved part of the issue but it wasn't fully resolved. He asked for more help but the issue was just weird and getting hard to help him. Then all of a sudden he posted that he'd cleared NVRAM and the issue was solved, it wasn't the only issue but was definitely an issue. Doesn't take a whole lot of experiences like that, and I've had more than a few both 1st and 2nd hand, to convince me that clearing NVRAM, at least when switching builds or doing a major upgrade, should be considered a basic troubleshooting step to be done before potentially wasting a lot of time running down red herrings.
  9. BastiM

    BastiM Addicted to LI Member

    ok, i upgraded my router_1 to tomato 1.25, then i did a nvram reset on both devices.
    Now, i can see my macbook and router_2 in the devicelist of router_1, and i can see router_1 in the devicelist of router_2. So far so good, but i cannot access the other part of the network. Neither can i ping to router_1 from router_2 nor the other way round.

    Here are screenshots of my config. Actually, i don't have any clue what to do next...

    Attached Files:

  10. gawd0wns

    gawd0wns Network Guru Member

    Unless there is another wifi network named default in your area, I don't see why your config shouldn't work. I don't know what else to tell you. I never ran my bridge with TKIP, but there is no reason why it shouldn't work.

    Make sure to refresh your network settings on any computers by repairing/disabling and re-enabling your devices after making the changes.
  11. dvaskelis

    dvaskelis Network Guru Member

    See if it works without security first just to be sure it's not the wireless configuration.

    WET (Wireless EThernet bridge) mode definitely doesn't support WPA2, but I ran a similar setup with the AP in WPA/WPA2 (AES only) mode and the WET in WPA (AES only) mode for several years without issues.
  12. TexasFlood

    TexasFlood Network Guru Member

    I don't know about WET but for WDS WPA PSK w/ AES has been stable for me, despite some minor issues on initially establishing the link between old & new drivers, I'm convinced it's the best choice. TKIP was not as stable for me. Might be the same, not sure, but worth a try.
  13. ifican

    ifican Network Guru Member

    The whole point of starting my remark was simply to make sure no one took it personal. To many people do, i tried. And as stated there is a time and place for nvram clear but i will make the same remark not every time. Early on i purposely did flash after flash after flash, going from dd-wrt circusly configured with options not supported in tomato, to thibor many many times. Trying to do my part to best figure out when clearing nvrarm was truly warranted. In the hundreds of flashes i have done over the years i have only ever had to do it twice. Is everyone going to have the same results? Nope but i do find more times then not its not a hosed up nvram. Is it sometime, sure but collectively from everyone that has flashed and not cleared nvram how many have had to go back and clear it to make it work? Now to helping folks, i spend way more personal time helping folks here than do many of you who are pissed at me right now. The problem is you dont see any of that because its offline. I usually take it offline when i need info from them that could otherwise compromise their networks. But thats all mute because those of you that are pissed from my comments could care less and are still going to be pissed. I will leave you with this, i cannot be held responsible for your feelings as harsh as that sounds but its true. Wasnt intended at anyone in particular, anyone feel free to PM me any comments you have directed towards me so we dont hose up this thread, I will graciously answer all of them.
  14. Cide

    Cide Addicted to LI Member

    What Luck! I ran into this post today, and it seems we are having a very similar, or identical issue! Have we hit a hardware limitation here? It's not often I see people wanting to do this kind of setup.

    Please read my thread, all participants; and advise accordingly!

    Thank you all so much,
    I hope to assist in the resolution of this issue, and others to come!


    Nigel Kristian McLeod
    IT Administrator
  15. BastiM

    BastiM Addicted to LI Member

    The last thing i did yesterday was to flash dd-wrt to my router_2. But i ran into the same problem. When i setup the bridge, i can see the other router from both webinterfaces / devicelists, but i cannot ping or do anything else.
    So i start thinking that router_1 might be the problem... it kind of wont let router_2 enter the network.
    Later, i will first try disabling wireless security, and if that doesn't help, i try switching the routers... so router_2 will become Access Point and router_1 will become Ethernet Bridge.
  16. TexasFlood

    TexasFlood Network Guru Member

    I just configured a pair of routers exactly as you listed and near as I can tell everything worked fine with both TKIP and AES encryption. I could connect to router 1 wirelessly and access router 2.
  17. BastiM

    BastiM Addicted to LI Member

    It works!
    I just swapped my 2 routers, and now everything is fine.
    I just experienced one strange thing... As said before, i connected my macbook by cable to router_2... after setting up the configuration of router_2, i hade to change the IP of my macbook, otherwise i would not be able to get any connection. This is reproducable.. changing e.g. from to *.0.67 is needed. No idea why....

    I also tested this with my desktop PC.. same thing.. after setting up router_2, i have to change my local ip to get connections...

    Well, thanks to everyone that tried to help me.

    c u

  18. TexasFlood

    TexasFlood Network Guru Member

    You could try troubleshooting it if you care. If it's working then you might not care. Maybe try a traceroute to see how far it gets. You might check to be sure that software firewalls aren't blocking traffic.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice