Wireless having issues on RT-N16

Discussion in 'Tomato Firmware' started by m0ngr31, Jan 26, 2013.

  1. m0ngr31

    m0ngr31 Serious Server Member

    So I've been having this problem for the last month or so... And I've tried various firmwares to try and figure out the solution, but so far no luck. I'm on the newest Shibby AIO build right now.

    My router is only letting 1 client connect over wireless. The others will technically connect (grab an IP and everything), but they won't pass any traffic at all. Anything ran over ethernet runs great with no problem. If I try and connect more than say 15-20 feet from the router it won't pass traffic (says I have perfect signal though).

    Maybe the chip in my router is going out? I've tried to use inSSIDer to find any interference, but I'm not seeing anything that could cause the level of problems I'm having. There are only a few APs visible from my house. Any suggestions?
  2. koitsu

    koitsu Network Guru Member

    Start by providing these details:

    1. What country you live in,

    2. All of your wireless configuration details -- I'm talking about all the settings on Basic -> Network under the Wireless section, and anything you've adjusted/changed under Advanced -> Wireless,

    3. If you did a full/thorough NVRAM erase after upgrading to Tomato/TomatoUSB, as well as doing that every subsequent time if you upgraded between Tomato/TomatoUSB versions (e.g. going from 1.0 to 1.0.1, etc.),

    4. How many APs are "visible from your house", and how you determined this, and over what period of time you collected this information -- did you use Tools -> Wireless Survey? If so did you set up the refresh interval (say every 2 seconds) and let it run for about 15 minutes? The total number of APs seen is at the bottom; that would be useful,

    5. Did you make repeated use the Scan button under Basic -> Network's Wireless section to get an idea of what channels had the most APs in use and pick a channel (the permitted channels vary per country, i.e. in the US you're supposed to use 1, 6, or 11) that wasn't heavily used?

    6. Does rebooting the router help? Does power-cycling the router help?

    7. Did you make sure the antennas are all screwed on and not loose in any way?

    There is always the chance you got a bunk RT-N16 -- it happens with any electronic device today -- but start with the above.
  3. adlerfra

    adlerfra LI Guru Member

    m0ngr31: It would help if you could post a screenshot of your Basic/Network settings.

    In the meantime, here are some troubleshooting ideas.

    (1) Check that your DHCP range is sufficient to cover all your devices.To rule/in out DHCP as a problem, you can set static addresses on your wireless clients.
    (2) Make sure that the wireless network mode, SSID, Security , Encryption. and Shared Key settings on your wireless clients match those set in the RT-N16.
    (3) Temporarily set Security in the router to Disabled and see if the clients can connect. If they can then there is a problem with the security settings on the clients.
  4. m0ngr31

    m0ngr31 Serious Server Member

    1. I live in the USA.

    3. I did a full NVRAM erase after upgrade last night, but hadn't during previous upgrades.
    4. Only 2. I ran inSSIDer for a while and walked around my house with my laptop. (I like on the edge of town)
    5. No, I've had it on automatic channel select a few times, but it doesn't seem to help.
    6. No, it has the same problem after rebooting.
    7. All antennas look good to me.

    I've had the router for maybe 2 years now, so maybe it's just dying?
  5. adlerfra

    adlerfra LI Guru Member

    One more thought. Change channel width to 20 MHz and see if any difference.
  6. fubdap

    fubdap LI Guru Member

    Is that a valid IP address for a router -
  7. Engineer

    Engineer Network Guru Member

    Yes, it's 1 of 3 private blocks with the others being 192.168 and 10.00 spaces.
  8. m0ngr31

    m0ngr31 Serious Server Member

    Same problem :\

    I ended up just plugging in one of my APs I had kicking around and it's been running fine. So maybe I'll just roll with that config until I save enough to get a new Tomato compatible router.
  9. kthaddock

    kthaddock Network Guru Member

    IANA-reserved private IPv4 network ranges    Start    End    No. of addresses
    24-bit block (/8 prefix, 1 × A)    16777216
    20-bit block (/12 prefix, 16 × B)    1048576
    16-bit block (/16 prefix, 256 × C)    65536
  10. koitsu

    koitsu Network Guru Member

    1. I concur with adlerfra -- please change to 20MHz. This has to do with spectrum usage, although if you truly don't have anyone else around you, 40MHz might be fine. No guarantees this will work with all other wifi radios (on other devices) however.

    2. Please also pick a protocol (if you can) rather than "Auto". It's one extra thing to narrow down.

    3. Do not use "Auto" for channel selection; instead pick a channel (if in the US, 1, 6, or 11).

    4. What about Advanced -> Wireless ? Did you adjust anything in there? If so, what?

    Finally, I need some clarification on your original statement. Quoting:

    I could interpret this two ways: a) you let 1 client connect, and when that client connect traffic does not work, b) you let 1 client connect and it works fine, but when additional clients connect traffic (for them) ceases to work.
  11. m0ngr31

    m0ngr31 Serious Server Member

    I get the same problems with 20MHz. So I changed to the G-only, and didn't see a difference. I also don't have anything other than the default settings in Advanced wireless page.

    And in response to your last question. It seems that 1 person can work perfectly within about 15ft of the router. Any farther and it'll start dropping packets like mad. If more than one person is connected, the extra person will not be able to ping anything, it does get an IP address though.
  12. koitsu

    koitsu Network Guru Member

    The number of people connected to the router should not play a role with regards to this problem.

    What exact brands of wireless devices are you trying to connect to the router with? Please list them all off, and if they're workstations/laptops, please list off their wireless NIC models and driver versions. You would be surprised how common vendor incompatibilities are. If you can get access to a different model/brand of product, try that first. Also try removing the encryption as a test, and any kind of MAC filtering you're doing too -- sometimes that causes all sorts of messy madness.

    And sure, it's possible the unit you have is bunk or the physical internal wiring for the antennas is busted. If you want to RMA it, give that a shot. Or you might do something like buy a new unit from Amazon, try that out, and if it doesn't solve your problem send it back to Amazon as an "accidental purchase" (you'll need to pay return shipping) -- this tends to be faster than an RMA. If you have the same problem once you get the replacement, then you're going to need someone to physically come out with a network spectrum analyser (this is not the same thing as inSSIDer) and look for noise.

    Below is a thread for a slightly different (but sounds familiar) issue which you can read as well -- read the posts from myself, Monk E. Boy, and Toastman.

  13. m0ngr31

    m0ngr31 Serious Server Member

    Well I've had it for a good couple of years now with no problems until a little while ago. I have an AP with dd-wrt running now that seems to be running with no problems, so I'll just stick with that until I can afford a new router.
  14. Monk E. Boy

    Monk E. Boy Network Guru Member

    When you say you did a long NVRAM erase, how did you then configure the router? Did you restore the configuration from a file or did you set it up by hand?
  15. m0ngr31

    m0ngr31 Serious Server Member

    I did it by hand this last time.
  16. koitsu

    koitsu Network Guru Member

    You're not overclocking the router, are you? (I'm asking because there is proof here on the forum of that causing massive problems with wireless in some situations)
  17. Monk E. Boy

    Monk E. Boy Network Guru Member

    Well darn, so much for that idea.

    I'm sure you know this already, but... when you restore a config you restore all the NVRAM variables, so there's no point in clearing NVRAM if you're going to restore a config. Since you did it by hand this possibility is ruled out.

    How was the cooling on your router? Did you have anything on top or below the router that would have blocked ventilation?
  18. m0ngr31

    m0ngr31 Serious Server Member

    No, I've never overclocked it.

    No, it's just sitting on a shelf. Nothing blocking it. In fact I put some heatsinks on the chips that were running the hottest after I starting having this problem to see if it'd fix it, but obviously it didn't work!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice