Wireless MAC filter

Discussion in 'HyperWRT Firmware' started by pchronos, Nov 22, 2004.

  1. pchronos

    pchronos Network Guru Member

    Enabling does not allow any wireless adapter to connect. Even the Macs listed in the "permit" list. Must disable MAC filtering to reconnect.
  2. dellsweig

    dellsweig Network Guru Member

    I posted this problem to DSL Reports a couple weeks ago. This is apparently something that was introduced in the Linksys 3.x code tree as when I fell back to Hyperwrt 1.4, this problem did not occur. I have not tried to re-create it in the latest hyperwrt b3 release

    "From www.dslreports.com"

    WRT54G HyperWRT 2.x problem?


    I ran across an interesting, repeatable problem with my WRT54G (hyperWRT2.0b2).

    My normal setup is WEP encryption and MAC filtering set to allow only MACs in my filter list. This has worked fine for months.

    Yesterday, I disabled the MAC filter as I had 2 new machines on my network I needed to update. Once my work was completed, I re-enabled MAC filtering. As soon as the changes were saved, I lost all wireless connections. The only way back was to hard-reset the router, re-connect via defaults and re-load my last saved configuration file.

    If I repeated the steps - the same result - all wireless was blocked. I still had signal - Netstumber showed WEP enabled signal on my SSID but I was unable to connect any clients.

    Has anyone seen anything similar with either the Linksys 3.x.x release or the hyperWRT 2.x release??

    All the correct MAC's were in the MAC list and the boxes checked before I saved the changes. MAC filtering was set to allow only MAC's in the list.

    I have disabled and re-enabled MAC filtering in the past - prior to hyperwrt2.x (Linksys 3.x.x). I did not have this problem before.

    Any ideas??
  3. dellsweig

    dellsweig Network Guru Member

  4. pchronos

    pchronos Network Guru Member

    Thanks for the info Dellsweig,

    I guess we wait for the next version and hope Linksys fixes the bug.
    BTW, the original ( linksys factory installed ) firmware ( 2.07 ) did not have this problem.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice