Wireless problem - wireless computer connected but no IP

Discussion in 'Cisco/Linksys Wireless Routers' started by bokingwen, Oct 5, 2005.

  1. bokingwen

    bokingwen Network Guru Member

    I have the wrt56g v3 with Sveasoft public alchemy-V1.0 firmware. All my computers that connect to the the internet via wirless cannot get a working ip from the router however they are all connected to the the network. In the computer it said wirelss signal is excellent computer is connected to the network but it is limited conection (something like that) and each wireless computer have the non working 169.xxx.xxx.xxx ip address.

    2 PC have the Bullafo 54g PCI NIC
    1 laptop with the buil in Intel wireless

    It works when I turn off all the encryption and boardcast the SSID but this is like leave the front door of my house open and let anyone walk in and out of my house. I test my intenet with a netgear router and everything works fine so I am pretty sure there is something wrong with the linksys router. I tried hard reset the router many times reset it to the factory default setting and nothing works.

    Anyone have any ideas?
  2. howardp6

    howardp6 Network Guru Member

    As for the Laptop, if it has an Intel Proset 2200BG update the driver to the latest generic driver form the Intel website. For all wireless NICs including then Laptop make certain the keys are hexidecimal and all the key lengths are the same and the key you typed in is exactly the same. If you have installed the WPA2 hotifx from Microsoft unintall it is causes problems with WEP encryption. Do not use any paraphase key generators, since key generators from deferent manufacturers produce different keys.
  3. bokingwen

    bokingwen Network Guru Member

    Thanks for the reply. I am 100% sure that I have type the web key correctly becuase I have been using the same wep key before and it works fine. At one point I was able to connect but the connection drop or I should said the internet connection droped after 10 minutes. When I switch to the Netgear I use the same wep key and they are worked fine so I don't think the problem is the wep key.

    Actually I just want to confirm that my wrt54g have gone "south" before I buy a replacement (probably a WRT54GS from buy.com). Other than the wireless not working everything else is working fine so I guess tough luck for me! :(
  4. danielhaden

    danielhaden Network Guru Member

    That's a V3?

    I'd give it a through reset (power cable out, hold down button for 30 seconds, keep holding down button, plug power back in, still holding down button, 15 to 30 seconds more)

    And next. . .

    I'd find and load Rupan's HyperWRT onto the router. Reset it throughly after two minutes, and test.

    If you want Speedbooster, just hold your router up to the light and look through the vent. If you see that 25% of the vent is now a lit up square because the motherboard is in the shape of an "L" then you do have a speedbooster model.

    DD-WRT Basic, Generic, V23 has speedbooster, and if that is too complicated, you can now load Thibor's HyperWRT with the latest security, speedbooster, and WDS support.

    However, if no square of light comes through the vents when you hold it up to a light, DD-WRT is still a good choice if you need WDS. If your needs are just a good wireless router with long range, Rupan's HyperWRT is the way to go and it certainly has more speed than Svesoft.

    After loading any firmware, before putting the router into service, give it one more through hardware reset.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice