Wireless setup using Tomato w/Linksys WRT54GL's

Discussion in 'Tomato Firmware' started by Gene, Dec 2, 2008.

  1. Gene

    Gene Addicted to LI Member

    After doing some research on line, which is what brought me here to this forum, I believe Tomato firmware is my best option considering my novice experience with networking.

    In explanation, here is what I am trying to accomplish...

    I have 4 - Linksys WRT54GL routers on hand and I have offered to use them to span a wireless network throughout my congregations church and rectory (all one large building).

    I plan to use router #1 in the office hardwired to the cable modem, which is centrally located, and the other three spanned throughout the building in separate directions, within range of router #1, to give greater coverage.

    I have already successfully flashed one router with Tomato ver 1.22, but am holding off on the rest until I come across a good tutorial and am more rehearsed in what I am attempting here.

    I am still in the initial steps and am doing so here at home first before bringing everything on site. My own network here at home operates off of the same router as well, but is presently running under Linksys firmware ver. 4.30.7.

    Now, it is my understanding that only the satellite routers need to be flashed with Tomato, and the main one connected directly to the modem can remain default, but perhaps I am wrong, or even if not, maybe it would make more sense to have ALL the routers running the same firmware? I have yet to flash my own for reasons of not being familiar with Tomato yet and not wanting to lose my own connection entirely.

    I guess my first, and main question is....can anyone direct me to a detailed tutorial regarding that which I am trying to accomplish, either here on this forum or elsewhere on the www? If I am in the wrong area or completely out of line by posting within, please respond stating as such and I will simply try and seek guidance elsewhere, but from what I have read thus far this forum would be my best bet in obtaining the guidance I seek.

    Thanks, Gene
  2. fyellin

    fyellin LI Guru Member

  3. Gene

    Gene Addicted to LI Member

    TY so much for the reply.

    OK, so I flashed my own router with Tomato as well and all went well. I then followed the link you posted and proceeded to configure both routers as the example suggests and now have a connection on the remote computer, but I now have a couple more of questions if I may...

    Under SSID it says to use the same SSID for each router. But by doing so, how am I to know which router the remote computer is now drawing bandwidth from being both router signals are in range here on my bench?

    To put it another way, now that I have both routers configured as recommended I only see one router under the wireless networks, (as apposed to two different ones such as I did before completing configuration), yet I am able to log into both routers Tomato configurations within the same browser using each of their own IP's in separate tabs. How can I determine which router I am connected to with the remote computer? Am I making sense?

    And another question...

    How I hoped to station the routers was..

    #1 - somewhat centrally located (hardwired to the modem)

    #2 to the east (within range of #1)

    #3 to the north (again within range of #1)

    And #4 further north (drawing its signal from #3)

    Is this feasible? and if so, am I to assume that I would have to enter #3's MAC address in #4's configuration and visa versa to make it work?

    Sorry if these are elementary questions, but considering last night was when I first became aware that there were 3rd party firmwares for routers I think I am doing pretty well :redface:
  4. Gene

    Gene Addicted to LI Member

    OK, what I have now is this...

    I have successfully flashed all four routers with Tomato.

    I am temporarily using my router, (#1) and modem as the Host, (the actual router being on site)

    #1's WAN is set for DHCP with the default IP address.

    The Wireless mod is set to Access Point + WDS on all routers

    The SSID are all the same on each router

    I am presently running under WEP encryption and the settings are set the same on all routers

    Under WDS, the MAC addresses for each #2 #3 and #4 are "linked only with" #1

    #1's MAC address is linked with all the other three routers, each entered separately in its own box

    I am able to access each of the routers firmware through any one of the three computers I have running on my home network. Two of those are wireless, but again my office is so small that I don't know which router either computer is communicating with, so I am not thoroughly convinced I've even succeeded. For all I know they are feeding off from my host router and the other three are doing nothing. Is there any way to determine this?

    And am I missing anything other than what I mentioned above :confused:
  5. Gene

    Gene Addicted to LI Member

    Hey Zzz,

    I was just coming in to post regarding this when I saw your reply.

    I understand what you're saying and it makes since. I have labeled each router with its IP and MAC Address along with its given name. And I understood that I was communication with each router. What I wanted to confirm was that I was able to access the NET through them.

    The problem I was having was that all the routers SSID were the same, as I understood it had to be by reading the instructions provided, and I couldn't get around that in my head. So, as a test I edited each routers SSID following it with a number resulting in my viewing four separate wireless connections and having to enter the WEP encryption for each (which is the same BTW and this makes me wonder it they need to be), but anyway, I am now able to traffic through each router so I must have done something right :)

    Thanks for the reply.

    I still have a few things to work out, but I am making good progress.
  6. Gene

    Gene Addicted to LI Member

    Hello Again,

    With the holidays past us I am once again directing my attention towards helping out my congregation by configuring a wireless signal throughout our church.
    I have made some good headway, but am still having some issues at the far end of the network and was hoping that I could get some further input here in order to help shed some light for me.

    Again, I am working with four WRT54GL routers, all which I successfully unbricked and reflashed with Tomato 1.22.

    There are no computers hooked directly to the router, everything is wireless, and all computers are running Windows XP.

    Router #1 is hardwired to the cable modem in the office

    Router #2 has been placed in the library in order to send a signal to the sanctuary’s computer, as well as to router #3 and then ultimately router #4.

    Router #3 is in a closet down the hallway between the library and the rec hall in an attempt to repeat the signal to router #4.

    And lastly router #4 is in the rec hall.

    Now I will try and explain as clear as I can how I have things configured….

    Router #1


    Type – DHCP
    MTU – Default 1500


    Router IP Address –
    Subnet Mask –
    Static DNS –

    DHCP Server - IP Range – to



    MAC Address – 00:00:00:00:00:10 (example)

    Wireless Mode – Access Point + WDS

    SSID - office

    Security - WEP (all four routers are set identically in this respect)

    WDS - Link With…

    MAC Address – 00:00:00:00:00:20

    Router #2

    WAN/Internet - Disabled


    Router IP Address –
    Subnet Mask –
    Default Gateway –
    Static DNS -

    DHCP Server - unchecked



    MAC Address – 00:00:00:00:00:20 (example)

    Wireless Mode – Access Point + WDS

    SSID – Library (set temporarily so I know which router I am communicating with)

    WEP is enabled

    WDS – Link With

    MAC Address – 00:00:00:00:00:10

    Router #3

    WAN/Internet - Disabled


    Router IP Address –
    Subnet Mask –
    Default Gateway –
    Static DNS -

    DHCP Server - unchecked



    MAC Address – 00:00:00:00:00:30 (example)

    Wireless Mode – Access Point + WDS

    SSID – Closet (temporary)

    WEP is enabled

    WDS – Link With

    MAC Address – 00:00:00:00:00:20

    Router #4

    WAN/Internet - Disabled


    Router IP Address –
    Subnet Mask –
    Default Gateway –
    Static DNS -

    DHCP Server - unchecked



    MAC Address – 00:00:00:00:00:40 (example)

    Wireless Mode – Access Point + WDS

    SSID – Rec Hall (temporary)

    WEP is enabled

    WDS – Link With

    MAC Address – 00:00:00:00:00:30

    (once I confirm all routers can achieve a connection to the internet I plan to rename the SSID so that they are all the same on each router).

    With the above configuration I am able to view and connect to all four routers via XP’s wireless connections from my laptop, and can even access every routers set up page through each wireless connection.

    What I cannot do is gain access to the internet from routers #3 and #4, but I can from routers #1 and #2.

    As such, my assumption is I am missing something simple between routers #2 and #3, as well as between #3 and #4, but what?
    I am inclined to think it has to do with the Default Gateway and Static DNS IP addresses on #3 and #4, but perhaps I am mistaken.

    This started out as a favor for my congregation, but is quickly turning out to be a headache…lol

    Any help would be greatly appreciated to solidify this set up.

    Perhaps this question would be better suited for "Network Issues"? And if so, I would appreciate it if an administrator could please be so kind as to move it on over to that section :)
  7. astehn

    astehn LI Guru Member


    A few thoughts:

    1) To simplify troubleshooting, you really should temporarily turn off all wireless security, as a slight misconfiguration can be the culprit. Then when you have everything running perfectly, you can easily re-enable it. WEP should work, though I only have personal experience with running WPA-AES, which was very stable. Given the security problems with WEP, you should seriously consider going with WPA.

    2) As far as I know, the SSIDs have to be the same for WPS to work. I could be wrong, but it will probably be simplest if you minimize your divergence from the recommended configuration. As for the issue of not knowing which router you are connected to, this can be determined by logging into each router until you see your computer listed in "Device List"--that'd be the one. (I don't have WPS running anymore, but I also believe you can also verify the WPS links in "Device List", which may help you troubleshoot the internet connection on Routers 3 and 4)

    3) Bear in mind that throughput gets cut in half each time you re-broadcast the signal. So for your configuration, anyone connected to Router 1 will have full throughput; anyone connected to Router 2 or 3 will effectively operate at 1/2 speed; and anyone connected to Router 4 will operate at 1/4 speed. Of course, the link will still probably be faster than your internet connection speed--and if you can't run ethernet cable between the routers, then you don't really have much choice in the matter.
  8. gptro81

    gptro81 Addicted to LI Member

    Try to do it this way and disable STP on all routers. I have a setup of 26 routers in wds and they work just fine.

    Attached Files:

  9. Gene

    Gene Addicted to LI Member

    Hi astehn and TY for the reply.

    I could try option #1. I agree it is one less thing to consider while troubleshooting.

    As for WPA, we live in a very rural area and as such I have never felt the need for, or even tried anything beyond WEP, but I am open to the idea, more intimidated by the unknown than anything else I suppose :redface:

    In regards to the first part of #2, if this were the case, would I be able to connect to the libraries router and gain access to the internet via it?

    Referring to the second part of #2, I see now that in the "device list", (thank you for pointing this out), the routers are listed. I also can see that the main router has a 99 quality where as the next router in line has a 49 quality. I assume this is what you refer to in #3? And yes, due to the size and construction of the building is is not feasible to run CAT5 throughout unfortunately :frown:

    As one can probably surmise by my questions, my newbie forum title suits me well in regards to networking, but we must start somewhere, right?

    Thanks again for the reply, I shall try disabling the security option and also look into WPA
  10. Gene

    Gene Addicted to LI Member

    Hi gptro81,

    With exception to router 2 being on the opposite side of router 1 this is how I have things laid out and unfortunately it has to remain as such due to where the cable enters the building and where the signal needs to span.

    I do see how your example would allow for a stronger signal throughout though...just not feasible in my situation, unless I am missing something.

    And what is STP? Sorry if I am being obtuse :redface:

    Thank you for your reply.
  11. gptro81

    gptro81 Addicted to LI Member

    Show me an image of your setup to guide you, you can learn about STP here http://en.wikipedia.org/wiki/Spanning_tree_protocol , basically it prevents loops on a wds network but in your case you dont need it. It is disable by default on tomato. (English is my second lenguage). But I will try to help you.
  12. Gene

    Gene Addicted to LI Member

    Regarding STP, I see under Advanced> Routing> there is a Spanning-Tree Protocol...is this what you refer to? Next to it the box is unchecked on all routers :confused:

    OK allow me some time to lay out a diagram.....
  13. Gene

    Gene Addicted to LI Member

    I'm hoping this is what you are asking for, pretty crude but it works...

  14. gptro81

    gptro81 Addicted to LI Member

    That works, now does Router 3 sees router 1? if it does then make router 3 connect to router 1 and 4, and router 4 connect to router 3 only.
  15. Gene

    Gene Addicted to LI Member

    Router 3 is not in range of route 1.

    I was trying to get router 3 to obtain a signal from router 2, and router 4 from router 3...if that makes sense.

    As I stated above. I am able to view and log into router 4 via any one of the routers wireless signals, but it ends there. I cannot connect to the internet through router 3 or 4.
  16. gptro81

    gptro81 Addicted to LI Member

    Are you connecting using DHCP or Static IP from your computer? It is strange. Because if you get closer to router 4 and connect to it from the computer using DHCP and if you dont get an IP then router 4 is not connecting to the main router. You can connect router 2 to router 1 and router 3, router 4 with router 3 only.

    Attached Files:

  17. Gene

    Gene Addicted to LI Member

    Yes, your most recent diagram is what I am trying to obtain. I am connecting using DHCP.

    If I am near router 4 and I choose to connect to it rather than any other router, I am able to log into router 1's setup. This tells me that router 4 sees router 1, 2,and 3. Wouldn't you think?
  18. gptro81

    gptro81 Addicted to LI Member

    Yes if you can connect to router 4 and obtain an IP that means router 4 is talking to main router. But are you sure you are connecting to router 4 and not any other router, go to devices list under router 4 to make sure you are connected to it.
  19. Gene

    Gene Addicted to LI Member

    Which leaves me with my main question...why can I not connect to the internet through router 4 or 3 for that matter? :confused:
  20. gptro81

    gptro81 Addicted to LI Member

    Let me show you one of my setups.


    As you can see I have some wireless daisy chain routers. And it works just fine. Something in your setup must be wrong?
  21. Gene

    Gene Addicted to LI Member

    I concur, which is why I posted everything I can think of above. Hopefully by viewing all the info I posted in the first post today someone can see what I am doing wrong.
  22. astehn

    astehn LI Guru Member

    Looking at your setup again, I can't tell what's wrong, though the IP addresses you have assigned to Routers 2-4 strike me as strange. Perhaps it is causing an IP conflict? Why not simply make it like this:

    Router 1: (this is already the case)
    Router 2:
    Router 3:
    Router 4:

    While you're at it, you could make double sure that routers 2-4 all have DHCP disabled and that they are configured with the following values:

    Subnet Mask –
    Default Gateway –
    Static DNS -

    In fact, it might be a great idea to clear the NVRAM for your routers and reconfigure them from scratch, given that you've probably been fiddling so much with settings, especially if you never cleared NVRAM after flashing to Tomato. They're so close to the default setup that it won't take you much extra time, and sometimes a leftover NVRAM setting you can't see can cause mysterious problems. This way you can rule that out. To do it in Tomato, click on "Administration", then "Configuration", then select "Erase all data in NVRAM memory" from the Restore Default Configuration dropdown.

    If you've cleared NVRAM, reconfigured all things from scratch exactly as described in your posts (and as slightly modified above), temporarily turned off wireless security, all SSIDs are the same, and you can verify all WDS links in the "Device List" of each router, then I honestly don't understand what the problem could be.
  23. Gene

    Gene Addicted to LI Member

    Thank you so much, astehn and gptro81 for your replies.

    astehn, the IPs I used were put in place because when I first set up the network I did so on my workbench here at home and here I have three computers of my own that already were using some of the sequence IP's you mention. As such I ran into conflicts and by changing them this corrected the issue.

    Now as I think I explained back when I first started this thread, the routers were already in place, (positioned exactly as I have them now so I know it worked at one time), having been flashed with OpenWRT (White Russian). But since then the ISP has changed and the person who set it up originally is no longer around, which is why I offered to take a crack at repairing it in the first place as a favor to the congregation.

    Prior to this I did not even know there was such a thing as a 3rd party firmware for routers, and upon studying the subject I learned that once the password has been set for OpenWRT and it has been lost, the only way to get back in is to use the failsafe mode. During my self training mission I discovered Tomato and decided that this would probably be easier for me to learn yet still suit our needs, so once I was able to access the routers again I just flashed them with Tomato 1.22 as the new firmware instead (I even flashed my own router at home with it replacing the Linksys firmware so that I could work with the setup here at home first).

    To touch upon your suggestion even further...the IP's of these routers were
    not even close to default when I started working with them. Instead they were something like and not knowing why these were put into place and only being familiar with the default range I went back to this. Does it matter? Would I be better off avoiding any conflicts and even be more secure were I to change the range all together such as the previous tech did?

    To answer your second inquiry, I assumed that by reflashing the routers, this would have left me with a fresh NVRAM...am I wrong in assuming so?

    Edited to say....when I first set up the network here at home I had entered all three of the satellite routers MAC addresses into router 1's configuration and then in each of the satellite routers I entered router 1's MAC address in them, as well as the MAC address of the router I want them to ultimately repeat from. By doing so I was able to gain access to the NET from either. Once this was working I believe, (this was over a month ago so I can't quite remember), I removed the MAC address of router 1 from the satellite routers so that they were daisy chained rather than all of them communication with router 1 and had it working as well.

    Regardless, I now have routers 3 and 4 here at home and have them set up with my own router and am having the same issue. I can access all three routers from any computer regardless of which wireless signal I am connected to, but I can only access the net from my own router as well as the second router in the link, but not the third :confused:

    Did I explain that all clearly?...lol
  24. Gene

    Gene Addicted to LI Member

    And yes, routers 2,3 and 4 all have DHCP disabled, and the Subnet Mask, Default Gateway,and Static DNS are all set as you suggest
  25. astehn

    astehn LI Guru Member

    Which of these ranges you use is arbitrary--there is no difference in security or conflicts. I'd suggest you just stick with the default 192.168.1.x range.

    Unfortunately, this is a wrong assumption. Especially given the fact that these were previously running OpenWRT firmware, I'd say that clearing the NVRAM would be imperative to avoid issues. Many mysterious issues reported on the forum have been resolved by a simple NVRAM clear and re-configure. You've obviously spent a lot of time working on this setup, and we know that it can work, so do yourself a favor and start again--clear the NVRAM of each router and enter the configurations from scratch.
  26. Gene

    Gene Addicted to LI Member

    astehn, I want to once again thank you for your taking the time to help me :wink:

    Despite what I am about to admit, I WILL clear the NVRAM to be on the safe side.

    Now, because of your asking the questions you have I went back and rechecked all the settings and discovered that on "router 4" the DHCP Server box WAS checked (guess I missed that). I noticed this while lining up each router in a separate tabs and then comparing them side by side. Now that I have unchecked this I am able to access the NET from that router. Thank you for your patience.

    But that still leaves me with another question, why was I not able to access the net through router 3, which, to my knowledge was set up correctly (did NOT have the DHCP Sever check)?
  27. Gene

    Gene Addicted to LI Member

    Yet another question I have regarding WEP vs WPA, and I hope I am not becoming annoying, you are being very helpful and I have learned a great deal in this endeavor. Even so, I know it can be a bothersome to some to be asked all these questions.

    I love learning new things, but all of this can be intimidation to one who has never worked with it at this level before, and is experimenting with someone else’s equipment to boot. Yet at the same time I find it all intriguing as well. You might be able to understand.

    Before I dive into it, is setting up WPA as simplistic as setting up WEP? I see there are several choices, i.e. WPA Personal, WPA Enterprise, WPA2, etc., then TKIP, AES, etc. Again, keep in mind that we live in a rather rural area, and that one of the ideas behind setting up this network was so that parishners could access the network via their own computers from time to time from the rec hall, (provided we entrust them with the security code), so we don't want it to be too difficult either.

    Perhaps there is a link you can provide me that would explain all this for a laymen such as myself if you’d rather? I certainly would understand if you felt as such.

    I may as well get this all kicked before I go back on site.
  28. astehn

    astehn LI Guru Member

    I'm glad to hear that you found the culprit for why Router 4 wasn't working. You're almost there! I'm curious to see how it goes after the NVRAM clear and re-config.

    As for your question about the different options for wireless security, take a look at this (especially the last post):

    Also, take a look at this for people's experiences in Tomato with WDS and the various wireless security options:

    WEP will maximize hardware compatibility (and work with WDS), but it really is pretty easy to hack (though this may not be a huge concern in a church building:)). As I see it, you probably want to go with WPA Personal (also called WPA-PSK) and use AES encryption, since this has been reported to be most stable flavor of WPA to use with WDS (as reported in the 2nd link). This would be plenty secure IMHO. WPA2, while better, should probably be ruled out b/c of incompatibility with older hardware and it may not even work with WDS. Bottom line suggestion: Try WPA Personal with AES encryption, and only downgrade to WEP if someone in the church absolutely can't connect even after upgrading their network adapter's drivers. As far as configuring the router, setting up a password with WPA Personal is absolutely no different than setting up a password with WEP. The only difference is the strength and compatability of the protocol.
  29. Gene

    Gene Addicted to LI Member

    astehn, thanks for the links and the suggestions (as well as your patience). I will follow through with clearing the NVRAM shortly, and will also read through the links and implementing the security options I choose to go with and post a follow up once accomplished, hopefully to say all went very well :wink:
  30. Gene

    Gene Addicted to LI Member


    OK I have cleared the NVRAM on both of the routers I have which belong to the church and reconfigured them, just as they were before.

    One router is working just fine and I can access everything (IP address being, but for some reason the other router (IP will not get past limited or no connectivity under wireless. The only way I am able to access it is if I connect directly and disable wireless. And just to be sure I tried changing its IP address and have checked all three of my systems here and none of them are even close to conflicting IP's.

    To confirm that I did everything correctly I cleared the inoperable router AGAIN and started all over with the same results :frown:

    I better mention that this router in question is NOT a WRT54GL, but instead a WRT54G ver 4, but seeing as it was working before I cleared the NVRAM I wouldn't think that would be the reason.

    Another thing worth mentioning is that I have NOT cleared the NVRAM on my own WRT54GL in fear of losing my own connection (I just know you are going to recommend that I do). My router on the other hand has up until last month always ran under Linksys firmware and seems to have been working just fine with these other router all along.

    Any suggestions? We're so close :confused:
  31. astehn

    astehn LI Guru Member

    If configured EXACTLY the same (right after an NVRAM clear), then there is no reason that you should have connectivity with the WRT54GL but not the WRT54G. And I find it unlikely that it would be solved by clearing NVRAM on your personal router (since you've witnessed it communicating effectively with the GL). So you're safe there:)

    Are you disconnecting from the wireless network, and then re-connecting through the WRT54G? I ask because it might be some goofy thing with the way that your computer is or isn't properly getting it's IP through DHCP.

    Is it the exact same problem you've been having--namely, that you can connect to the WRT54G (i.e. obtain a new IP address through the DHCP server on your personal router that the WRT54G is connected to via WDS)?

    Are you seeing the WDS link in "Device List" on the WRT54G?

    Are you positive that you have Access Point + WDS selected on your home router AND the WRT54G?

    You are working WITHOUT any wireless security for testing purposes?

    SSIDs are the same?

    Are you positive that the MAC addresses are listed properly for each router in WDS?

    Have you tried rebooting your home router, waiting 30 seconds, rebooting the WRT54G, and then rebooting the computer you're connecting through?

    Have you arranged browser tabs like you did previously to verify that the settings are exactly the same on 54G as on the 54GL?

    Because like I said, if you've started from scratch and configured the two routers in EXACTLY the same way, I can't think of any reason (barring a hardware problem) that one would work and the other not. Are you able to connect if you plug a cable into the 54G you're having problems with (this would verify that the WDS link is good, but that there's a problem with the AP/wireless function)?

    I know these steps are pretty obvious, but it's almost always something obvious when I find a problem in my own setup:biggrin:
  32. Gene

    Gene Addicted to LI Member

    Yes, you are right, it is almost always something obvious and I have no quarms with you asking the questions you have. After all it was one of them that resolved the issue I had earlier.


    I agree, none the less bearing in mind I am not skipping something, this seems to be the case.

    To eliminate several variables I just cleared the NVRAM on my own router and left it with no security until I resolve the issue at hand.

    I also, for the hell of it I just REFLASHED the WRT54G with Tomato 1.22 and again cleared the NVRAM.

    Did it anyway just to be safe, as mentioned above.

    In order to even access the router once the NVRAM is cleared I HAVE to disable wireless because it defaultly assigns the router with an IP of

    Once in I change the IP to 192.168.1.whatever (doesn't seem to matter)

    set the WAN type to disable

    disable DHCP

    change the wireless mode to Access Point + WDS

    confirm that the signal is the same GHz

    set WDS to Link With... and for the time being enter MY routers MAC address just to get a connection

    and I am still getting No Connectivity on the WRT54G router, yet the WRT54GL works fine when I swap them

    Sorry, I am not sure what you are asking here. If you're asking if it was the same problem I was have pre clearing the NVRAM then no. Prior to I was able to connect to the router where now I can't even do that.

    I AM seeing MY routers MAC Address in the device list of the WRT54G router, with a reading of 99, but only when I am connected via local network on another computer on my bench. Is that explained clearly?



    no but that never mattered before. I name each router differently so that I can see them separately in the wireless connections list and know which I am connected to. Remember, I am working in the same room with all routers and as such this is the easiest way for me to be sure.


    no, but that would have no bearing on whether or not I can obtain connectivity the WRT54G to the other computer via wireless, especially when the WRT54GL does, right?

    Well no but only because I cannot connect to both at the same time and throught either wired or wireless. I will do so next wired with the G and then leave that window open and connect the GL via wireless and confirm

    As stated above, yes

    I realize some of us has a life away from this forum ATM, obviously not me though :rolleyes: so I am quite patient on this end and understanding should you not answer promptly. Its not going anywhere. Thanks again for your time.
  33. gptro81

    gptro81 Addicted to LI Member

    "I AM seeing MY routers MAC Address in the device list of the WRT54G router, with a reading of 99, but only when I am connected via local network on another computer on my bench. Is that explained clearly?"

    This means wrt54g is not establishing a connection with the wrt54gl.
  34. Gene

    Gene Addicted to LI Member

    Hi gptro81,

    for the moment I am only using one router at a time on the secondary computer. Meaning this...

    MY computer has a 54GL hardwired to the modem

    The other two routers I am working on via the secondary computer, but I am only providing power to one at a time (and before you ask, yes I am disconnecting the CAT5 from either router when not in use).

    The 54GL is working flawlessly, actually I am corresponding to you from it as we speak.

    But when I unplug power from the 54GL and plug power into the 54G I get "no connectivity via wireless and can only access it when I disable wirelless and plug in the CAT5 using the local network.

    And astehn, I just confirmed that both the 54G and the 54GL are configured exactly with exception to the WDS MAC addresses they communicate with, which at this point shouldn't matter. I can't even gain access to the 54G via wireless from the secondary system.

    Incidentally, I neglected to enter a Default Gateway or a Static DNS on either router since clearing the NVRAM and yet the GL is working without them. I noticed this was the case for the 54G prior to clearing the NVRAM as well once I realized that the DHCP Server box was checked before on said router and yet it too communicated with all as well :confused:
  35. Gene

    Gene Addicted to LI Member

    One thing I found odd was, even after clearing the NVRAM on all the routers each routers MAC Address remained the same. I would have thought that these would have randomly changed.
  36. astehn

    astehn LI Guru Member

    Some last thoughts before bed:

    Can you confirm that "Router" is selected on the WRT54G in the dropbox under Advanced-->Routing-->Misc-->Mode? The router with the internet connection should have “Gateway†in the dropdown, but all the other routers should have “Router†selected.

    Another silly question: You are sure you are using the Wireless MAC address of both routers in WDS setup (and not the Wired or WAN MAC addresses)? Copy and paste from the “Wireless Interface†box in Tomato under “Advanced†just to make sure you’re getting the value exactly right.

    After triple-checking configurations, I do believe it’s worth rebooting everything in order: 1) Router with internet, 2) WRT54G, 3) computer you’re connecting through.

    Just for kicks: What happens if you select “Automatic/Lazy†in the dropdown box for WDS rather than manually entering MAC addresses? If this does work, it might take a few minutes to sync up (as a well as a reboot of both routers).

    p.s. SSIDs do have to be the same (if you’re using WPA), but apparently not if you aren’t using any security or WEP (just FYI).
  37. gptro81

    gptro81 Addicted to LI Member

    Hi, you said that you cant connect to the wrt54g wirelessly but can connect to it with cable? Must be a hardware problem.
  38. Gene

    Gene Addicted to LI Member

    No it was NOT. It was set to Gateway. I switched it to Router and now I am using it to post this reply :biggrin: Wonder why this would be default for the 54G but not the 54GL?

    Something else odd, and no I am not smoking something, not 5 minutes ago for no reason the 54G connected wireless. Surprised I unplugged it, set it out in the other room and connected the 54GL to try and daisy chain them but when I tried again to connect to the 54G once it was rebooted it was the same old story, no connectivity :confused:

    This is a very legitimate question, but yes I am using the 'wireless' MAC address as apposed to the LAN address.

    Not sure I want to follow through with your other suggestions now that it is working again, for the moment anyways....lol

    Good to know!

    gptro81, I am not yet convinced that you statement is false. You may very well be on to something. I was thinking the same thing about it being bricked. Guess time will tell. I do have a 5th WRT54GL that I cannot seem to unbrick using the same procedure I did for the other four and am assuming that it is bricked.

    Anyway, I will see if things have straighten out now that I made the change in the Advanced-->Routing-->Misc-->Mode option and let you know.

    Thank you again so much for taking the time to help me through all this :thumbup:
  39. Gene

    Gene Addicted to LI Member

    OK, I am now creating this post via the following connection...

    Router 3 - 54G> Router 2 - 54GL> Router 1 - 54GL (mine)> cable modem.

    Problem is the connection slowed to a snails pace wirelessly and now my main system which is connected direct cannot connect to the NET at all. I'm going to reboot everything in the order suggested to see if this resolves the issue.

    BTW, I just checked the 54GL router we have been working with (not mine) and it too was set as Gateway, so I have to assume that the other two routers still at church are set this way as well (well the main one needs to be). Wonder why the 54GL allowed the connection to pass through it being set this way but the 54G did not :confused: and how can I connect to the NET through 3 routers but cannot connect to it through a CAT5 at the first router? Maybe these routers are haunted :rolleyes:
  40. Gene

    Gene Addicted to LI Member

    OK this is getting ridiculous.

    Once I set routers 2 and 3 as suggested in the advanced tab I was only able to gain access to the net through router 3, but not my main computer which is hard wired. Nor could I gain a wireless connection through router 2 (only got 'no connectivity') and MY router was not even visible on the wireless connections list.

    Now that I have disconnected the power to routers 2 and 3 I am again able to gain access to the net from my main computer, WTH?
  41. gptro81

    gptro81 Addicted to LI Member

    Mine are:
    DSL Modem with PPPoE and DHCP server on,>Main WRT54GL with DHCP server on,, using DHCP to connect to Modem>WRT54GL DHCP server off>WRT54GL DHCP server off>WRT54GL DHCP server off.
    All WDS routers are set to a fixed transmission rate of 18 Mbps. All set to the default gateway mode. And about the speed yes in the last chain i can only get about 2600kbps out of my 4000kbps that is connected with cable to the last WRT54GL in the chain.
  42. Gene

    Gene Addicted to LI Member

    LOL, alright. I went back in and corrected the Default Gateway and Static DNS settings on routers 2 and 3, those which I mentioned above I neglected to fill in, then shut everything down and booted. Having done so everything appears to be back up to speed. I can connect to the NET regardless of which wireless connection I am using with no noticeable speed difference.

    I think I'll wait until tomorrow to alter the security settings :rolleyes:
  43. gptro81

    gptro81 Addicted to LI Member

    Nice to hear that.

    Whati s your internet speed and can you max it out on the last WRT54GL?
  44. Gene

    Gene Addicted to LI Member

    Not sure where you are getting you speed test from. Is there an option within the router itself to determine this?

    Using speedtest3, testing from the third router (through the 2nd and ultimately the first) I am obtaining 4700 download and 480 upload. I get the same result from my main system which is hard wired.
  45. Gene

    Gene Addicted to LI Member

    OK, so now that we appear to have that solved (I hope), how can I get this to work from my car.....just kidding :biggrin:

    Bed? you must be in the UK or something, eh?

    I know I've said it multiple times, but thank you both for the help.
  46. gptro81

    gptro81 Addicted to LI Member

    The speed test is from speakeasy.net, and I can get full speed from third router but not from router#4, too many wireless hops!. Cool that your setup is running good now.
  47. astehn

    astehn LI Guru Member

    Yeah, I'm living in Spain for the year (where I set up 5 WRT54GLs to provide internet to our apartment complex--thus my bit of experience with WDS before we ran Cat5 cable).

    At any rate, congratulations! It was very nice of you to take this project on for your church:)
  48. RonWessels

    RonWessels Network Guru Member

    Congratulations on getting your setup to work.

    One comment I will make about WEP vs WPA (or WPA2). It has already been mentioned that WPA/WPA2 is much more secure than WEP. What hasn't been mentioned is that the WEP key is a hexadecimal number, whereas the WPA/WPA2 key is an alphanumeric string. In other words, if you use WPA or WPA2, you can set your wireless password to something that is memorable and easy to tell people, rather than having to give them a printed sheet of paper with a WEP hex key.

    Oh, and if you use WPA and/or WPA2, make sure you use AES as well. It is done in hardware, rather than TKIP which is done in software, and will therefore be faster.

    Personally, I use the WPA/WPA2 AES setting.
  49. Gene

    Gene Addicted to LI Member

    Good info Ron, TY. Ill be setting things up tomorrow so I'll return to let y'all know how it went :)
  50. Gene

    Gene Addicted to LI Member

    Went in today to finish setting up the network with the new ammunition and it works like a charm :smile: We are having one little issue though and I wanted to iron it out before I set the SSID to be the same on all the routers.

    The computer in the main office, which is like 20 ft from the router in that room repeatedly wants to switch over to the router in the library, which is more like 100 ft away, in turn having sporadic internet connection issues. This to me doesn't make much sense. All we need to do is manually redirect it back to the office router, but then an hour later its right back to the library again.

    Any idea as to why it would prone to keep doing this?
  51. astehn

    astehn LI Guru Member

    Happy to see that everything "works like a charm." Of course, there's always SOMETHING:)

    That is a bit puzzling. It works fine, then, when you force the office computer to connect to the office router before switching SSID? Is there any obvious source of radio interference in the office? Or something directly blocking the line of sight between the computer and router? Perhaps the router 100ft away has it's wireless radio power set higher than the one in the office? (You've probably read this elsewhere already, but you can safely set the radio power to 84mW without running into any problems if you need the extra wireless coverage--the default is half that at 42mW).

    I take it you've already tried updating to the most recent driver of whatever network card is on the main office computer? Also, you could check to see if the card manufacturer provides a utility that would force the card to lock on to the correct router using its MAC address. The built-in Windows wireless utility unfortunately doesn't provide this option.

    If it's really only 20ft away, you might just run a cable:biggrin:

    Edit: All of the above assumes that the office computer is exhibiting this behavior only when the SSIDs are set the same. If this is NOT the case, then it must be trying to connect to the router further away because that router is listed higher in the preferred order of wireless networks, in which case, you only need to change the order.
  52. Gene

    Gene Addicted to LI Member

    Just wanted to come back and post that the network is all up and working. astehn, I did what you suggested and boosted the signal on the main router, but the office computer, which is like 10 ft from the router still wants to connect to the library router instead :confused: To correct the matter I did hard wire the office direct via CAT5, which I too recommended. It only made sense being so close, which leaves little chance there will be an issue in the future.

    Thanks for all the help :thumbup:
  53. astehn

    astehn LI Guru Member

    Great! Glad to hear everything is up and running smoothly. That's still a puzzle about office computer wanting to connect to the router further away, but you implemented the best possible fix by just wiring it:)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice