wl.o crash

Discussion in 'DD-WRT Firmware' started by templ, Oct 7, 2005.

  1. templ

    templ Network Guru Member

    Wifi driver crashes after clearing flash an nvram: on each FIRSTBOOT.
    it would boot if i live nvram settings which was created with V22 of firmware., but die on same error after power ON/off the router)

    (on all firmWares (v23) since 15.8.2003 that was last that worked).

    Are some default variables missing in new firmwares?

    using WRT54GS-DE HW 1.0

    (v22r2 works without a problem)

    if anyone have any idea of what to check
    ,or any more thinfg i should try or check to solve this
    i would be wherry great full!!

    The problem is driving me mad for 7 days 8 hours per day now!! ((


    CFE version 1.0.37 for BCM947XX (32bit,SP,LE)
    Build Date: Fri Jun 25 15:49:22 CST 2004 (root@Amin)
    Copyright (C) 2000,2001,2002,2003 Broadcom Corporation.

    Initializing Arena.
    Initializing Devices.
    et0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
    rndis0: Broadcom USB RNDIS Network Adapter (P-t-P)
    CPU type 0x29007: 200MHz
    Total memory: 0x2000000 bytes (32MB)

    Total memory used by CFE: 0x80300000 - 0x8043DF30 (1302320)
    Initialized Data: 0x803381A0 - 0x8033A550 (9136)
    BSS Area: 0x8033A550 - 0x8033BF30 (6624)
    Local Heap: 0x8033BF30 - 0x8043BF30 (1048576)
    Stack Area: 0x8043BF30 - 0x8043DF30 (8192)
    Text (code) segment: 0x80300000 - 0x803381A0 (229792)
    Boot area (physical): 0x0043E000 - 0x0047E000
    Relocation Factor: I:00000000 - D:00000000

    Boot version: v3.2
    The boot is CFE

    mac_init(): Find mac [00:0F:66:C8:6F:B5] in location 2

    No eou key find
    Device eth0: hwaddr 00-0F-66-C8-6F-B5, ipaddr, mask
    gateway not set, nameserver not set
    Reading :: Failed.: Timeout occured
    Loader:raw Filesys:raw Dev:flash0.os File: Options:(null)
    Loading: .. 3704 bytes read
    Entry at 0x80001000
    Closing network.
    Starting program at 0x80001000
    CPU revision is: 00029007

    Primary instruction cache 8kB, physically tagged, 2-way, linesize 16 bytes.

    Primary data cache 4kB, 2-way, linesize 16 bytes.

    Linux version 2.4.32-rc1 (root@colinux) (gcc version 3.4.4) #926 Thu Oct 6 10:51:31 UTC 2005

    Setting the PFC value as 0x15

    Determined physical RAM map:

    memory: 02000000 @ 00000000 (usable)

    On node 0 totalpages: 8192

    zone(0): 8192 pages.

    zone(1): 0 pages.

    zone(2): 0 pages.

    Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs noinitrd console=ttyS0,115200

    CPU: BCM4712 rev 1 at 200 MHz

    Using 100.000 MHz high precision timer.

    Calibrating delay loop... 199.47 BogoMIPS

    Memory: 30308k/32768k available (1582k kernel code, 2460k reserved, 108k data, 92k init, 0k highmem)

    Dentry cache hash table entries: 4096 (order: 3, 32768 bytes)

    Inode cache hash table entries: 2048 (order: 2, 16384 bytes)

    Mount cache hash table entries: 512 (order: 0, 4096 bytes)

    Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)

    Page-cache hash table entries: 8192 (order: 3, 32768 bytes)

    Checking for 'wait' instruction... unavailable.

    POSIX conformance testing by UNIFIX

    PCI: Fixing up bus 0

    PCI: Fixing up bridge

    PCI: Fixing up bus 1

    Linux NET4.0 for Linux 2.4

    Based upon Swansea University Computer Society NET3.039

    Initializing RT netlink socket

    Starting kswapd

    devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)

    devfs: boot_options: 0x1

    Squashfs 2.1-r2 (released 2004/12/15) (C) 2002-2004 Phillip Lougher

    pty: 256 Unix98 ptys configured

    Serial driver version 5.05c (2001-07-0 with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled

    ttyS00 at 0xb8000300 (irq = 3) is a 16550A

    ttyS01 at 0xb8000400 (irq = 0) is a 16550A

    HDLC line discipline: version $Revision: 3.7 $, maxframe=4096

    N_HDLC line discipline registered.

    PPP generic driver version 2.4.2

    PPP Deflate Compression module registered

    PPP BSD Compression module registered

    MPPE/MPPC encryption/compression module registered

    imq driver loaded.

    Universal TUN/TAP device driver 1.5 (C)1999-2002 Maxim Krasnyansky

    cfi_cmdset_0001: Erase suspend on write enabled

    Using buffer write method

    Flash device: 0x800000 at 0x1c000000

    Physically mapped flash: squashfs filesystem found at block 817

    Creating 5 MTD partitions on "Physically mapped flash":

    0x00000000-0x00040000 : "pmon"

    0x00040000-0x007e0000 : "linux"

    0x000cc6b8-0x0039a198 : "rootfs"

    mtd: partition "rootfs" doesn't start on an erase block boundary -- force read-only

    0x007e0000-0x00800000 : "nvram"

    0x003a0000-0x007e0000 : "ddwrt"

    Initializing Cryptographic API

    NET4: Linux TCP/IP 1.0 for NET4.0

    IP Protocols: ICMP, UDP, TCP, IGMP

    IP: routing cache hash table of 512 buckets, 4Kbytes

    TCP: Hash tables configured (established 2048 bind 4096)

    Linux IP multicast router 0.06 plus PIM-SM

    ip_conntrack version 2.1 (512 buckets, 512 max) - 328 bytes per conntrack

    ip_tables: (C) 2000-2002 Netfilter core team

    IPP2P v0.7.4 loading

    iptables-p2p 0.3.0a initialized

    ipt_random match loaded

    netfilter PSD loaded - (c) astaro AG

    ipt_osf: Startng OS fingerprint matching module.

    ipt_recent v0.3.1: Stephen Frost <sfrost@snowman.net>. http://snowman.net/projects/ipt_recent/

    ipt_IPV4OPTSSTRIP loaded

    arp_tables: (C) 2002 David S. Miller

    ip_queue: failed to register queue handler

    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.

    NET4: Ethernet Bridge 008 for NET4.0

    802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>

    All bugs added by David S. Miller <davem@redhat.com>

    VFS: Mounted root (squashfs filesystem) readonly.

    Mounted devfs on /dev

    Freeing unused kernel memory: 92k freed

    Using /lib/modules/2.4.32-rc1/kernel/drivers/net/et/et.o
    Using /lib/modules/2.4.32-rc1/kernel/drivers/net/wl/wl.o
    Oops in traps.c::do_be, line 385:

    $0 : 00000000 00000000 20040000 000f3800 81e54000 fffffbff 00000400 b8001000

    $8 : 00002719 8015d0d0 00000000 801b5b30 00001e51 1000fc01 00000000 00000001

    $16: c0056680 80093b10 81e54000 8009252c b8001000 80092318 00004320 8024ed40

    $24: ba2e8ba3 801cd5b4 81172000 81173c58 00000100 c006616c

    Hi : 00000063

    Lo : bcd77800

    epc : c0056688 Not tainted

    Status: 1000fc03

    Cause : 0000001c

    PrId : 00029007

    Process insmod (pid: 13, stackpage=81172000)

    Stack: 81e5510c 81e5510c 00000100 81e54000 81e55120 00000006 800931cc

    81e54000 c009c110 c005cc50 ba2e8ba3 00000000 00000000 69165f61 00000100

    00000000 00000000 00000000 00000000 00000000 00000000 c009c110 00306c77

    8116c8c0 10046000 81099120 01f3d717 80022a90 8107bdd8 803c76dc 81172000

    00000001 00000002 80010000 00000000 00000000 00000000 00000000 00000000

    800978d0 ...

    Call Trace: [<800931cc>] [<c009c110>] [<c005cc50>] [<c009c110>] [<80022a90>]

    [<80010000>] [<800978d0>] [<8015cfe0>] [<c0052fe8>] [<80093a6c>] [<80095184>]

    [<8016a684>] [<800a823c>] [<8016a9e0>] [<800a849c>] [<8016ab4c>] [<c009c0dc>]

    [<c0053264>] [<c003ae60>] [<c009c084>] [<800a8f74>] [<c009c0dc>] [<800a9060>]

    [<c009c0dc>] [<c005361c>] [<800147f0>] [<80014978>] [<80014898>] [<80018360>]

    [<c0036060>] [<80008a40>] [<c009a1e0>] [<c009c264>] [<c0079cec>] [<c009c26f>]

    [<c00987d0>] [<c009c27e>] [<c003c2b4>] [<c009c28c>] [<8005a56c>]

    Code: 27bd0020 8c87109c 00052827 <8ce20120> 00451024 00461025 ac8218a8 8c8318a8 03e00008

    Using /lib/modules/2.4.32-rc1/kernel/drivers/net/adm6996/adm6996.o
    ADM6996L Driver version 3.2 by Nikki Chumakov, 10-Jul-2004

    Using /lib/modules/2.4.32-rc1/kernel/drivers/net/ctmisc/ctmisc.o
    Register /dev/ctmisc device, major:250 minor:0

    The boot is CFE
    insmod: writemac.o: no module by that name found
    Algorithmics/MIPS FPU Emulator v1.5
  2. BrainSlayer

    BrainSlayer Network Guru Member

    it seems to be a bug in the wl driver itself. i was talking with some openwrt guys and no one knows a solution and since this happends in the original linksys fw too. it can be a hardware defect
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice