Discussion in 'Other Linksys Equipment' started by Anonymous, Feb 16, 2006.

  1. Anonymous

    Anonymous Guest

    I recently purchased a WMB54G (Wireless-G Music Bridge) and have been very pleased with the hardware and its functionality, but the PC-side software leaves much to be desired.

    Basically, the Music Bridge software can only be either completely on or off, and when on it hijacks all sound that would otherwise go to the primary sound driver and sends it to the wireless bridge's output. The problem with this is obvious -- it either sends all sounds or none, and so when streaming music to my stereo I also get all other incidental sound effects.

    A much better implementation would be for it to create a fake sound driver to register alongside "Primary Sound Driver" (like, ahem, "WMB54G - <specific device name>"), so that I could choose to output to it from within specific applications. This could actually be combined with the original implementation so it had like 3 or 4 options -- "stream selected" (in which it would redirect only those apps with the wmb54g sound driver chosen), "stream none" (in which case all sound routed to the fake wmb54g sound driver would be re-routed to the primary sound driver), and maybe a "stream everything" which would work as the current software does now and might be useful for apps that for whatever reason couldn't or wouldn't use the fake sound driver.

    As with all linksys products like this, its open-sourced, so where is the community to create such a solution? (As far as I can tell, they wouldn't have to do anything to the device firmware -- its all about the local machine software). Help?
  2. glub

    glub Guest

    Open source doesn't help

    I had a somewhat similar desire: to use the wmb54g as remote speakers, unrelated to what was going on in my PC.

    But while all the firmware is available as a download, the PC side software, and the actual music streaming s/w on the device itself are proprietary: they are not given as source, nor is the actual over-the-wire protocol documented anywhere I could find.

    Sorry, but it looks like it would be a project to reverse-engineer the device, and not just a recompile-and-go sort of weekend project.
  3. Anonymous

    Anonymous Guest

    Re: Open source doesn't help

    I did see a separate tools-type archive inside the source code download from linksys, dunno if that contains any of the relevent bits for either the PC side software or the music streaming s/w on the device itself. (Regarding this latter in particular, I'm rather surprised that at least /it/ isn't included with the source download.)

    Even if not, this should still be relatively straightforward to reverse engineer considering how many ppl would be interested. Or for that matter since we have access to the device's OS itself (which presumably includes its drivers for the onboard sound output hardware) we could write our own device-side s/w for receiving auto coupled w/ our own pc-side software to interface with it.

    Somebody should at least throw up a forum or wiki for the thing to get people together who might be interested.
  4. Anonymous

    Anonymous Guest

    I recently purchased the WMG54G Wireless Music Bridge and was unable to use it with my WRT54GX4 router, wirelessly ! I spent a total of 3 hours with tech support and we were unable to ping the music bridge. All security programs where disabled and the WEP was turned off on the router.

    Does anyone know if there is a compatibility issue with these two devices?

  5. Anonymous

    Anonymous Guest

    Problems w/ installation of WMB54G Bridge Utility

    Sorry to digress but I am unable to find any information about a problem I am having with a WMB54G. I cannot get the Bridge Utility to install/work properly on my main PC. It goes through the installation process and everything appers to be OK. You can fire the program up and it will function. However, for whatever reason, the GUI front end is messed up. On the main panel, the right portion of the graphics is truncated, so you can't see all of what is supposed to be there. The buttons for volume control, mute, etc. are missing. I can move the cursor around to place that allows me to tab between the 3 panels but it is a real pain. Don't recall ever having problems with this PC before and can't figure out what went wrong. It did die mid-installation on me the first time - I have uninstalled, reinstalled about 20 times to no avail.. even had to do a system restore or two. Can you think of any reason why the graphics and buttons would be missing but I'd still be able to get the basic function to work?
  6. Anonymous

    Anonymous Guest

    Problems w/ installation of WMB54G Bridge Utility

    Try to disable 802.11e QoS function in WRT54GX4! It may be the reason why you couldn't see WMB54G.
  7. Anonymous

    Anonymous Guest

    To the original question of this thread, the music bridge info sheet at http://tinyurl.com/fpcln (tinyurl to linksys url) says the following:

    Have you just not located where to do this? I don't have the unit yet but when I read your post I remembered reading this.

  8. Anonymous

    Anonymous Guest

    Actually, that quote from the linksys website was a significant factor in my decision to buy the music bridge. However it now appears that this was a false claim! After spending over an hour on the phone with support, they were unable (even with assistance) to figure out how to control which sounds go to the music bridge. They said they'd be investigating more and would get back to me, but I'm not holding my breath...

    And I also have found the bridge software utility to very buggy. It doesn't truly toggle sound back and forth between PC and bridge, or between bridge utilities running on different computers. You have to shut down the software completely, and sometimes even power-cycle the bridge itself. Also very annoying is that the utility will usually change the volume to the minimum setting when disconnecting/reconnecting, rather than remembering the previous level.

    Very frustrating to pay $100 for beta quality software!
  9. GEEKZ

    GEEKZ LI Guru Member

    Re: Problems w/ installation of WMB54G Bridge Utility

    The same thing was happening to me. I fixed it by changing my font resolution (DPI setting) in the Display Properties window ("settings" tab, then "advanced" button) to "Normal (96 DPI)". I have a widescreen Dell laptop, so I had the DPI setting bumped up a bit since the eyes aren't what they used to be. I'll just have to get stronger glasses, I guess...

    This wireless music bridge was exactly what I wanted. However it was a B***CH to get working. A lot of folks were writing about that in the forums I visited before buying, but I thought "well, I know what I'm doing, so it shouldn't be that hard for me". Hah. Yeah, why should it be any different for me? And I have a linksys router too...you'd think they would do a better job integrating the setup/install wizard with their own hardware. I eventually got it to connect and play through the optical output to my Kenwood AV rcvr. All digital. Nice.

    That was a few days ago. Today, I came home from work eager to hear some tunes, but when I open the laptop there was a Windows automatic update pending and a subsequent reboot req'd, so I went along, like a good boy, and let it happen. Reboot, no music. Utility showed connected to WMB, but no tunes. Tried everything (and yes, I know about stopping the media app prior to switching to the WMB). I'm guessin' the update overwrote something, so I uninstall and re-install eveything, setting up the WMB to work with my wireless network once again. 2 hours and much foul langauge later, it's working again. Linksys REALLY needs to use beta testers prior to release. I can see where many would just give up and return it...

    It doesn't work with my Windows Media Player 10. This might have something to do with the fact that I'm running Windows Media Center edition, which may interface to WMPlayer a little differently. It does work with my MusicMatch, which I prefer. Works with Rhapsody radio, which is especially nice.

    Oh, and I sent them a nasty-gram about their claims on the website about the user able to choose which audio should go to the WMB (like music) and which shouldn't (like Windows beeps and dings). Hah. That's sooo wrong. Doesn't anybody check this stuff out before release to market? I'm not gonna lose sleep over it, but that kinda stuff really ticks people off.

    I'd like to see Linksys make better utility software for this product, as I'm sure would everyone. But it does sound great. :thumb:

    UPDATE 8/28/06: for those of you that are experiencing the "sometimes it works, sometimes it doesn't" aggravation with the WMB54G, I have discovered this tidbit of information...
    I run the Music bridge software on Windows XP SP2 Media Center edition. I am setup for 2 users, my wife and myself. I installed the Music Bridge utility for both. Apparently, my problems are resulting from the fact that when we are both logged on, there are two sets of software processes (used by the utility) running at the same time. It seems the utility doesn't like this! You can see all running processes by running Windows Task Manager. The process in question is cmflywav.exe, required by the system to switch from the PC's sound card to the WMB. If I force a log off of the other user (you can do this with Task mgr) I can usually get the WMB to work, but even then sometimes have to reboot. I ultimately can, however, get the WMB to work but it's a hassle. I keep checking the Linksys site hoping for an update to the utility...with all the negative feedback they must be getting you'd think they would get with it.
  10. dsr70

    dsr70 Network Guru Member

    After using the wmb54g a few months, I finally noticed it does have a sound driver. It's the "C-Media Wi-Sonic" one in the sound driver list.

    I haven't figured out a way to get this to work so that apps can independently send audio to the bridge or not, but I haven't tried much yet.

    But I think this is promising. The bridge software simply makes the Wi-Sonic driver the primary, but apparrently does something else too. Plus C-Media may release their own drivers that allows what we want. Best would be the Wi-Sonic driver that outputs to an IP without having to scan like the Linksys software.

  11. dsr70

    dsr70 Network Guru Member

    There's another kludge workaround to address the OP's original question.

    If you switch to the music bridge, start Winamp, then switch back to the PC's speakers, Winamp will still use the music bridge. All other sounds will use the PC speakers.

    Other programs besides Winamp may behave the same way.

  12. DocLarge

    DocLarge Super Moderator Staff Member Member

    The only thing that ticks me off about this device is the amount of dropouts...

    I've lowered the threshold, switched between my WRV54G (with a 7dbi high gain antennae), Netgear DG834G, and WRT54GC (using the 7dbi high gain antennae) and I still get the dropouts wirelessly.

    Out of all the complaints listed, is anyone else having this problem?

  13. obrienj

    obrienj LI Guru Member

    See what C-Media Wi-Sonic really means

    All interested in the WMB54G might want to look at this:


    Sounds very familiar, did Linksys outsource the WMB54G to C-Media or visa-versa.

  14. lordashley

    lordashley LI Guru Member

    r u still facing a prob with ur wmb54g and wrt54gx?
    there is a fix .... try enabling the qos
  15. emuman100

    emuman100 LI Guru Member

    Welp, I purchased one of these bad boys, and let me tell you, the software linksys provides is crap, but I did get it working as intended, and it sounded decent, and I see the device has promise. The firmware is buggy too, as getting wireless to actually work was a pain, but I got it working. I had to uninstall the software to get pc sound back again, but when the software was set to video, playing a movie file the sound was in sync. The hardware platform seems to be reliable.

    So I opened this baby up to see what the floop made it tick. It's based on a reference design from Cmedia for sending audio from a PC over an IP network through their proprietary WSAS protocol. Cmedia's whole design plan was to create a virtual audio device that will pipe audio over this WSAS protocol. Inside contained the Cmedia Wi-Sonic SoC which is 200MHz MIPS based and runs on embedded linux (yes!). It is ACPI power managed device as well as containing a PCI bus for a CMI8769 PCI Audio processor with S/PDIF and analog audio outputs. It contains an ethernet PHY and wifi radio, as well as a whopping 128mb DRAM and 16mb flash. This is one damn fine hardware platform if I do say so myself. I've requested some info from Cmedia, but I doubt they'll give me anything useful.

    My intentions are to use the WMB54G as a network audio device with out the virtual soundcard. I want to run mpd and control it via telnet or browser interface. For those of us with vintage audio equipment but lots of music stored on a server, this device fits the bill. I want to run it standalone to play mp3s locally, shoutcast stations, and whatever format can run on this puppy. Anyone have ideas, suggestions, advice, etc on hacking into the unit? There are two pin header footprints on the PCB, I'm sure possibly a serial port somewhere, but I'm not sure if the SoC has linux embedded into it and linksys added their own web browsing and network app onto the flash ontop of linux or if it runs on linux thats on it's 16mb flash.


  16. Skull-Head

    Skull-Head Guest

    Sync Sound for both PC and WMB54G

    I recently purchased a WMB54G (Wireless-G Music Bridge) and had no problem with the setup. I too have experienced the same problems of shutting down the application (i.e. Media Player) before the Music Bridge software would release the streaming audio from the home stereo to the PC.

    Is it just me or did anyone else expect the PC and the home stereo to stream the music simultaneously? If there is a lag in the stream it would be minor or non-existent with a Ethernet connection. Has anyone figure out a workaround to sync the PC and home stereo?

    Has anyone installed two or more of the WMB54G? Will the software sync with more then one unit or will it only stream to one device (WMB54G) at a time?
  17. emuman100

    emuman100 LI Guru Member

    I took it apart and noticed pulsing on one of the header pads durring bootup with my scope. It seems to pulse at 3V. I'm thinking this is a TX line on a serial port. I ordered a 3V TTL to RS232 tranceiver and will see what I can get on a terminal. Anyone else do this in the past?
  18. emuman100

    emuman100 LI Guru Member

    I think I have a preliminary partial pinout of J9 on the PCB.

    1 2
    3 4
    5 6
    7 8

    2 and 4 are Vcc
    6 and 8 are Gnd
    1 is possibly TX

    More info to come when I get my TTL to RS232 converter.

  19. emuman100

    emuman100 LI Guru Member

    Good News!! The stock firmware outputs this at 38400, 8, N, 1 on pin 1 of J9:

    UART1 output test ok
    Uart init
    mfid=000000c2 devid=00002249
    Found 1 x 2M flash memory

    ---RealTek(RTL8186)at 2005.11.08-15:14+0800 version 1.3c [16bit](180MHz)
    no sys signature at 00010000!
    Jump to image start=0x80300000...
    early printk enabled
    Determined physical RAM map:
    memory: 01000000 @ 00000000 (usable)
    Initial ramdisk at: 0x8017d000 (3584000 bytes)
    On node 0 totalpages: 4096
    zone(0): 4096 pages.
    zone(1): 0 pages.
    zone(2): 0 pages.
    Kernel command line: root=/dev/ram console=0 ramdisk_start=0 single
    Calibrating delay loop... 178.99 BogoMIPS
    Memory: 10956k/16384k available (1341k kernel code, 5428k reserved, 3616k data,)
    Dentry-cache hash table entries: 2048 (order: 2, 16384 bytes)
    Inode-cache hash table entries: 1024 (order: 1, 8192 bytes)
    Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
    Buffer-cache hash table entries: 1024 (order: 0, 4096 bytes)
    Page-cache hash table entries: 4096 (order: 2, 16384 bytes)
    check_wait... unavailable.
    POSIX conformance testing by UNIFIX
    Probe PCI Bus : There must be one device at the slot.
    PCI device exists: slot 0 function 0 VendorID 13f6 DeviceID 111 bd710000
    Find Total 1 PCI function
    pcibios_fixup_resources IO form 1d500000 to 4f0000
    Linux NET4.0 for Linux 2.4
    Based upon Swansea University Computer Society NET3.039
    Initializing RT netlink socket
    Starting kswapd
    Serial driver version 6.02 (2003-03-12) with no serial options enabled
    ttyS00 at 0x00c3 (irq = 3) is a rtl_uart1
    Realtek GPIO Driver for Flash Reload Default
    ezWAVE Mini-Driver v1.0.0.8
    cpu_clock = 180
    vendor=0x13f6, device=0x0111, iobase=0x004f0000
    chip version = 055
    initialize_chip ok.
    block: 64 slots per queue, batch=16
    RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
    RealTek E-Flash System Driver. (C) 2002 RealTek Corp.
    Found 1 x 2M Byte MXIC MX29LV160AB at 0xbe000000
    RTL8185 driver version 1.8 (2005-11-18)
    8186NIC Ethernet driver v0.0.2 (Jan 30, 2004)
    eth0: RTL8186-NIC at 0xbd200000, 00:01:02:03:04:05, IRQ 4
    eth1: RTL8186-NIC at 0xbd300000, 04:05:06:07:08:09, IRQ 5
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP
    IP: routing cache hash table of 512 buckets, 4Kbytes
    TCP: Hash tables configured (established 1024 bind 2048)
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
    NET4: Ethernet Bridge 008 for NET4.0
    RAMDISK: ext2 filesystem found at block 0
    RAMDISK: Loading 3500 blocks [1 disk] into ram disk... done.
    Freeing initrd memory: 3500k freed
    VFS: Mounted root (ext2 filesystem).
    Freeing unused kernel memory: 52k freed
    mount /proc file system ok!
    serial console detected. Disabling virtual terminals.
    init started: BusyBox v1.00-pre8 (2005.11.30-07:10+0000) multi-call binary

    BusyBox v1.00-pre8 (2005.11.30-07:10+0000) Built-in shell (msh)
    Enter 'help' for a list of built-in commands.

    rm: cannot remove `/tmp/params': No such file or directory
    rm: cannot remove `/tmp/static_flash_params': No such file or directory
    killall: restore_defaultsd: no process killed
    killall: raspmonitor: no process killed
    killall: raspplay: no process killed
    killall: wizard: no process killed
    Initialize wlan0 interface
    killall: syslogd: no process killed
    killall: klogd: no process killed
    SIOCGIFFLAGS: No such device
    bridge br0 doesn't exist; can't delete it
    Setup bridge...
    device eth0 entered promiscuous mode
    eth0:phy is 8201
    SIOCDELRT: No such process
    device wlan0 entered promiscuous mode
    SIOCDELRT: No such process
    br0: port 2(wlan0) entering listening state
    br0: port 1(eth0) entering listening state
    SIOCDELRT: No such process
    waiting for bridge initialization...
    Usage:: not found
    start raspmonitor
    raspplay start !Allocate play buffer 262144 bytes
    ----------------> ezmn_open : 1
    Allocate play buffer 1048576 bytes
    send notify pkt
    send notify pkt
    send notify pkt
    send notify pkt
    br0: port 2(wlan0) entering learning state
    br0: port 1(eth0) entering learning state
    br0: port 2(wlan0) entering forwarding state
    br0: topology change detected, sending tcn bpdu
    br0: port 1(eth0) entering forwarding state
    br0: topology change detected
    # Osborne in dhcpc.sh going to run udhcpc
    Osborne in br0.sh deconfig
    Osborne in br0.deconfig 1
    SIOCDELRT: No such process
    SIOCADDRT: Invalid argument
    rm: cannot remove `/tmp/params': No such file or directory
    rm: cannot remove `/tmp/static_flash_params': No such file or directory
    killall: easyconf: no process killed
    killall: tftpd: no process killed
    Dante's tiny TFTP Server is ready on port 69
    Osborne in br0.sh bound
    lan_ipaddr is, now setting the NVRAM vars for br0 as a DHCP clien.
    deleting routers
    SIOCDELRT: No such process

    Finished setting NVRAM vars for br0.
    adding dns
    adding dns
    rm: cannot remove `/tmp/params': No such file or directory
    rm: cannot remove `/tmp/static_flash_params': No such file or directory
    Dante's tiny TFTP Server is ready on port 69
    Osborne in dhcpc.sh running udhcpc GOOD
    send notify pkt
    send notify pkt

    Then, RX is pin 7 on J9. Press return on your terminal and you are graced with a linux prompt, though there is no uname. Apparently this is busybox with someprograms that utilize the dsp for audio playback, raspmonitor for monitoring packets and raspplay to actually play the audio. raspmonitor probably sends notify packets. Remember, to get a prompt, you'll need a TTL to RS232 converter, and pinouts are as follows:

    1 2
    3 4
    5 6
    7 8

    2 and 4 are Vcc
    6 and 8 are Gnd
    1 is TX
    7 is RX

    Not sure what pins 3, 5, and 9 are for, as I never saw any pulsing on them, and RX I found by trial and error sending a return character on pins 3 and 5 and got nothing, and stopped on 7 because it was RX, but with my scope, 3, 5, and 9 are all low.
  20. obrienj

    obrienj LI Guru Member

    Telnet access to WMB54G Linux from PC

    Since Linksys provides the WMB54G software as GPL I downloaded it and was able through some trial and error to create the necessary ptyp and ttyp devices and activate telnetd on the WMB54G so I have full access to it.

    Sadly all of the non-Linux pieces (except those also GPL like BusyBox) only come in object form in the distribution so raspplay, the audio chip driver, etc are not directly accessable so someone would have to reverse engineer them or get the specs for the C-Media protocol or the ezwave driver to use the chip directly.

    The mods involve modilying files nm_config, nm-config.h to specify the additional commands required for BusyBox (telnetd, free, df, and others at your choice). Note that these two files are NOT the normal way to configure BusyBox but for expediency it is the course I chose.

    In the file that builds the image, you need to define some ptyp and ttyp devices (see the line DEVICE=).

    In the files profile.ap you and sys_restart.sh you need to add the lines "killall telnetd" and "telnetd &".

    All of this is bult with the commands "./MakeFW clean" and "./MakeFW Linksys". This process takes a while.

    Reflash the device using the produced ".bin" file (you might save the one that arrives with the GPL distro or run a build before making mods) and the normal web based firmware upgrade process under the Help tab.

    BEWARE, there is no jtag, boot_wait, or failsafe (like OpenWrt) for this so that first reflash can be a bit of a nail biter as I am unsure what, if anything, the reset button does.

    As I said this was "quick and dirty" but it works fine. I also found that tftpd is enabled and, with some failures, have been able to tfpt get and put from windows.

    Now off to see if I can figure out how to use the audio chip directly and I have an Internet radio as well as other functions without having to have a PC running to downstream the audio. (Yes, the device can access anything URL or IP address with the proper software like "nc", "wget", etc.

    Much of the work done for OpenWrt might apply here.

    Up and running the device has 6MB of memory available and 2MB of "file space".

    Have fun,
  21. bob2701

    bob2701 LI Guru Member

    Has anyone been able to get the WMB54G to work with the WRT54GX4 yet. Linksys tech support refuses to respond to my emails. Works wired but cannot connect wireless.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice