WMP54G not receiving signal

Discussion in 'Other Linksys Equipment' started by South, Jul 31, 2006.

  1. South

    South Network Guru Member

    So My problem is the following. I have a wireless network set up at home with everthing dandy. One PC connected with wires directly to the router (Linksys WRT54G v1.1), while there is one PC and one laptop that connects wirelessly.

    I was trying to add another wireless PC to the system. I bought a wireless Linksys PCI-card (WMP54G v4). Installed it into my system everything seemed flawless, but it was not able to locate the wireless network! I had my laptop right next to it and it still couldn' t find it. Why?

    I tried uninstalling and reinstalling, but all that changed were that in the Networking Connection I saw Wireless Connection 2, than Wireless Condition 3 and so on.

    Why can't it locate the network (I tried using another antenna, but to no avail). There are no yellow exclamation marks in the Device Manager. I tried to connect the router to the system with an Enthernet cable, everything worked fine. I tried to connect with the wireless while connect via a cable and even then it would not recognize it. SSID is not hidden.

    I have another PCI Linksys in another system it is a g-based so probably it is WMP54G too, but the version is lower. I switched the two cards and still nothing. The previously working card did not recieve a signal either!
    What prevents the card from receiving the signal.

    I'm lost, help me.

    Thanks for the help!
  2. Toxic

    Toxic Administrator Staff Member

    is the SSID disabled (hidden) in the routers setup?
  3. South

    South Network Guru Member

    "SSID is not hidden."
  4. Toxic

    Toxic Administrator Staff Member

    Seems to me you ahev tried everything that most of use would have tried.
    and tbh if it wont work on another PC then i guess the card is defective.

    did you get the old card from the working PC installed ok on the other PC?
  5. South

    South Network Guru Member

    As Ihave mentioned in my post. I took a similar older PCI card from my other PC (probably version v1 or v2) - which works perfectly fine in the other pc - and installed it in the faulty system and received similar sympthoms. Unable to locate wireless network.

    So does this imply that there is a Windows fault?
    I know of no options in windows that will cancel out wireless networks.

    Any ideas?
  6. Esquire

    Esquire Mesquire Staff Member Member

    Are you running Windows XP and using Wireless Zero Configuration (WZC)? Did you install also Linksys own wireless client manager (WCM) along with the driver? Please check whether the service you want to manage your wireless connection is running and not the other.

    If you are using WZC, make sure the service is also running:

    Start > Control Panel > Administrative Tools > Services
    Wireless Zero Configuration should have an Automatic startup type and status showing it is running
  7. South

    South Network Guru Member

    The Linksys Client Manager automatically installs (!) with the drivers and the card. But managed to uninstall it and only use WZC. Yes the service is set to automatic. And will run on startup.

    It shows no error messages (besides no wireless network found) as it did previously when is conflicted with WCM.
  8. Toxic

    Toxic Administrator Staff Member

    there is a radio on/off setting in the drivers advanced settings on most versions of broadcom drivers. check the advanced properties in device manager of the wireless device.
  9. Esquire

    Esquire Mesquire Staff Member Member

    Actually, you can install the driver without the Linksys WCM - just don't run the installation setup application. When Windows detects the adapter and asks for a driver, point it to your setup CD and it should find and install only the driver. This also works for the ZIP format of the driver download from Linksys.

    Come to think of it, are you able to detect other wireless networks (assuming they are present)? Check your driver properties also. I don't have a WMP54G v4 but there is a setting on the driver I use for my WMP54G v1.0 that allows the radio to be enabled/disabled, just like that on a notebook:

  10. Esquire

    Esquire Mesquire Staff Member Member

    Beat me to it :tongue:
  11. South

    South Network Guru Member

    "boradcom drivers"? What exactly are broadcom drivers? I haven't found anything like this.
  12. Esquire

    Esquire Mesquire Staff Member Member

    Broadcom is the company that makes the wireless chipset on many Linksys wireless equipment, in which case Linksys drivers are often rebadged OEM reference drivers from Broadcom.

    Just check the driver for properties and settings available in your Device Manager.
  13. South

    South Network Guru Member

    Yes Radio is enabled.
    Since there are no other wireless networks in my neighbourhood I can't locate or connect to another network.
    Where it should lilst the available wireless networks none is listed. (None reachable).
  14. Esquire

    Esquire Mesquire Staff Member Member

    What about the adapter driver? Is the driver up-to-date?
  15. South

    South Network Guru Member

    I have driver version for the WMP54G
  16. Toxic

    Toxic Administrator Staff Member

    if you have tested BOTH cards in on PC and they both do not work then the problem could be something on that PC. What motherboard is the PC using?

    is it old? I ask as I am thinking that the PCI Slots on this motherboard are not compatable, especially if it is old. have you tried a different PCI slot incase of PCI conflicts?
  17. South

    South Network Guru Member

    Yes I tried to install the PCI card from an old PC to the faulty PC and that did not work either. So yes unfortunately it seems it is some sort of PC (Windows) failure.

    Motherboard is an Asus A7N8X Deluxe v1.1 with 1Gb ram. Not overclocked. I have 3 HDDs in the PC all IDE. One DVDRW and 5 fans. All with an Enermax 365W PSU.

    I tried another PCI slot but no luck.
  18. Toxic

    Toxic Administrator Staff Member

    pity, i was hoping the motherboard was very old and wasn't PCI v2.x complainant. I could only suggest either a USB Wireless Adaptor for that PC or Hard Wire that PC into 2nd WRT54G (as a Wireless client with 3rd party firmware) or your existing Router. its obviously not the solution you wanted but it would work. somehow there is an incompatbility issue with either your PC's Hardware (most likely) or the operating system has some weird registry entry that is killing any Wireless drivers.
  19. Esquire

    Esquire Mesquire Staff Member Member

    I presume motherboard BIOS and chipset driver are both up-to-date also?
  20. South

    South Network Guru Member

    Yes I was afraid you would suggest something like that. I think I will try to reinstall my windows, I can't think of anything else that might help.

    Thanks a million anyways!
  21. South

    South Network Guru Member

    After starting to go slightly mad, I can think of and accept anything as a reason that is blocking the transmission. Could it be the Motherboard chipset drivers? Anything is possible it is an nForce2 chipset.

    Although highly unlikely. :(
  22. Esquire

    Esquire Mesquire Staff Member Member

    Give the latest chipset a try if available.
  23. South

    South Network Guru Member

    Here is another wall. Nvidia is not the best at keeping old hardware drivers updated. There are no unfiied drivers, so the official drivers for the nForce2 are more and a year old! There are a bunch of different un-official drivers compiled by nForce 2 fans. But would that solve my problem, or just fuck up the system?
  24. Esquire

    Esquire Mesquire Staff Member Member

    Very difficult to say. I'm not a fan of the nForce2 myself.... have had a nightmare with the only nForce2 based ASUS board I come across - to this day it's still not running quite as smooth intermittenly.

    Probably best to stay away from unofficial chipset drivers and switch to a USB adapter if possible, as suggested.
  25. jrsweger

    jrsweger Network Guru Member

    One thing I haven't seen answered here yet unless I missed it is which operating system you are using, XP or 2000? With XP you can just plug the card in and go (should be found by XP and properly configured) but if you are using W2K, you need to install the software and drivers before plugging in the PCI card. I have the same motherboard and am using the original chipset drivers with no problem.
  26. infoterror

    infoterror LI Guru Member

    I have a similar problem here.

    Motherboard is Abit IC-7 with updated chipset drivers.

    Operating System is Windows XP.

    Installation via Windows or Linksys setup.exe is easy, but then the card can literally find nothing and in "Network Connections" shows as disconnected.

    It's a WMP54G V4.

    One problem: I'm now on "Wireless Connection 6" since the process of installing/reinstalling apparently went through several connections.

    I am baffled as to why this is happening. I am also confused as to why Linksys chooses to have the big idiot software install to do what Windows Zero Configuration wireless networking does better. I am also wondering how so many people run this card without this problem. But this rapidly leads to existential territory.

    Any help is appreciated. If not, I have no choice but to replace the card with another (probably not a linksys). I am out of other options as far as spending more hours playing with it goes.
  27. infoterror

    infoterror LI Guru Member

  28. infoterror

    infoterror LI Guru Member


    (Looks like that's gonna be the solution here too soon -- simply incompatible and, judging by the looks of things, possessed of some kind of intensive design flaw.)
  29. infoterror

    infoterror LI Guru Member

    Doing this here causes the problem as well -- exactly the same as every other method of installation.

    If no one has any other ideas, I have to conclude its an incompatibility between the WMP54g card, the Abit IC-7 motherboard and Windows XP and use a different card.


    Found this error in the logs:


    Seems the broken Linksys installer left behind some waste that's causing all network card installations to fail. Wow, what didn't they do wrong with this product?
  30. South

    South Network Guru Member

    Your posts were great help inforterror!

    Unfortunately I couldn't access the offical help page it ask for login.

    I have the exact same problem, expect with an ASUS A7N8X mb.
    It would be interesting what are the similarities with between the two cards, in order to solve this stupid problem.

    Will this be cured by a newer driver? (Will RAIlink drivers help?) I'm afraid of trying after reading all the bad things about leftover drivers.

    Could it be a motherboard driver problem, BIOS even?

    Will they return the card, if technically nothing is wrong with it?

    What is the solution? Return the card and buy another Linksys product (ie: a USB adaptor?) will I not have the same type of error, or simply forget Linksys and opt for another manufacturer?

    Another annoying thing is when I change the PCI slot (was trying everything possible) I end up with Wireless-G PCI Adapter #2, #3 and on and on. Any way to remove the numbers?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice