WMP54G problems finding 802.11B network

Discussion in 'Other Linksys Equipment' started by elnino, Aug 10, 2004.

  1. elnino

    elnino Network Guru Member

    On my network I use a BEFW11S4 as the router and access point. If I have a B card, it'll connect to the network fine. This WMP54G (running on Win2k) will not. It seems like I've tried everything, putting in the WEP key I use, disabling WEP on the router, enable SSID broadcasting, etc. and everything I've tried, the WMP54G still won't find my access point on the Site Survey in its software. What else should I try?
  2. Couledouce

    Couledouce Network Guru Member

    The BEFW11S4 is a Wireless-B Broadband Router using the 802.11b wireless standard. The WMP54G is a Wireless-G device using 802.11g but should also work with 802.11b. Have you checked that the WMP54G is correctly set in Mixed Mode?:
    "Network Mode - Select Mixed Mode, and both Wireless-G and Wireless-
    B computers will be allowed on the network, but the speed will be reduced.
    Select G-Only Mode for maximum speed, but no Wireless-B users will be
    allowed on the network."
  3. Esquire

    Esquire Mesquire Staff Member Member

    There is no Mixed Mode setting for WMP54G v.1 (dunno about later versions) - seems superfluous on an adapter since it is the router that controls the mode.

    Having said that, there are discreet 802.11g and 802.11b modes to select under the driver's Properties but they are only applicable to IBSS mode (i.e., ad-hoc connection).

    Which WMP54G version are you using?

    Are you using any MAC Address filtering on the router?

    Check the driver's Properties. Is the setting for the Radio set to Enabled?
  4. Couledouce

    Couledouce Network Guru Member

    Form the linksys site the product data sheet for WMP54G_V4 clearly states:
    "Also interoperates with Wireless-B (802.11b) networks at 11Mbps"

    So it should be possible for at least a WMP54G_V4.

    Now the question still remains, what version do you have?
  5. Esquire

    Esquire Mesquire Staff Member Member

    Yes, all 802.11g devices will say that, but it doesn't mean there is a Mixed Mode setting on this adapter.
  6. Couledouce

    Couledouce Network Guru Member

    From the datasheets in: ftp://ftp.linksys.com/datasheet/
    earlier versions of the wmp54g are supposed to be interoperate with all the 11Mbps Wireless-B (802.11b) products.

    So maybe you have to go back to the basics of checking if the
    wmp54g is using the same channel, SSID, security settings etc as the BEFW11S4.
  7. Couledouce

    Couledouce Network Guru Member

    Looks like we are exchanging posts...

    I do not have a wmp54G installed, I'm going only from the documentation on the Linksys site. The user guide also indicates that you can set the Network Mode but only in adhoc mode:
    "Network Mode - Select Mixed Mode, and both Wireless-G and Wireless-
    B computers will be allowed on the network, but the speed will be reduced.
    Select G-Only Mode for maximum speed, but no Wireless-B users will be
    allowed on the network."
  8. Esquire

    Esquire Mesquire Staff Member Member

    Yes, and the emphasis is on ad-hoc mode, which you correctly pointed out.

    Ad-hoc mode (or IBSS mode) is not for connection to routers, but for connection between clients in a peer-to-peer network - kinda like connecting 2 computers using a cross-over LAN cable. Connection to an access point or router is known as Infrastructure Mode, in which case the Mixed Mode is controlled by the router/AP, (in ad hoc mode, this is controlled by the clients since there is no router, hence the different mode settings), which is why I said earlier in my first reply there is no Mixed Mode, but there are discreet mode settings for ad-hoc connection. I hope this clarifies what I and the user guide are trying to say.

    In addition, there is usually no channel to set in infrastructure mode on an adapter - the channel setting is also for ad-hoc mode.
  9. Couledouce

    Couledouce Network Guru Member

    Thanks, I think I understand clearly now but it doesn't help elnino much.

    It may only work in ad-hoc mode and probably ad-hoc mode is not what elnino wants!
  10. elnino

    elnino Network Guru Member

    Wow! I didn't expect this many replies already, you guys are awesome!

    I'm using the first version of the WMP54G (the one with the MiniPCI type on the PCI card, not the super skinny v4) and I'm using the latest drivers from Linksys that's labeled for version 2. Like it was mentioned above, the software doesn't give me any control over the mode setting or the channel while in intrastructure mode. Do you think there would be any way for me to hack the profile settings in the registry set it to Wireless-B and the channel?

    About my router, I'm not using MAC filtering or anything like that. I was surprised that when I turned off every type of security feature on the router, the WMP54G card still couldn't find it. I've got version 2 of the BEFW11S4 router/WAP and am currently running the 1.42.7 firmware. The latest firmware offered by Linksys is 1.45.10 but nothing in the release notes mentions better G-compatability or anything. Should I still upgrade the firmware to see if that fixes the problem?
  11. Couledouce

    Couledouce Network Guru Member

  12. elnino

    elnino Network Guru Member

    The computer is running Windows 2000 so a lot of that stuff wouldn't apply. :? Do you think the firmware upgrade to my router would help?
  13. Esquire

    Esquire Mesquire Staff Member Member

    elnino, is this a new card? Is it possible that this card is not working from the start? Do you have someone with a desktop and G router that can test the card for you? Have you checked for driver's Properties page (via Device Manager, etc.) to see if the Radio has been disabled (default = Enabled)?

    Do you know if you have other WLANs in your neighbourhood? Is your WMP54G able to detect these WLANs in the area? You said you have a B card, does it detect other WLANs around where you are?

    If the card is working as it should be, you wouldn't need to set channel or the "B" mode - the card should work as is - I have connected my WMP54G to about seven/eight B routers old and new (although nothing from Linksys) in the past and I never had to do anything to get it to work with them, regardless of channels or modes. As a side note, I even did an experiment not too long ago with a non-Linksys B client and my G-only router - the client detected the router, but wasn't able to connect to it. In case you are wondering, my WMP54G should be identical to yours right down to the driver.

    I also wouldn't worry about the missing compatibility with "G" on your router - only the 802.11g standard calls for backwards compatibility with 802.11b, not the other way round, so the omission is "red-herring" - even the latest BEFW11S4 V.4 doesn't say it is compatible with G because it is not necessary. In any case, it is the G devices that need to connect with and operate as B devices, not B as G.
  14. elnino

    elnino Network Guru Member

    Thanks for your reply Esquire. Yes, the card works. It was previously working fine on a WRT54G before I reformatted the computer so that I could reinstall Windows 2000. I checked device manager and the Radio is enabled. When I click refresh on the Site Survey, I can hear the card click once or twice, so it's gotta be working

    There are other WLANs in my neighborhood, but none close enough that my WMP45G would be able to pick up.

    I went ahead and upgraded the firmware on the router and it didn't work. Alteast it was worth a shot.
  15. Esquire

    Esquire Mesquire Staff Member Member

    So even if you switch to a B adapter, your router is the only one that is visible when performing a site survey?

    I'm just as baffled as you are. Do you know someone or have access to another G-client and see if it can connect to your router? This way you can narrow down the area where the problem lies - the router or the adapter.
  16. Problem Solved.

    Just in case anyone else comes to this forum with a similar problem... I had a similar issue where my wireless router was BEFW11S4 and wireless adapter or card was WMP54G version 1.0. Wireless connection was listed on client side but wasnt able to connect.

    However, changing the wireless connection to Chanel 1 solved the problem.

    So what i did was that i went to administration panel for my router at and under "Wireless" tab, changed the "Wireless Channel" to "1-2.417 GHZ" and it started working right away.

    The default admin password for linksys is "admin" and user id is empty.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice