WMP54G V. 1 issues

Discussion in 'Other Linksys Equipment' started by crs117, Mar 10, 2005.

  1. crs117

    crs117 Network Guru Member

    I spent the better part of the morning working with my wmp54g to get it working again in windows xp. Here is the situation.

    Last night i came home from work and noticed that my network icon on the taskbar was suspiciously missing. My network connection still worked so i didnt worry about it at first. Later on i checked my network connections to see if anything had been changed only to find that there were no network connections to be found. I used to have my wmp54g listed along with my firewire card.

    I figured that a simple reboot would probly rectify the issue and allow me to get back to feeling like my computer was running normal again. Unfortunately when i rebooted, nothing returned to normal. Instead the network connections page remained blank and so i checked out the device manager only to see that my wmp54g was not listed as an unknown device titled "wireless g pci adapter" and underneath that was a listing for my firewire card. I simply assumed that a reinstall of my drivers would fix that, but i waited till this morning to get to work on it.

    This morning i downloaded the latest drivers for the wmp54g only to find drivers for version 2 and 4 of the card. I assumed that one of them would work so i tried installing it off of the CD allowing windows to install it for me only to see windows say that no better driver for the device was found. I then manually installed the driver by selected the v2 driver directly. I rebooted only to see that it did not fix the issue. I then tried to force the install of the v4 driver (i now know that is useless), and windows would not let me install it. On the properties page in the device manager i have a code 31 error saying that windows was unable to install the driver for the device.

    I then located an driver i had on my machine (ver 1.3 perhaps) and rebooted. Again it did not work and it had the same code 31 error in the device manger properties window.

    I assumed that perhaps i had caught some virus and ran a virus check only to find nothing. So my options are that either my firmware on the card somehow got messed up or i still do not have a proper driver for my card.

    Please help. I almost went out and purchased a new card, but i am worried that it may be a pc or windows issue and not a card issue.

  2. howardp6

    howardp6 Network Guru Member

    Error code 31 is the suitable driver would not load or be found for Windows. You can confirm this by going to the event log. Select the system event log and search for and red exclaimation marks and getting the an explanation for the error.

    Try this, it may or may not work. Go to device manage and unistall the wireless network card. Power down and unplug the computer, since you are going to remove the WMP54G to determine which version it is. You should always unplug your machine, when inserting or removing PCI boards, since the later motherboard remain partially powered, wwhen turned off. Remove the WMP54G and check the FCC Certification ID, the last [art of the certification should read WMP54GXX, where the XX is the version number. If it is version 1.0 ther may not be an XX.Reinsert the WMP54G, making certain it is fully seated and plug in and re-start the machine. The machine should detect a new wireless G PCI adapter. Have it reload the correct driver for version 2 or 4. Version 1 and version 2 use the same driver. Hopefully the WMP54G will work now. Otherwise you may have to change the registry, and remove all references to the WMP54G, which is an option I do not recommend, since may make your machine unbootable.
  3. crs117

    crs117 Network Guru Member


    Thanks for the reply. First of all i know for sure it is version 1 because it has the largest pcb of any of the wmp54g cards made. Also i have both soft and hard uninstalled the card (powered down and rebooted) tried manually using my old ver 1.3 driver as well as version 2. When i try using version 4 windows prevent this from being used because it is incompatable with the cards firmware.

    The only other time i have found code 31 being an issue was with CD and DVD drives after removing an older version of roxio from windows. The fix was to remove the upper and lower limit values for the optical devices found in the registry so i did some investigation last night. I first of all made a full back up of my registry and did some minor tinkering with some of the network adapter settings. I could not get to the bottom of the issue after a few tinkers and reboots so i was gonna call M$ today to see if i couldnt get to the bottom of the issue.

    I am pretty certain this is a microsoft issue and not a card issue, i am just suprised to find myself as the only victom of this code 31 error except for CD related problems.

    Any other help would be greatly appreciated.

  4. Esquire

    Esquire Mesquire Staff Member Member

    Have you tried moving the card to a different PCI slot?
  5. crs117

    crs117 Network Guru Member

    Yes i have moved the card.

    I have narrowed down the issue to a windows file i must have accedently deleted when cleaning out an ie hijack. I did not even know my ie was hijacked since i have been using firefox, but i was not about to allow it stay hijacked.

    Apperently i have some issue with my rasman service and my event logger shows an error listing this issue "Remote Access Connection Manager failed to start because NDISWAN could not be opened."

    The ndiswan file is on the computer, so it must be some windows file that keeps ndiswan from being opened. Is there a list of files out there that are necissary for windows to install the drivers for network adapters??? Is there a way to totally reinstall the network components in windows without having to reinstall xp completely? I have gone through the add/remove and windows components to uninstall and reinstall the network stuff, but it did not fix it.

  6. Esquire

    Esquire Mesquire Staff Member Member

    Probably not. It is a core component of the Windows shell, but Windows XP File Protection should have kicked in and replaced the deleted system file.

    How did you fix your hijack? Was a System Restore point created prior to deleting files? You could use the Restore point and see if you can restore to the state prior to fixing the hijack (you would have to refix your hijack).

    And in case you do need to reinstall .....
  7. howardp6

    howardp6 Network Guru Member

    Did you check your system event log for any erros, specifically one that would prevent ndiswan from running. The reinstall of of Windows XP may be a got idea, if you go it an an upgrade, you will not have to re-install all of your software.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice