WMP54g v2 for Vista 32bit driver request

Discussion in 'Other Linksys Equipment' started by jetjaguar, Feb 15, 2012.

  1. jetjaguar

    jetjaguar Networkin' Nut Member

    Could someone please tell me exactly where I can find a driver for:

    WMP54g v2 for Vista SP2 32bit

    It used to work just fine, until I recently reinstalled Vista (and installed all the updates) and now my internet connection is "limited."

    I've spent way too long trying to get it working again...

    Thank you in advance!
  2. howardp6

    howardp6 Network Guru Member

    Did you set the encryption correctly? First go to device manager in the control panel, then network adapters and check to see if there is an exclamation mark next to it. If there is no red exclamation mark next to it, then the device driver was installed. Left double-click the icon for your WMP54G V2 and left click the driver tab. It should give you information on the driver. Make certain the WMP54G is not disabled, if it is enable it.
  3. jetjaguar

    jetjaguar Networkin' Nut Member

    Yes, Windows automatically uses a Broadcom driver. Nothing is disabled, there are not any conflicts, and the problem remains even if I restore the OS back to restore point that I created right after reinstalling Vista (and before doing anything else). If I hook the computer directly up to my netgear router via cable, Windows Update will download and install a more recent version of said driver (no improvement).

    Other laptops in the house have no problems with the wifi. I have turned off both my cable modem and wifi router several times.

    The adapter does connect to the internet, and the signal strength is "excellent", but if drill down to the properties of the connection, it says that IPV4 is connected to the internet, but IPV6 is "limited." This then results in a very weak connection to the internet that goes in and out. I have tried unchecking IPV6 per some recommendations, but that did not help.

    I have tried resetting everything (winsock, etc) via command prompt.

    I have also tried the drivers on linksys's website, though none exist specifically for Vista 32bit.

    At this point I'm pretty sure that I need a different driver.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice