WNR3500Lv1 - can't access Web UI after upgrade

Discussion in 'Tomato Firmware' started by Luddrigo, Apr 20, 2013.

  1. Luddrigo

    Luddrigo Networkin' Nut Member


    I just did something foolish. :rolleyes:

    I upgraded my router (WNR3500L v. 1) to tomato-K26USB- and I forgot to check the clear NVRAM setting.

    After the upgrade the router worked it's magic and came back alive. DHCP gave my computers IP and everything seems to work as before except the Web UI.

    My setup is as follows, if it matters:
    • WNR3500L v.1 ( I tried the ALL-U-NEED adblock thing a while back with pixelserv and I connect to the router through Pixelserv and adblock is not installed anymore.
    • WRT54GL ( this old gems WAN-port got toasted as described in this thread: Linksys WRT54GL v1.1 won't obtain WAN ID - Help me please? This router is connected to the WNR3500 with cable and only handles the wireless needs of my household. Since I am somewhat of a nerd I keep this fancy looking piece of equipment in the middle of the living room which is located in the middle of the house and covers every nook and cranny of the house, garage and almost all of the garden.
    • Two PC's connected to the WNR3500 via cable and static IP outside the DHCP-range according to MAC adress.
    How could I fix this? My guess is to use the reset button but I just want to check first so I don't do anything even more stupid.

    I would rather not enter all my QOS-rules again since I don't have a backup readily available. I will do it if I have to but I would rather not.

    The WNR3500 answers to pings, the QOS works and so on. When I try to connect to the Web UI I get a connection refused error from both my computer, my iPhone and my wifes computer.

    This is the error I get, it's in swedish but it loosely translates to "Error 102 (XXX) The server refused to connect".

    "Fel 102 (net::ERR_CONNECTION_REFUSED): Servern vägrade ansluta."
  2. gfunkdave

    gfunkdave LI Guru Member

    To be clear, you're saying that you can still browse the internet but just can't access the router's web config?

    Telnet or SSH into the router and issue the command nvram get http_enable. If it's zero, you have somehow disabled http access to the router. TO fix issue the following commands:

    nvram set http_enable=1
    nvram commit
  3. Luddrigo

    Luddrigo Networkin' Nut Member

    Yes, that is exactly what I am saying. :) I write this connected to the router. As far as I can tell everything works, port forwarding etc, just not the Web UI.

    I don't know if I have SSH or Telnet access enabled in the settings. However, when I try to connect to with Putty I get a connection refused error. Maybe there is a better way to try to connect. This SSH and telnet stuff is a little like Voodoo / black magic for me.
  4. gfunkdave

    gfunkdave LI Guru Member

    If you can't telnet or SSH into the router (try both the Telnet and SSH settings in Putty), then your only choice is to reset the router to factory settings and start over. Sorry.

    Also, just for giggles, try accessing the router with https.
  5. Luddrigo

    Luddrigo Networkin' Nut Member

    I tried both SSH and Telnet in Putty but no luck. I do use https to acces the Web UI (but I did try both http and https). When I had pixelserv installed it used the :80 port.

    If I do use the resetbutton, will I just restore to Tomato defaults (this is what I hope will happen) or will I be stuck with the stock Netgear firmware?


    I just restored, after setting a static IP on my computer I was able to connect to the Web UI on and start hacking away with the QOS etc.

    Thanks for the help, I will make sure to have SSH enabled. I believe I have read somewhere that you can export the most tedious settings to a file somewhere for easy restore. I will look into that, maybe set something up with cron if that is possible. :)
  6. Toastman

    Toastman Super Moderator Staff Member Member

  7. Luddrigo

    Luddrigo Networkin' Nut Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice