WOL - ARP Cache

Discussion in 'Tomato Firmware' started by F157, Dec 14, 2006.

  1. F157

    F157 LI Guru Member


    first I want to say: BIG thanks for this awesome firmware, i use it for two days now and i know i'll never regret not to use dd-wrt anymore ;)

    my question: as long as my pc is in arp cache i have no problem to wake him up by just clicking on his ip in the wol-window...
    but if the pc is shut down for more than a few hours, it's not in the list anymore... if i try to wake it by manually entered mac it wont wake up...

    is there something i don't understand or why doesn't it work?
    is there a way that the pc stays in arp cache a longer time?

    thanks for helping and sorry for possible bad english ;)
  2. njeske

    njeske Network Guru Member

    good question. i'd be curious about this as well. i've tried to wake up a pc using a manually entered MAC. if i get some time when i get home for work, i'll test this to see if i can confirm.
  3. elscorcho

    elscorcho LI Guru Member

    a way around this is to assign the computer a static DHCP through the Device list (click on the IP addy of your computer on the Device List page.
  4. F157

    F157 LI Guru Member

    I'm using version 1.02 but I'm still experiencing the problem...
    Who is using the WOL-Feature an could tell me how it works at his environment?
  5. cgondo

    cgondo Network Guru Member

    I have been using WOL either from ARP or manually entering the MAC and it always works everytime
  6. paped

    paped LI Guru Member

    Just any idea but try extending the DHCP lease time to the maximum lease time (not sure what that is but you could maybe try 9999 seconds?) as while the lease is still within it's time limit I would have thought that the router would still recognise the link between the IP and MAC addresses. Alternatively try reserving specific IP addresses in the DHCP settings? Not sure if either idea will work but it's worth a try....
  7. F157

    F157 LI Guru Member

    Sorry for digging up this old thread, but after quite a time WOL wasn't needed I tried it again with the actual version of tomato. The problem unfortunately still exists.

    WOL is configured well, yesterday I was able to wake my PC shortly after shutting it down.

    The final test was this morning, 8 hours after the shutting down the pc.
    The PC did not wake up, I think the reason is, again, the ARP Cache.
    The PC has a static IP from the router DHCP.

    Here's the WOL window, a click on my PC did not wake it up:


    Any suggestions? A command that keeps the ARP entry, or a possibility to enter the ARP entry manually and keep it saved?

    /e: the PC I'm talking about is the one on the top "FIST".
    /e2: I thought a chance to edit the arp behaviour would be to telnet the router and use the "arp" command. busybox is loaded and can be accessed, but "arp" doesn't work... :( any suggestions on that?
  8. TerminatorHTK

    TerminatorHTK LI Guru Member

    I'm able to use the WOL feature without any trouble. I have the DHCP set to 7 days, so the PC shows up in the device list, and I can copy the MAC address from there, put in the WOL window, and the WOL works.
    I did have trouble with WOL before version 1.16, but with 1.16 it works correctly for me.
  9. F157

    F157 LI Guru Member

    That really is strange.

    I also have 1.16 and the lease time to 7 days. But after the pc isn't in the ARP cache anymore I can't wake it.

    Are you sure the PC wakes up in your scenario, even if the PC isn't in ARP cache anymore?
  10. F157

    F157 LI Guru Member

    I don't know why, but this morning it worked. \o/

    I'll try it again the next days, let's see if it continues working. :)
  11. TerminatorHTK

    TerminatorHTK LI Guru Member

    That is odd that it didn't work and then started. But I've tested mine extensively and it always works for me, regardless of the ARP cache.
  12. F157

    F157 LI Guru Member

    Today after work I tested with taking the router off the power, so the arp cache got cleared. after that, it did not wake up again...

    i dont get it...
  13. F157

    F157 LI Guru Member

    Ok, this morning it worked again... I think yesterday, the problem was to clear the arp cache by plugging off the power...
  14. F157

    F157 LI Guru Member

    Sorry, me again ;)

    Is it normal behaviour, that when you shutdown th pc, after that plug off the router from power, plug in again, and wol doesn't work?

    Is there a workaround to do WOL even after the router went out because of power failure?
  15. TerminatorHTK

    TerminatorHTK LI Guru Member

    I've not had any issues with WOL after powering down & up the router. In fact, I just did that the other night for a different issue, and today I had occasion from work to use the WOL feature. The PC was not in the ARP cache, and I was able to use the WOL feature with no problems. I'm not sure what the difference might be, but it's definately working for me...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice