Would you like ADSL2MUE to be a real modem?

Discussion in 'Other Linksys Equipment' started by joseangel, May 23, 2005.


What do you think about ADSL2MUE?

  1. I use it as a router and works fine, leave it alone.

  2. I use it as a modem and works fine, leave it alone.

    0 vote(s)
  3. I am not fully satisfied, I want Linksys to release the source code.

  1. joseangel

    joseangel Network Guru Member

    I bought an ADSL2MUE "modem" a week ago. After that I found it was not a modem, but an small router.

    I contacted linksys support and after a bit of research I asked them to release the source code so I could modify it to let it work like a real mode.

    Up to date, there has been no afirmative response. Perhaps they think we are satisfied with the product.

    That's why my poll comes.

    Do you like ADSL2MUE the way it is (an small useless router) or a real mode with full RFC1483, PPPoE and PPPoA support?

    It is not that I want someone else to code the mod because I al more than willing to do it myself, so a real modem firmware would surely come up from my hands if the source code is released (at least I would do my best for that to happen).
  2. Guyfromhe

    Guyfromhe Network Guru Member

    if they havn't released the source for this already it's probably because it's not running GPL code, i'm sure it's clearly labled on the box that it's a router and not just a modem, (not that theres anything wrong with a router) but maybe you should have paid more attention when buying your device...
  3. joseangel

    joseangel Network Guru Member

    I cannot post a picture of the box because I have no camera, but there are six labels around 3x10 centimeters each saying: "ADSL2 Model with USB and Ethernet".

    Actually there are two labels of that size one by another, one in english and the other in french. Both say the same. A pair is on the back, another pair on the front and the last one on the top.

    Other 3 smaller labels complete the box on the right and left side of the box as well as the bottom.

    Also, on the right side it says: "Package contents: [...] - ADSL2 Modem [...]"

    And on its web page it says: "The Linksys ADSL2 Modem [...]" at the very beggining.

    On every online shop it is under the "Modem" cathegory.

    It is not like I did not read about it. It is jut that they lied about what the device is.

    I just made a search on it and I found I was not the only one swindled:
  4. Guyfromhe

    Guyfromhe Network Guru Member

    guess I was wrong they don't mention it anywhere which is suprisng for linksys they usually push every little thing their stuff does, anyway it's likely ot GPL so your not gonig to get source for it...you could return it.. what are you trying to do that you can't do with a router anyway?
  5. Guyfromhe

    Guyfromhe Network Guru Member

    actually it looks like you shoudl be able to login to the modem switch it to bridged only mode and then use a pppoe client on your computer to connect, have you tried that?
  6. Guyfromhe

    Guyfromhe Network Guru Member

    Per page 86 of the linksys manual for this modem:
    Bridged Mode Only:
    If you would like to use your Modem as a bridge, which makes the Modem act like a standalone modem (without NAT or Routing), select Bridged Mode only.
    under basic setup section under the first screen that comes up when you logni to the modems interface.
  7. joseangel

    joseangel Network Guru Member

    Thanks for the suggestion, but I already tried that (before contacting linksys support).

    My ISP connection is encapsulated as RFC1483 in LLC based routed mode and looks like the "Bridge only" mode does encapsulate diferently (perhaps RFC1483 bridge mode).

    What I want to be able to do is using my WRT54G as my internet gateway instead of the ADSL2MUE. That way firewalling, QoS and NAT features are much more advanced.

    I already received a response from them. They point to this web site for the ONLY solution they can provide. Grrrr. 8O :x :evil: :madman: :axed: :axed: :protest:
  8. Guyfromhe

    Guyfromhe Network Guru Member

    i havn't dealt with DSL in a long time but if it doesn't work, it doesn't work, i'd assume your screwed... you should be able to do all that (qos, firewalling and nat) via the wrt if it's the only device hookde up the ADSL via it's WAN port even though it has an internal address, just forward all incomming traffic via DMZ to the WRTs itnernal IP it gets from the ADSL, it shouldn't know the difference.
  9. joseangel

    joseangel Network Guru Member

    It does make a diference for me.

    So, yes, I am screwed. I think I will try to sue them to get them pay back the money or whatever (do not know yet).

    Any idea on how could I create a GPL firmware from the scrach? Did anybody opened the hardware to find out what is it and if linux can be fitted into it?
  10. joseangel

    joseangel Network Guru Member

    I do not care if Linksys helps releasing the code. If they do not help, I will do it from the hardware.

    I've discovered ADSL2MUE is an ADSL Modem/Router based on the architecture of the AR7 "all-in-one" chip manufactured by Texas Instruments.

    Of course, all other chips are compatable with that AR7 solution shown by Texas Instruments, so my best guess is that also the board is a cut-down version of the full architecture proposed by T.I.

    It has 32MB RAM and 32MB flash but do not know yet the microcontroller clock rate.

    By the way, T.I. proposed solution is Linux based, so if Linksys does not want to release the source it could be happening against the GPL license.

    Just to let you know. This chip is capable of a serial link, has an unused (on ADSL2MUE) PCI bus and can be used also as a Voice over IP gateway.

    I'll keep you updated on my research. Promise.

    Edited: Could it be that Linksys does not release the source code because this piece of equipment could be a very nice router at a cheap price? Considering the claims T.I. makes in this chip, of course. Or perhaps it was on the contract they signed with T.I. not to release their NSP software source code. I'll try to contact them to see if they can release it as GPL. :)
  11. Guyfromhe

    Guyfromhe Network Guru Member

    can't you just take the router back to the store you bought it from and get a refund?
    i don't think your going to get very far trying to sue them in anycase... you can go ahead and try to wrtie your own firmware however without all the specs on the hardware and how the board talks to the various components you'll have a hard time, i'm not a hardware engineer so i can't really help you out there i'm not sure your going to find the people you need for something of this scale here though...you could resolve it by getting a modem that works in standalone mode with your DSL service alot quicker in anycase... why does it matter to you so much?
  12. Guyfromhe

    Guyfromhe Network Guru Member

    they may have been on contract to not use GPL code on this product.
    they may have done it because they don't want consumers messing with the DSL side of it...i can't say forsure, if they wanted to make it so you couldn't have a cheap router they wouldjn't have released most of their other routers under the GPL...
  13. joseangel

    joseangel Network Guru Member

    Actually is kind of a self challenge now. I do not really care about the 50 EUR I spent, it is not that much money wasted. Of course, returning the modem is an option but surely I would have to pay the shipping and that would be half the price of the modem. And you are right, sueing them would be useless. I prefer solving it by myself.

    I knew building from the very bottom would be very hard. But luckily I found there are quite a few modems based on exactly the same hardware (it is funny to see that on a few of them the only diference is the way a capacitance is provided by a single big capacitor or a group of capacitors in parallel).

    Here is a list with some of those cloned modem/routers AR7 "based":
    - Actiontec GT701
    - AVM Fritz!Box
    - Netgear DG834G
    - Aztech DSL600E
    - D-link DSL-G604T
    - Sinus 154 DSL Basic SE
    - Linksys ADSL2MUE
    Taken from: http://www.linux-mips.org/wiki/index.php/AR7

    I will go a little further on my research before triying, but now I feel the firmware from a few of those clonned modems would work on mine. Plenty of web sites around dealling with AR7 architecture and a Linux version for them so I can have fun and tweack it accordingly to my hardware.

    Looks like I am on the track to get my modem even without Linksys sources.
  14. joseangel

    joseangel Network Guru Member

    Ha, ha, ha, ha. I just found out it even has an standard console I can connect to my com1 with no soldering needed. I can even recover the modem if I brick the modem.

    I just need to be carefull because voltages are not compatable. I need a converter to be able to connect it to the RS232 port on my computer, but at least I do not need to attach anything to the board (I hate soldering)

    It would be close to this one:

    Thanks, Linksys, I am really having fun. :)
  15. Guyfromhe

    Guyfromhe Network Guru Member

    i'm not completely sure that you grasp how hard this is going to be to implement or not, but i'm interested to see if you can manage :)
    and hey as long as your having fun thats all that matters :p
  16. joseangel

    joseangel Network Guru Member

    ADSL2 is takeing its time to come to Spain, so there is still plenty of time to play with this device. :)

    After all it would not be like recodeing everything. It looks like one of the firmwares from other companies could surely be adjusted properly. I am actually building my console connector to recover the device when bricked (I' sure it would get bicked very often).

    The worst case would end up with me having encreased my knowledge on hardware, linux programing and usage and networking technologies. :) Not bad for a worst case scenario, don't you think?

    Of course it would have been much easier if I had Linksys source code. I know by heart the diferences between RFC1483 bridge mode and routed mode both LLC and VC options so changeing a few fields, variable lenghts and functions should had been enough.

    Instead I shall have to have a deep look to two hardware boards, Linksys and the GPL source code one, then translate the diferences to software, then extend it with the features I am missing and cut down what I think shouldn't be there on a modem.

    As I just want RFC1483 LLC routed mode perhaps I should just get Busybox1.0 software and add the ADSL driver and the RFC1483 networking code. But I would prefer to release some usefull firmware for everyone out there looking for an ADSL2 modem (not a router).

    In any case that's a lot of hard work (most of it is adapting firmware from another device), but as I said, there is no hurry and I am enjoying it. :)

    NEXT STEP: Building my console adapter and testing it.
  17. Guyfromhe

    Guyfromhe Network Guru Member

    are you sure that other firmware is going to work on that device, i'd guess not... also you're still going to have a binary image even if it does work so unless the other firmware supports what you want you're in the same boat ither way...
  18. joseangel

    joseangel Network Guru Member

    My guess would be yes because only transformers (adsl and ethernet) differ from one version to the other. Also dram and flash sizes may differ but I will check that first. Also addressing may change, but since both boards are clearly based on AR7 reference design that diference is very unlikely.

    Of course it would make no sense to use just other firmware binary. Actiontec and netgear (?) did release their source code as GPL.
  19. joseangel

    joseangel Network Guru Member

    1st SUCCESS

    Looks like I managed to get clear how to connect to the modem console.

    I still have to do some further testing to release a good enough doc on how to connect to the console, but I managed to get the post messages I would like to share with you.

    Please, feel free to extract data from this post and comment on how much memory you see there, etc. That way I will be able to compare with what I learnt from the hardware board.

    Minimal POST completed...     Success.                                      
    Last reset cause: Hardware reset (Power-on reset)                                                 
    PSPBoot1.2 rev:                       
    (c) Copyright 2002-2004 Texas Instruments, Inc. All Rights Reserved.                                                                    
    Press ESC for monitor... 1                          
    Launching kernel decompressor.                              
    Starting LZMA Uncompression Algorithm.                                      
    Copyright (C) 2003 Texas Instruments Incorporated; Copyright (C) 1999-2003 Igor                                                                               
    Compressed file is LZMA format.                               
    Kernel decompressor was successful ... launching kernel.                                                        
    LINUX started...                
    Config serial console: ttyS0,38400                                  
    CPU revision is: 00018448                         
    Primary instruction cache 16kb, linesize 16 bytes (4 ways)                                                          
    Primary data cache 16kb, linesize 16 bytes (4 ways)                                                   
    Number of TLB entries 16.                         
    Linux version 2.4.17_mvl21-malta-mips_fp_le (root@mandrake.nctu.edu.tw) (gcc ver                                                                                
    sion 2.95.3 20010315 (release/MontaVista)) #                                           
    Determined physical RAM map:                            
     memory: 14000000 @ 00000000 (reserved)                                       
     memory: 00020000 @ 14000000 (ROM data)                                       
     memory: 00fe0000 @ 14020000 (usable)                                     
    On node 0 totalpages: 4096                          
    zone(0): 4096 pages.                    
    zone(1): 0 pages.                 
    zone(2): 0 pages.                 
    Kernel command line:                    
    calculating r4koff... 000b71b0(750000)                                      
    CPU frequency 150.00 MHz                        
    Calibrating delay loop... 149.91 BogoMIPS                                         
    Freeing Adam2 reserved memory [0x14001000,0x0001f000]                                                     
    Memory: 14420k/16384k available (1454k kernel code, 1964k reserved, 99k data, 56                                                                                
    k init)       
    Dentry-cache hash table entries: 2048 (order: 2, 16384 bytes)                                                             
    Inode-cache hash table entries: 1024 (order: 1, 8192 bytes)                                                           
    Mount-cache hash table entries: 512 (order: 0, 4096 bytes)                                                          
    Buffer-cache hash table entries: 1024 (order: 0, 4096 bytes)                                                            
    Page-cache hash table entries: 4096 (order: 2, 16384 bytes)                                                           
    Checking for 'wait' instruction...  unavailable.                                                
    POSIX conformance testing by UNIFIX                                   
    Linux NET4.0 for Linux 2.4                          
    Based upon Swansea University Computer Society NET3.039                                                       
    Initializing RT netlink socket                              
    Starting kswapd               
    Disabling the Out Of Memory Killer                                  
    devfs: v1.7 (20011216) Richard Gooch (rgooch@atnf.csiro.au)                                                           
    devfs: boot_options: 0x1                        
    pty: 32 Unix98 ptys configured                              
    Serial driver version 5.05c (2001-07-08) with no serial options enabled                                                                       
    ttyS00 at 0xa8610e00 (irq = 15) is a 16550A                                           
    ttyS01 at 0xa8610f00 (irq = 16) is a 16550A                                           
     Enter led_init from led_wrapper.c                                  
    block: 64 slots per queue, batch=16                                   
    Using the MAC with internal PHY                               
    Cpmac driver is allocating buffer memory at init time.                                                      
    Default Asymmetric MTU for eth0 1500                                    
    PPP generic driver version 2.4.1                                
    avalanche flash device: 0x400000 at 0x10000000.                                               
     Amd/Fujitsu Extended Query Table v1.1 at 0x0040                                                
    number of CFI chips: 1                      
    Looking for mtd device :mtd0:                             
    Found a mtd0 image (0xa0000), with size (0x360000).                                                   
    Creating 1 MTD partitions on "Physically mapped flash:0":                                                         
    0x000a0000-0x00400000 : "mtd0"                              
    Looking for mtd device :mtd1:                             
    Found a mtd1 image (0x20000), with size (0x80000).                                                  
    Creating 1 MTD partitions on "Physically mapped flash:0":                                                         
    0x00020000-0x000a0000 : "mtd1"                              
    Looking for mtd device :                       
    Found a mtd2 image (0x0), with size (0x10000).                                              
    Creating 1 MTD partitions on "Physically mapped flash:0":                                                         
    0x00000000-0x00010000 : "mtd2"                              
    Looking for mtd device :mtd3:                             
    Found a mtd3 image (0x10000), with size (0x10000).                                                  
    Creating 1 MTD partitions on "Physically mapped flash:0":                                                         
    0x00010000-0x00020000 : "mtd3"                              
    Looking for mtd device :mtd4:                             
    NET4: Linux TCP/IP 1.0 for NET4.0                                 
    IP Protocols: ICMP, UDP, TCP, IGMP                                  
    IP: routing cache hash table of 512 buckets, 4Kbytes                                                    
    TCP: Hash tables configured (established 1024 bind 1024)                                                        
    Linux IP multicast router 0.06 plus PIM-SM                                          
    ip_conntrack version 2.0 (128 buckets, 1024 max) - 364 bytes per conntrack                                                                          
    ip_tables: (c)2000 Netfilter core team                                      
    netfilter PSD loaded - (c) astaro AG                                    
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.                                                   
    NET4: Ethernet Bridge 008 for NET4.0                                    
    Initializing the WAN Bridge.                            
    Please set the MAC Address for the WAN Bridge.                                              
    Set the Environment variable 'wan_br_mac'.                                          
    MAC Address should be in the following format: xx.xx.xx.xx.xx.xx                                                                
    VFS: Mounted root (squashfs filesystem) readonly.                                                 
    Mounted devfs on /dev                     
    Freeing unused kernel memory: 56k freed                                       
    serial console detected.  Disabling virtual terminals.                                                      
    init started:  BusyBox v0.61.pre (2004.10.19-18:15+0000) multi-call binary                                                                          
    Starting pid 9, console /dev/tts/0: '/etc/init.d/rcS'                                                     
    Algorithmics/MIPS FPU Emulator v1.5                                   
     Reading Standard Configuration File /etc/led.conf                                                  
     Configured 17 states                     
    Using /lib/modules/2.4.17_mvl21-malta-mips_fp_le/kernel/drivers/net/avalanche_us                                                                                
    USB: Entering USB_init_module.                              
    USB Driver built for RNDIS protocol only.                                         
    Ignoring bootloader environment configuration.                                              
    VID = 0x13b1            
    PID = 0xf         
    No Serial Number String present.                                
    Manufacturer = Texas Instruments                                
    Product description = Linksys RNDIS Network Adapter                                                   
    USB: Entering USB_Init.                       
    USB: Leaving USB_Init.                      
    Default Asymmetric MTU for usb0 1500                                    
    USB: Leaving USB_init_module.                             
    Using /lib/modules/2.4.17_mvl21-malta-mips_fp_le/kernel/drivers/atm/tiatm.o                                                                           
    registered device TI Avalanche SAR                                  
    Texas Instruments ATM driver: version:[]                                                  
    Waiting for enter to start '/usr/bin/cmcli' (pid 33, terminal /dev/tts/0)                                                                         
    Please press Enter to activate this console. Sep  8 12:00:07 cm_monitor: Monitor                                                                                
    SIOCGIFFLAGS: No such device                            
    SIOCGIFFLAGS: No such device                            
    SIOCGIFFLAGS: No such device                            
    Doing BRCTL ...               
    addbr br0         
    Doing BRCTL ...               
    addbr br1         
    Sep  8 12:00:08 cfgmgr(snmpcm): snmpd starts (1)                                                
    Sep  8 12:00:08 cfgmgr(fdb): Firewall NAT service started                                                         
    Default Asymmetric MTU for nas0 1500                                    
    Default Asymmetric MTU for br0 1500                                   
    Default Asymmetric MTU for br1 1500                                 
    Sep  8 12:00:09 cfgmgr(lanbridge0): Bridge Created: br0                                                       
    Doing BRCTL ...               
    setfilter br0 0               
    Doing BRCTL ...               
    addif br0 eth0              
    Doing BRCTL ...               
    addif br0 usb0              
    Sep  8 12:00:10 cfgmgr(lanbridge0): No Module Description from Interface Below                                                                              
    Doing BRCTL ...               
    addif br0 nas0              
    Doing BRCTL ...               
    addif br0 nas0              
    Sep  8 12:00:10 cfgmgr(lanbridge1): Bridge Created: br1                                                       
    Doing BRCTL ...               
    setfilter br1 0               
    Doing BRCTL ...               
    stp br0 off           
    device eth0 entered promiscuous mode                                    
    br0: port 1(eth0) entering learning state                                         
    device usb0 entered promiscuous mode                                  
    Sep  8 12:00:10 cfgmgr(lanbridge0): Bridge Interface Added: eth0
    device nas0 entered promiscuous mode
    br0: port 3(nas0) entering learning state
    Doing BRCTL ...
    setfilter br0 0
    Doing BRCTL ...
    stp br1 off
    Sep  8 12:00:11 cfgmgr(lanbridge0): Bridge Interface Added: usb0
    br0: port 2(usb0) entering learning state
    Doing BRCTL ...
    setfilter br0 0
    Sep  8 12:00:12 cfgmgr(lanbridge0): Bridge Interface Added: nas0
    Doing BRCTL ...
    setfilter br0 0
    Sep  8 12:00:12 cfgmgr(lanbridge0): Add Bridge Iface Error: 1
    Sep  8 12:00:12 cfgmgr(lanbridge0): Duplicate Bridge Iface: nas0
    br0: port 1(eth0) entering forwarding state
    br0: topology change detected, propagating
    br0: port 3(nas0) entering forwarding state
    br0: topology change detected, propagating
    br0: port 2(usb0) entering forwarding state
    br0: topology change detected, propagating
    Sep  8 12:00:17 cfgmgr(sar): DSL Carrier is down
  20. Guyfromhe

    Guyfromhe Network Guru Member

    hm well if it's running linux you should be able to bug Linksys for the source, you could try that approach... you don't get a console promp on the serial interface?
    have you made any progress?
  21. joseangel

    joseangel Network Guru Member

    Yes, I did make some progress, but I thought I had to write an small doc on how to connecto to the console of this device first.

    By now I found it is Linux with Busybox 0.61 inside (clearly leaving Linksys against GPL with this device) so I reported it to Erik at Busybox.net. Surely he would ask Linksys to release the code, sue them or include them in the hall of shame.

    As a summary of what I found. A few seconds after power on it posts and an emergency console shows up if you press scape within 5 seconds. If you do so you can find flash io mappings (0xB000 0000 - 0xB040 0000), CPU clock (150MHZ), system bus (125MHz), and a few other things I haven't completely analyzed yet.

    If you let the device power on normaly (no ESC key pressed) it boots and when pressing ENTER you get a CLI. Also an enabled CLI can be activated with the password you set on your web interface (by default "Admin").

    While in CLI you can configure manually the modem. ADSL, Ethernet and all other things.

    Also a Linux shell is available. A not fully functional Busybox 0.61 (some commands missing) lets you browse the file system, and have a look around.

    By now I am trying to gather enough information so I can mod Actiontec source code to fit into Linksys' hardware. It should work if I set properly memory mappings and the correct drivers for ADSL and Ethernet are used. Flash may be an issue because Linksys ADSL2MUE has only 4MB flash.

    After that I think I would get a Busybox 1.0 and a linux kernel 2.6 and propper drivers to build my own firmware. Surely including Linux PPP implementations and extending what is already available with the protocol I want (more in the future) like RFC1483 routed.

    Hope next post is the howto on moding the hardware to get the console working, howto build the console cable and basic details on the hardware and software that mades up this small piece of equipment.

    PS: I was wrong when I said ADSL2MUE has 32MB of both RAM and flash. It actually has 4MB flash and 16MB RAM.
  22. ak47hkk

    ak47hkk Network Guru Member

    I too am having problems with the ADSL2MUE. The suggested fix of putting it in bridge mode, does not help me, I still cannot get my ports to be open.

    Which real modem can I buy instead of this ..pardon my french.. POS? (ok it does look pretty and stacks well with the WRT54GS) ;)

    I live in the UK where ADSL is still the cheapest option I believe. And I too would love to be able to "make this work" for me, but with no experience in electronics and no desire either, I'm asking you or anybody who reads this for help :) H E L P

    Phew hopefully that's done the trick, I've had enough of this "modem" problem!
  23. joseangel

    joseangel Network Guru Member

    I guess you read the whole thread and now know I am goin to mod the original firmware to make it become a mode, didn't you?

    First my intentions were to mod another vendor firmware (with source code released under GPL) but now there is something that would speed things up.


    I am downloading it to check if it was not any of the devices under the same part name, but I am pretty confident it would be our belowed 'modem'.

  24. ak47hkk

    ak47hkk Network Guru Member

    Great I'm all for havin a firmware come in and change everything round to make it a real modem...but I am lookin for a quick fix unfortunately.

    I've run outta patience completely. Any ideas which modem to buy? I hate having to, but as I say, my patience with modem probs is completely disapated..

    The firmware fix youre workin on is bang on track for makin me feel better about the situation later on though, it would be nice to make it real.
  25. joseangel

    joseangel Network Guru Member

    Cannot help you with that. I know no other modem as I made the same mistake (that is buying ADSL2MUE thinking it was a modem) but instead of looking for a workaround, I bugged linksys support and messed up around with the hardware to make it work.

    I would, of course, love to release a quick patch to the sources so it behaves correctly. But now, I am not even able to compile the sources and there is a lot to learn about Linux and this piece of software. Networking is my only strength, anything else would need to be learnt (but C language).

    It will surely take me some time to find where is the best place in the sources to make my changes. Perhaps I just need to use what is already there or perhaps I would need to recode certain parts of it, but before all, I first need to know where is done what, and that would take time.

    PS: I will not be able to post a "how-to" on connecting to the ADSL2MUE console because I have no digital camera to show where the connector is placed. When I get it I will post the "how-to".
  26. Moosh

    Moosh Network Guru Member

    Try the Dlink DSL-300T...Amazon usually has a good price. There are others, but all more expensive(in Europe, anyway). Dlink made the same mistake as Linkysys and first released it as basic NAT router. but their last firmware update turned off NAT and the firewall. Now it passes the ISP ip straight to my wrt54gs on PPoA...haven't been able to get PPoE to work. There's evensome 3rd party support, http://mcmcc.bat.ru/dlinkt/, as the fw is also open source. I'll be looking out for a updated f/w for the adsl2 though.
  27. FiveHorse

    FiveHorse Network Guru Member

  28. DocLarge

    DocLarge Super Moderator Staff Member Member

    You can try the x-modem ce from www.adslnation.com if you need a "pure" modem (none of this modem/gateway crap). I believe Dlink stopped selling the particular model above, which is why I bought the x-modem ce. There's a new model coming out, but if you need one, get the x-modem ce; it runs great with my smcbr18vpn router and my wrv54g.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice