Would you recommend that I purchase a WAG54G

Discussion in 'Other Linksys Equipment' started by shard_2k, Aug 6, 2004.

  1. shard_2k

    shard_2k Network Guru Member

    Hi all

    Of all places, this might very well be the last place some of you thought you'd see this post.

    However, it is my hope that current users of this ADSL Gateway could give me some feedbacks on whether or not I should in fact buy it.

    I currently reside in Auckland, New Zealand, and having recently read some of the negative things that has been said of this particular product, especially in the thread http://www.linksysinfo.org/modules.php?name=Forums&file=viewtopic&t=235 which seem to comment especially badly on the ADSL component of the item. I'm somewhat put off about purchasing the unit.

    I was put onto the Linksys brand by a friend who currently owns a BEFW11S4, who basically raves about it.

    Now of course, given the fact that the WAG54G has the additional ADSL modem & firewall, my friend's compliments for his BEFW11S4 will all be for nothing if the modem is in fact unstable.

    So if anyone has any feedback (both the good & the bad are most welcome) about any particular aspect of the WAG54G that they would like to share with me, it would be most appreciated.

    And of course, for visitors that also currently lives in NZ, Auckland, your thoughts on the matter would be greatly treasured (most noteably your experience with setting up the unit).

    And finally, taking into the fact that this section isn't yet flooded with troubleshooting posts for the WAG54G, my opinion of the unit is still quite high at the moment ^^

    Thanks in advance all :lol:
  2. md3v

    md3v Network Guru Member

    Linksys WAG54G

    I own a Linksys WAG54G unit and use it at home with a ADSL connection (PPPoE).

    I like the unit and have had no problems with the ADSL modem BUT I have had problems with the wireless component. Clients randomly disconnect and re-connect to the unit for no reason at all.

    I am using the "original" firmware, version 1.0.6 which seems to be the most stable. DO NOT use the latest version 2.x - its useless and seems to cause the ADSL modem issues you mentioned.

    I am hoping Linksys will get a decent solution to all this problems soon ... right now I cannot publish internal server/s or services with the 1.0.6 fw.
  3. jdepew

    jdepew Administrator Staff Member Member

    We've found on the WRT54G series, that changing the 'Beacon Interval' available in Advanced Wireless Settings from the default of 100 to 50 has helped eliminate that issue with disconnects and reconnects, especially when you are using the Windows XP wireless configuration.

    If that is an option (I don't have a WAG on hand) give that a shot, and report back your results, hopefully we can help others out with the problem.
  4. md3v

    md3v Network Guru Member


    Thanks for touching base.

    I am testing the Beacon Interval using your mod of 50 ms (mili-seconds) on Firmware Version: 1.01.6.

    I'll report back in a couple days and let you know how it goes.

    Is anyone else using the latest WAG firmware been able to get Single Port Forwarding working?

  5. shard_2k

    shard_2k Network Guru Member

    Hey guys, thanks so much for your reply.

    md3v -> I've been scouring the forums at
    apparently, people have had good luck with the new firmware release, 1.02.3_2 is it? Especially in handling the dropped wireless connections. Tell us how it goes will ya?

    And also, I've contacted the supplier that I'm going to buy the item from, and they told me that (and I don't mean any offense by this by the way), that there is probably more brick houses & closer surroundings in UK which aren't so wide spread in NZ. Ok, given that the thicker walls would make the radio signals harder to travel.

    Could I please get an indication as to how many non-UK users are experiencing problems with the WAG54G please?

    And also, is it ignorant of me to assume that the MAC address filtering (as offered by the WAG54G, but not the USR9106) is pretty much fool-proof? As from my own very limited understanding of networking, MAC address are globally unique, which would kind of suggest that only people you allow (i.e. with the correct network card) can get on your wireless network, thus keeping all hackers out??

    Thanks guys, keep those posts coming...
  6. md3v

    md3v Network Guru Member



    I would like to test out 1.02.3_2 BUT the problem is that my current firmware 1.01.6, is not available for download and I have sent multiple emails to Linksys Support in order to find out where I can get it, but have had no response.

    I'd like to have a copy of it in case the 1.02.3_2 causes problems (and I've been told it does).
  7. md3v

    md3v Network Guru Member


    I am using the unit in Thailand - purchased the unit here. As stated... having some problems.

    MAC address filtering is a good addition to WEP/WPA and I recommend its use if its available BUT it is not fool proof. MAC addresses are sent in the clear (Layer 3) and can easily be grabbed off the wire and cloned by anyone wanting to gain access to your network. Yes, MAC addresses are "technically" unique BUT at the operating system/software level a MAC address can be modified. I have written a brief "how to" on MAC address modification, download it at http://www.md3v.com/bin/MAC Address Modification.pdf
  8. md3v

    md3v Network Guru Member

    Firmware Version: 1.02.3


    Ok - I upgraded to Firmware Version: 1.02.3 and changed the Beacon Interval of 50 ms. No disconnects as of yet BUT ... still no luck getting, Single Port Forwarding, Pot Range Forwarding, Port Triggering or DMZ to work.

    I am simply trying to forward an external port (8888) to an Internal Port (80).

    Does anyone have any suggestions on what I need to do?
  9. md3v

    md3v Network Guru Member

    Nudge ... kick....

  10. TazUk

    TazUk Network Guru Member

    Re: Firmware Version: 1.02.3

    I don't believe you can do that, the source and destination ports need to be the same :? If it's to run a local webserver on a non-standard port why don't you just configure the webserver to listen on port 8888 instead of 80 :?:
  11. md3v

    md3v Network Guru Member


    I am trying non standard ports because standard ports do not work ...

    I think its a problem with this firmware version.

  12. shard_2k

    shard_2k Network Guru Member

    Hi guys.

    Thanks for being here. And to jdepew, md3v & TazUk thanks for the replies, and notifying me of future possible prolems as well as solutions for the WAG54G.

    Great appreciated. At the end of the day (yesterday that is :D ) I did buy a WAG54G.

    Thanks all.
  13. md3v

    md3v Network Guru Member

    Port Forwarding


    I found out this morning, after speaking with a senior engineer from my ISP), that they are in fact blocking TCP/80 to end-users, meaning I cannot run a local web server on a 'standard' port. I AM able to run a FTP/Web Server on a non-standard port though.

    Using the latest Linksys WAG54G firmware, 1.02.3 with the wireless beacon set to 50 ms seems to make the unit extremely stable.

    I'm happy once again!

  14. jdepew

    jdepew Administrator Staff Member Member

    Great, glad to hear the 'beacon' setting helped out! I know it immediately gave my XP clients immediate stability!

    Welcome to the club!
  15. md3v

    md3v Network Guru Member

    Fixes with...


    It corrects the issue on computers using WinXP's ZERO CONFIG but computer/s using the Intel Centrino 2100B or 2200BG software still seem to have spastic problems with the WAG54G.

    A temp. fix is to use ZCFG....
  16. thosch

    thosch Network Guru Member

    > Would you recommend that I purchase a WAG54G

    Definitely not. Their support is equal to a placebo.

    I have reported an issue to Linksys support since April and there is still no verification from their side neither they know if it will ever be fixed.

    Bugs I noticed:
    - SNMP monitoring shows only incoming packets, outgoing octects are not increasing properly
    - PPTP forwarding from the internet to a server behind the WAG does not work
    - notification mails are empty
    - when entering 1460 as the MTU size the WAG still keeps 1492
    Workaround: enter a value 28 lower and it will keep the correct value (for 1460 enter 1432)
    - single port forwarding stops working from time to time. Workaround: enter the single port into the port range forwarding - works flawless.

    AFAIK every firmware had those bugs, currently running beta firmware 1.02.3
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice