Discussion in 'Sveasoft Firmware' started by wryoung, Aug 28, 2005.

  1. wryoung

    wryoung Network Guru Member

    I posted this to the Sveasoft Alchemy forum yesterday, but have not yet gotten any response, so I wanted to try this forum as well.

    Sveasoft forum post:
    I am running 2 WRT54GSv1.0 routers. I have been running WDS using WEP 128bit flawlessly for several months. I have done the (weak) security task of disabling SSID broadcast. I would like to move up to WPA to increase the security on my wireless paths both Station to AP and the WDS links. I have not been able to make WPA AES WDS work together. Previously I was running Satori using the WEP, but updated to Alchemy Public V1.0 release to enable WPA PSK. WDS was configured through the browser GUI and works fine, so I think the WDS config is correct. Through the GUI I setup WPA PSK security and my laptop connects just fine to the AP, but the WDS links don't seem to connect. Another thread on this forum suggests setting the NVRAM var


    I did this on both routers via a ssh session and power cycled the router, but the WDS links still do not seem to come up. What am I doing wrong? Is there a step by step somewhere that tells how to configure WPA PSK AES WDS? I have gone back to WEP for now, but really want to get the added security of AES encryption on my wireless links both Station -> AP and WDS AP -> AP.

    Maybe related, maybe not, I have noticed that since going back to WEP I am having a problem with the client station losing it's connection periodically to the AP. This NEVER happen before I moved to Alchemy and started trying to enable WPA. What causes this behavior?

    Thanks to anyone who can help.
  2. 4Access

    4Access Network Guru Member

    If you didn't already do it immediately after the upgrade I'd suggest resetting the routers to default settings and then reconfiguring. (Always a good idea after a firmware upgrade.)

    Out of curiosity have you tried enabling WPA TKIP with the WDS connection? Does that work?

    The nvram variable undoubtedly needs to be customized to your configuration and can't simply be entered as displayed... what thread did you pull that suggestion from?

    Simple solution might be to try DD-WRT instead of Alchemy. I've found v22 of DD-WRT to be a bit more stable than Alchemy for WDS links. (Remember to reset to defaults after the firmware change.)

    Good luck.
  3. wryoung

    wryoung Network Guru Member

    What is the appropriate way to reset the router to defaults? It appears that this can be done via the reset button or via the Web Management. Is one method more thorough or preferred over the other, or do they pretty much do the same thing?

    I tried a lot of different things, so I'm not sure, but I think I tried all three WPA options, TKIP, AES, and TKIP+AES. None of them worked.

    I did modify the nvram variable to set it to the appropriate MAC of the remote router, my SSID, and my passphrase. I got the suggestion from a Sveasoft Alchemy forum thread. Can't find it again right now. It was referenced from another thread I was reading.

    Thanks for the DD-WRT advice. It's only been a week now and so far I have not had issues with WDS stability using WEP. I'm going to stick with the Alchemy version for now and see how things go. If I ever get WPA working, I'll have to evaluate the stability again.
  4. 4Access

    4Access Network Guru Member

    Either is fine.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice