WPA crashes my WRT54Gv3 router

Discussion in 'Networking Issues' started by Veridor, Jun 8, 2005.

  1. Veridor

    Veridor Network Guru Member

    Hi, I'm trying to get my WRT54Gv3 to connect to my D-Link DWL-G122 USB wireless adapter using WPA-PSK with TKIP, but every time I enable WPA, the power light will not stop flashing. I can powercycle the router to get the power light to go steady green, but after this, I can get no wireless connectivity at all. I have tried a Netgear WG111 wireless adapter, to no avail. I have also tried both adapters on another computer; no dice. Both machines have WinXP service pack 2.

    After the "crash", it'll see the network and connect, then drop the connection within 5 seconds. Afterward, it will either see the network and not connect, or will not see the network at all. The only way I've found to get any sort of wireless to work is to reset the router by holding in the reset button for 30 seconds. I'm convinced this is a router issue with WPA becuase I've tried both adapters on different PCs. Also, if I leave security disabled, it stays connected. If I use 128-bit WEP, that stays connected as well (providing that I turn off 802.x authentication in WinXP). However, as soon as I turn on WPA, it starts exhibiting the above behavior until I reset the modem.

    I've tried changing channels, reducing the length of the encryption passphrase, changing the signal beaconing to 50 ms, switching from TKIP to EAS, making sure 802.x authentication is disabled...all to no avail. I would really like to get WPA-PSK working if at all possible, as I am a bit paranoid about wireless security living in a subdivision and all. I have updated the router to the latest official firmware, 3.03.6. Any help would be greatly appreciated, as I am at my wit's end and have already gone through two Netgear WGR614v5 routers trying to get WPA-PSK to work, and would like to stick with Linksys if at all possible.
  2. Mathias

    Mathias Network Guru Member

    Hi, I'm having exactly the same problems with my WRT54Gv2 router and an Intel ProWireless 2200BG network card. The connection works just fine when using no encryption or plain shared-key WEP, but it doesn't work at all with anything WPA Pre-Shared key based: both TKIP and AES are a no go. :(

    At first, I thought it was a user-error, and double-checked all settings: they all panned out. Then I thought: well, maybe it's old drivers or old connection software on the laptop that're causing the problems. I updated both the drivers and the Intel ProWireless connection software, but to no avail. Of course, I was configuring the laptop in another room, and when I entered the room where the WRT-router is located, I noted that a light on the extreme left hand side was flashing. At first, I thought it was the DMZ-light, which was odd, as I don't have DMZ-configured. Upon closer inspection, it was the power led that was flashing instead of the DMZ-light.

    Now, from all that I've read about this router, a flashing power led indicates a serious problem. The funny thing is that both wired connections and the web-based configuration portal were all still available and working well. Upon resetting the router, the power led was solid green again.

    So, for now, I've configured both 128-bit plain WEP-encryption, disabled SSID-broadcasting and installed a MAC-filter list. That's still not enough security for me though. I purchased this router because I knew it supported WPA out of the box, so it would be a pretty tough lesson to learn that it doesn't work with an Intel 2200BG wireless card. It works fine for now, but when trying to configure any form of WPA (TKIP or AES), the power led starts flashing, and there's no wireless connectivity.

    Anyone else seen this problem before and maybe a solution ? Both me and Veridor would be very appreciative for any pointers to a solution or a better explanation about the problem. I should add that I have a HyperWRT firmware, but that shouldn't matter, as it's very close to the official Linksys firmware.
  3. Veridor

    Veridor Network Guru Member


    Well, after several late-night chat sessions with Linksys support, they advised me to upgrade to the latest official firmware. Same issue. Then they sent me the beta firmware. Same issue. As Mathias pointed out, yes, when the power led stays flashing after turning on WPA-PSK (with either TKIP or EAS), I can still use the wired connection fine and access the config page. I have to reset the router to get it to stop flashing.

    So, they told me to get another router. I went to Best Buy and exchanged the router. Out of the box, I'm having the same issue. I have tried both a D-Link and Netgear USB adapter on 2 different PC's, to no avail. For the record, this is the FOURTH router I've had this issue with (2 Netgear WGR614v5's and these two WRT54Gv3's). The ONLY common thread I'm seeing is both machines are running WinXP with Service Pack 2, and with all current updates as of today. I just got off the chat with Linksys, and they rold me to try both the latest official and beta firmwares. So, here I go.
  4. Mathias

    Mathias Network Guru Member

    Re: Update

    Well, I can confirm with certainty that Windows XP2 isn't the culprit of these problems. My main laptop runs Ubuntu linux, and while I rarely use the wireless card in that laptop, I decided to configure it for WPA access. At university, there's no form of wireless security whatsoever besides a MAC-address filter, and at home connectivity to the network is provided by a plain UTP-cable, attached to the docking station for this laptop.

    So, off I went, grabbing the latest linux drivers for the IPW2200 recently sporting WPA support, and recompiling the kernel. After quite a bit of time messing around with wpa_supplicant, I finally managed to get a proper configuration going, but, sadly, the problem persisted. When I tried to associate, nothing happened, but the light on the router wasn't flashing as with Windows XP. Then I figured out that I forgot to modprobe the AES crypto kernel module. After inserting the kernel module and trying wpa_supplicant to get it to associate once more, the power light on the router started flashing again :(. So it seems that whenever you send an AES-encrypted packet to the router to associate yourself with it, the wireless part of the router crashes. After chaning the configuration back to WEP though, the flashing of the power led stops, and there's connectivity again.

    I'm pretty sure it's the router's fault, as after rigorously following multiple guides to get WPA Pre-Shared key based encryption going on both Linux and Windows XP SP2, two independent people with varying hardware have run into the same problem with the same symptom: a flashing power led on the router and a complete lack of wireless connectivity. I'm unsure what to do next. Maybe trying out the power-packed firmware's like DD-WRT or OpenWRT or even Alchemy. On the other hand: the official software should just do what it's supposed to do, and I don't have much time to configure a complex firmware on this router. I'm still hoping for a golden pointer from someone on these forums to get it sorted...
  5. Veridor

    Veridor Network Guru Member

    If it's an issue with the router though, then Linksys and Netgear both have horrible QC for their products, as this is the fourth router I've had this issue with (2 Netgear WGR614's and 2 Linksys WRT54G's). I hesitate to go with anything other than official firmware because I'm scared it'll brick the router. I mean, if it states the product supports WPA, it should support WPA. But, that looks like like it may my only choice at this point.

    Update: I contacted Linksys support again. They want me to call in at this point. She said "you have an odd situation there" and "we can't seem to isolate the issue." I couldn't agree more. But, I dread calling their support (or any support outsourced to India). I'm sorry, but I have a hard time understanding them sometimes.
  6. Veridor

    Veridor Network Guru Member

    Ok, last night I tried Sveasoft's latest build of Alchemy, and while it solved the issue of the power light flashing while trying WPA, I am still experiencing failure to connect when using WPA, as described above.
  7. Veridor

    Veridor Network Guru Member

    802.1x Authentication?

    In my continued wrestling with this, something occured to me. From what I can tell of the specs for WPA, it requires the use of 802.1x authentication. However, when I select WPA on my computer, it won't let me put a check into "Enable 802.1x authentication" (in other words, it is grayed out). Any ideas?
  8. Veridor

    Veridor Network Guru Member

    At the advice of my uncle who's a network specialist for a bank, I downloaded a packet sniffer (Ethereal) to see what exactly gets sent between the router and the adapter. Particularly, he told me to make sure the same MIC (Message Integritiy Check, a.k.a, Michael) was beeing negotiated.

    WHat I discovered is that the 1st packet in the capture, from router to adapter, appears fine. However, the adapter's reply is labeled in Ethereal as a "malformed packet" and appears to have an invalid frame check. Not quite sure what to make of it at this point, but at least it's a start.
  9. nels0360

    nels0360 Network Guru Member

    Same problem here.

    I have two computers that each have a Trendnet PCI Wireless G card in them (TEW-423PI v. A cards). They use the Texas Instruments TNETW1130 chipset and connect to a WRT54G router. Signal strength is very good on both of them.

    However, when I run the computers with WPA encryption enabled, they will randomly drop the wireless connection multiple times per day. I have to repair the connection to get it working again. The wireless works fine when I leave the network open.

    Thinking it was a router problem, I tried 2 WRT54G routers (one v. 2.2 & one v. 3) and a Belkin Pre-N router. The situation occurs with all of them. One of the WRT54G I tried worked just fine for six months with a Dell Inspiron 600m & a Apple PowerBook at a different location. I have of course tried the latest drivers and firmware.

    There is also a Vtech phone system in the house with one base and six handsets, but they didn't interfere with the wireless B network I had installed and they don't interfere when the Wireless G network is open. Therefore, I highly doubt it is the phones.

    I'm thinking of going with different wireless PCI cards as a next step. I've tried different channels and everything. Any other ideas? Thanks.
  10. Veridor

    Veridor Network Guru Member


    Not quite sure how this worked out, but I have it working now.

    Basically, I bought a D-Link router to use in concert with my D-Link USB adapter. At first it did the same thing as the Linksys, but, lo and behold, once I had D-Link support on the line and they had me try it, it worked. It held the WPA connection for several minutes before I shut down the PC. Go figure.
  11. flopez

    flopez Network Guru Member

    hi all,

    I'm sort of experiencing the same problem. I have a wrt54gv2 router and i have the latest official linksys firmware on it (3.03.6) and when i wanted to try out WPA with it, it did that same wierd power light blinking thing when i enabled WPA. However, when i turned off WPA, the blinking power light turned solid. I enabled WPA again and i power cycled the router, which stopped the power light from blinking and when i tried to connect my 2 PC's upstairs, (one has a linksys WMP54Gv4 pci card, the other a linksys WUSB54Gv1) by configuring them with the windows xp wireless network setup wizard and a USB Flash Drive they all worked. No connections dropped at all. These wierd WPA problems might have something to do with the adaptors being the same company or maybe the windows xp wireless network setup wizard changes something to make it work. :?

  12. moi666

    moi666 Network Guru Member

    Hi guys,
    I got wind of this thread from the helpful folks at hyperwrt.org.

    Router : WRT54G v2.2 with Tofu11 & WPA-TKIP & MAC address filtering
    Client : Intel 2200BG 11g adapter and Intel Proset Wireless software v9.0.3 in notebook running Win2k SP4

    When I set the encryption to WPA-TKIP, no IP address is obtainable ( The 2200bg can detect the wireless signal fine but cannot obtain an IP address.

    Running "ipconfig /renew" gives a "DHCP server unreacheable".

    When I turn OFF WPA-TKIP (ie no encryption) then the client can obtain an IP address!

    Has anyone ever experienced this issue, and gotten a fix? I just noticed Intel posted v10 drivers and I may give that a try (sigh).
  13. SAPo57

    SAPo57 Network Guru Member

    sometimes WPA is difficult to configure devices with and even some dont support it. I can configure any router, but takes time. For my simple home network I just use a WEP encryption which is more easy to connect devices with and for security purposes I would enable MAC filtering. If your DHCP is unreachable too then it might be turned of or you'll have to set your pc or notebook to manually have the WPA or WEP key, password,etc. that your router has.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice