WPA Encryption Causing Wireless to Drop? WRT54G

Discussion in 'Cisco/Linksys Wireless Routers' started by nels0360, Jun 11, 2005.

  1. nels0360

    nels0360 Network Guru Member

    I have two computers that each have a Trendnet PCI Wireless G card in them. They connect to a WRT54G router. Signal strength is very good on both of them.

    However, when I run the computers with WPA encryption enabled, they will randomly drop the wireless connection multiple times per day. I have to repair the connection to get it working again. The wireless works fine when I leave the network open.

    Thinking it was a router problem, I tried 2 WRT54G routers and a Belkin Pre-N router. The situation occurs with all of them. I have of course tried the latest drivers and firmware.

    I'm thinking of going with different wireless PCI cards as a next step. I've tried different channels and everything. Any other ideas? Thanks.
  2. xcaliba

    xcaliba Network Guru Member

    Same Problem

    I am having the same problem, just sat on support for 30 mins to find out what happens. I can use two the two computer independently however when both are connected using wpa the connection drops. Support said to use wep and sent me the new firmware but not happy with this solution.
    It seems as though it is the router though, and only when there are two connections using wpa
  3. kdude

    kdude Network Guru Member

    WPA Problems

    I am using 3 computers with the WRT54G and the Linksys beta firmware and a mixture of WPA-AES and WPA2 without any significant problems. And this is in a house where I was having many problems previously using a Netgear router. The 3 computers all use different adapters which is why I haven't switched to WPA2 entirely.
  4. Mathias

    Mathias Network Guru Member

    Re: WPA Problems

    Say kdude, what wireless adaptors do you use to connect ? Besides that question, are you using WPA Shared-Key authentication, or some form of external RADIUS server ? I'm asking, because I can't for the life of me get any laptops to connect to my WRT54Gv2 using anything but WEP. The instant one tries to associate with AES or TKIP, the power light on the router starts flashing. I am using a relatively old version of HyperWRT (2.0b3) though. Are you saying WPA didn't work before you flashed to the beta firmware, and, if so, where did you get said firmware ?
  5. nels0360

    nels0360 Network Guru Member

    Re: Same Problem


    What kind of cards are you using? My trendnet TEW-423PI v. A cards use the Texas Instruments TNETW1130 chipset.

    If it were the router, why would it happen with the Belkin Pre-N router too
  6. xcaliba

    xcaliba Network Guru Member

    I am using one intel pro 2200b/g and one netgear usb g adapter. Two different brands completely. There was absolutely no problem on my old netgear 614, but as soon as both are active on the linksys the linksys dies.
  7. nels0360

    nels0360 Network Guru Member

    Does it drop your connection immediately when the second client connects? Or does it just happen eventually with both clients connected?

    I've had two wireless clients connect to this router before but they didn't have the trendnet PCI card..they were laptops. I didn't experience any problems then.
  8. xcaliba

    xcaliba Network Guru Member

    Since it has happened the first time I have no longer been able to connect via wpa. This includes two firmware updates, several hardware resets, and the power plug being yanked for an hour in frustration.
    I have spoken to linksys again and they said it could be a "bug" with the intel adaptor (sounds like rubbish to me) and are sending me a new beta firmware to try.
    Currently I am connected via 128 bit WEP and havent had a problem, even with two computer running, and have uploaded about 5 gig to my server without a bump wirelessly at the same time as browsing and transfering files to the other wireless pc.
  9. xcaliba

    xcaliba Network Guru Member

    Has anyone having this problem used another firmware say alchemey or hyperwrt and does the problem still exist? I am willing to use another firmware, but would like the problem fixed.
  10. kdude

    kdude Network Guru Member

    WPA Problems

    I'm using the following adapters (sorry I can't recall all the model exactly just now)

    Netgear PCI in desktop
    Intel 2200bg miniPCI
    IBM a/b/g miniPCI

    All of the drivers are the latest I can find. I have the WRT54Gv3.

    The firmware I have tried with success are the official Linksys & HyperWRT releases and the unofficial Linksys beta (low clock rate only). I have been using the Linksys beta because of it's support for a mixed WPA/WPA2 environment but WPA worked with the others as well. The linksys beta should be in the downloads section of this site.

    Not sure of this is particularly helpful as my experience with wireless has shown me that everything is particular to exactly which adpaters/routers/firnware/drivers you are running.
  11. nels0360

    nels0360 Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice