WPA stopped working

Discussion in 'Cisco/Linksys Wireless Routers' started by JeffDay, Jan 24, 2005.

  1. JeffDay

    JeffDay Guest

    The WPA on my WRT54G (V2) has suddenly stopped working! Here is the story...

    In the New Year I bought this wireless router and set it up to work with my new Sony Vaio. I wanted to use WPA-AES Personal with a 63 bit key. At first this wouldn't work for WPA with the installed XP & SP2 on the laptop, but after installing Intel's own wireless driver this worked ok.

    For the last 3 weeks I have been using this setup quite happily with no problems to speak of. (The only grumble came from my wife who complains that the WLAN led flickers every 5 seconds or so all night and disturbs her :) )

    Yesterday, as normal, I turned on my laptop, but this time there was no wireless connection available. I have altered nothing...it was working fine, so I had no need to change anything. However after checking things out I have identified the only difference between now and when it was working the night before...

    At idle, when set to WPA working, the WLAN light on the router no longer flickers every 5 seconds or so. If I set the router to operate with either no security or with WEP then the WLAN led flickers every 5 seconds when no other activity is taking place. If I set my laptop in the same way then it gets a network connection no problem. The moment I change the router security back to WPA then the WLAN led stops flickering and the laptop cannot connect.

    I tried powering down the router for about 5 minutes and then re-powered but this made no difference.

    In summary...
    I altered nothing prior to the failure
    I am the only user on the network and machines
    WPA has worked fine for 3 weeks and then just suddenly stopped
    The WLAN led has suddenly stopped flickering every 5 seconds at idle
    WEP & no security work fine (and the led flickers)

    I have done the following since the failure to no effect...
    Re-powered the router
    Re-checked all settings
    Changed the beacon rate to 50ms
    Changed the key (tried various combinations and key lengths)
    Tried various values for the key timeout including zero
    Tried AES and TKEP

    I have not tried resetting to factory defaults and rebuilding. This would be a pain and I want the problem resolved...I don't want to have to rebuild every 3 weeks!

    Also I have not touched the firmware, which was supplied at 2.02.7, which I believe is the latest UK version.

    If anyone has any bright ideas I would love to hear them. I really don't believe the issue is with my laptop, as I cannot see any difference in behaviour with it (other than it cannot connect!). But with the router its behaviour has definitely altered, so I believe this to be the area to investigate.

    Many thanks

  2. stighenning

    stighenning Network Guru Member

    Strange. Don't know why really...Might be your antenna.. and conditions.
  3. atp

    atp Network Guru Member

    Me too!

    WPA-PSK had been working fine for me since Christmas time, last night I tried to connect to my internal network and it failed.

    Now, I probaby haven't tried to connect for a week or so, prior to that it had "just worked" every time. I eventually switched to No Encryption - it was fine, then to WEP - it was fine. WPA? Nope, that failed again.

    So for now I am on WEP.

    My laptop is an HP one, with WLAN built in. The WLAN chipset on the laptop must be Atheros, as there is an "Atheros Client Utillity" in the system tray.

    How about you?

  4. atp

    atp Network Guru Member

    Should have said - Linksys F/w v 2.09.1
  5. howardp6

    howardp6 Network Guru Member

    I could not get WPA-PSK working on my daughters Dell D600, which used an Intel 2200BG card, there seems to be a problem with the way the Intel client software implements WPA-PSK in either AES or TKIP. I could connect with my Linksys and Bufflotech devices, but not with the Intel minipci card. Check the Intel website to see if there is newer firmware and client software for the card.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice