WPA wont connect, WEP connects fine?

Discussion in 'Cisco/Linksys Wireless Routers' started by Maranello, Dec 22, 2004.

  1. Maranello

    Maranello Network Guru Member

    Im using a WRT54G router latest firmware (linksys) and a WPC54GS PC card latest drivers. OS is XP Pro. Connecting the card to the router via 64 or 128 WEP I have zero problems. Connection under WPA-PSK isnt happening.

    The SSID is set the same on both systems.


    Set WPA-PSK
    set passphrase
    set TKIP (tried AES as well)

    WPC54GS:(linksys software)
    Set PSK
    set passphrase the same as the router
    Matched TKIP/AES to the router
    Confirmation on save screen shows everything the same and shows encription as WPA

    On a connection attempt I get "waiting for keys" and it disconnects, it keeps doing that in a cycle. Everything on the screen under that error (linksys software link tab) shows exactly as I set it except for encryption. Its showing as PSK-Radius. That is the choice that was below pre-shared key in the linksys software when your going through the setup wizard... however that is not the one I picked or that showed up on the confimation screen before a save and connect attempt.

    Ive tried SP1 and SP2, WZC disabled using Linksys software, Linksys software disabled using WZC. Ive tried changing the authentication to shared key... which works with WEP but does not work with WPA. Ive googled just about every phrase I can think of, tried the Linksys support faq... but nothing. If anyone knows how I can connect this I would appriciate the help. Thanks.
  2. howardp6

    howardp6 Network Guru Member

    Check to see if 802.1X authenication is disabled. You can find it if you click the wireless connection icon, and select the properties control button and select the wireless networks tab. You can select your wirelss network and cilick the properties control button and select the authenication tab. It is diabled as a default, but you should try ti check the setting.
  3. Maranello

    Maranello Network Guru Member

    Yes, it is disabled.
  4. Maranello

    Maranello Network Guru Member

    OK... heres where I stand. I finally got WPA-PSK to work... but not with my Linksys software.

    I had to remove the card, then the G wireless Linksys software and drivers and the Odyssey program and delete the wireless connection. Rebooted, inserted the PC card, installed the drivers only from the Linksys CD and used WZC to configure my WPA-PSK connection to my WRT54G. Ive changed it several times now (ssid, passphrase, channel, tkip/aes) and its connected every time.

    For some reason the Linksys software just wouldnt connect as WPA-PSK instead always trying to connect as WPA-RADIUS (unless it was set for WEP). I tried a couple different versions of the software and router firmware (all linksys) and it still tried using radius.. who knows.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice