WPA / WPA2 trouble on WRT54GS v5.1 firmware 1.50.8

Discussion in 'Cisco/Linksys Wireless Routers' started by dacull, Aug 6, 2006.

  1. dacull

    dacull LI Guru Member

    I have a WRT54GS V5.1 (I thought I was getting one of those nice linux ones but ended up with the stunted later version).

    Most things seem ok so far, I managed to get connected okay. However since upgrading to firmware 1.50.8 I just cannot seem to connect using WPA or WPA2 from an intel 2200bg chipset laptop. I have tried all combinations, and using either AES or TKIP but with no joy. I remember having it up and running fine with the initial firmware version. Should a firmware upgrade really kill WPA WPA2 ?

    Everything is setup correctly, shared key is matching, I run on channel 11.
    WEP and Open work fine, but WPA WAP2 refuse, it appears to connect, but then no IP ever comes across from the DHCP. I have linux on another laptop using a rt2500 chipset (ASUS W104-g) and that doesn't work either (although there is another problem I am currently debugging there for the rt2500 device driver authors).

    Does any one have any suggestions on what this can be.. I don't fancy downgrading the firmware (if i can find the original) as there are a couple of changes I would like to keep.

    Any suggestions advice gladly received :) :thumbup:
  2. Toxic

    Toxic Administrator Staff Member

    if the other unit (ASUS) doesn't work either then i guess the Laptops drivers are not conforming to the WPA/WPA2 standard. have you tried other drivers?
  3. dacull

    dacull LI Guru Member

    2 x laptops, one with a built in intel 2200bg wireless, the other with a PCMCIA ASUS wireless , neither work with WPA or WPA2 against this new linksys (after firmware upgrade) makes me suspect the linksys. I tried updating the drivers for the 2200bg and still no joy...
  4. dacull

    dacull LI Guru Member

    I solved this problem finally though doing a full reset (using the button), power recycle, reflash, full reset, power cycle, reflash and redo all settings. No a single crash and everything works great.

    Apparently its not good to flash an upgrade if some of your settings dont sit well with the upgrade so its safer to flash from a reset router.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice