WPC54G "Device Cannot Start"

Discussion in 'Other Linksys Equipment' started by Stadsport, Mar 14, 2005.

  1. Stadsport

    Stadsport Network Guru Member

    I got this card (Wireless 54-G v2.0) for Christmas. It was working fine up until about two weeks ago. Suddenly whenever I'd be online, with this card of course, the mouse would act jerky and everything would sort of lag a little bit at the time. After restarting, Windows prompted a Found New Hardware dialog saying it had found a new Network Controller. I tried to install it using the included drivers (even though it had never been uninstalled or anything), but it said it couldn't find any drivers. I took it out and put it back in. As soon as I took it out the mouse continued to move smoothly and everything. I put it back in and the lights on the device didn't even come on.
    After repeating similar cycles, every once in a while it would popup in the device manager saying "The device cannot start."
    I tried another adapter, some old SMC 802.11b adapter, and it worked fine.
    On the hunch that this was a software issue, I went ahead and formatted and reinstalled Windows. When I first got this adapter, I was using Windows 2000 SP4, and later upgraded to Windows XP Pro. When I formatted, I reinstalled Win2k, tried it with and without Sp4.

    So any ideas? Do I just have a dead network card?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice