WPC54G doesn't work with D-Link DSL routers??

Discussion in 'Other Linksys Equipment' started by darkobserver, Mar 7, 2005.

  1. darkobserver

    darkobserver Network Guru Member

    Hi everyone

    I bought a new WPC54G notebook adapter card and tried to get it to connect to my 11 MBit/s D-Link 614 DSL router. It just won't work! The adapter never sees the AP. I d/l the latest drivers searched the Net but to no avail. OS is XP Home.

    Could it be that the two products just won't work together? If yes that's pretty crappy, since my old 11 MBit/s ELSA airlancer card worked with the D-Link router without problems.

    Also, when I try to set the data rate of the adapter to 11 MBit/s manually via the properties dialogue, the program will hang and I have to kill it via task manager. Any ideas about that?

    Thanks very much in advance
  2. darkobserver

    darkobserver Network Guru Member

    Um...hello? Doesn't anybody have an opinion about my problem? Does anybody at least know if there's a known incompatibility between Linkysys and products of other manufacturers?

  3. howardp6

    howardp6 Network Guru Member

    Do you have any type of ecryption. If you are using two different brans of wireless equipment, some things may be implemented differently.

    For example, paraphase key generators produce differnet keys between manufacturers, so copy the key generated and use the same key on your router and wireless adapter.

    Some manufacturers use ASCII or hexadecimal keys. Linksys uses only hexidecimal, so, if your router uses both specify hexidecimal keys and make certain that the key length is the same. If your adapter has four keys or your router uses four keys, use tha same key in the first key and use the same encryption WEP or WPA-PSK.

    If you have MAC address filtering on your router make certain the the MAC address of your wireless adapter is in the list of PCs allowed to access the router.
  4. darkobserver

    darkobserver Network Guru Member

    Howard, thanks for replying.

    The trick was to enter the essid and WEP key in the Windows wireless configuration by hand. Only then would the adapter connect to the router although it never pops up in the "available wireless networks" window. Go figure...


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice