WPC54G giving limited or no connectivity

Discussion in 'Other Linksys Equipment' started by Devileyezz, Mar 5, 2007.

  1. Devileyezz

    Devileyezz LI Guru Member


    I have a WRT54GL (Tomato 1.04).
    And I'm able to connect every other wifi adapter to it with full security (WPA/WPA2) or even no security.

    However, this WPC54G just doesn't connect. WPA2/WPA/WEP and no security, it just doesn't do it. Connects with a limited or no connectivity error.

    I disabled mac filter and even rebooted the router, to no avail.
    Can someone please help out?

    PS: Drivers have been reinstalled and all that jazz. XP pro sp2.
  2. HiSpeed

    HiSpeed Network Guru Member

    Which WPC version ?
    Which driver version ?
  3. Devileyezz

    Devileyezz LI Guru Member

    If the number after the hyphen is the version, then it's 2.

    Driver was installed by www.linksys.com/connect
  4. HennieM

    HennieM Network Guru Member

    Go to the adapter's "Properties > Wireless Networks", and delete all the networks you find there, make sure you use Windows Zero Configuration to configure your wireless net, then try again.

    If it still does not work, delete the networks, then uninstall, reboot, re-install the driver. Check that there are no defined networks, then try to connect.

    Make sure you use a latish driver, such as the Broadcom drivers - a link to that somewhere on this site.

    Note though, that in my experience, and in general, the WPC adapters have way less range than other adapters, so get a bit closer to your AP.
  5. Devileyezz

    Devileyezz LI Guru Member

    Actually, my apologies.

    The version is
    And ver date is, 2/18/2005.

    And, HennieM, I followed all your steps - except the 'latish' drivers. I'm gonna look for them now.

    Also, I have 5 full bars of signal, and I'm not far at all from the router. :)
  6. HiSpeed

    HiSpeed Network Guru Member

    WPC54G v2 has a Texas Instrument chipset !
    If your WPC54G has a Broadcom chipset (see my page) uses the Broadcom driver with XP !
  7. Devileyezz

    Devileyezz LI Guru Member


    I tried using those drivers.. it just doesn't work.
    Installing them itself is a big hassle.

    Know of an easy way to install them?
    Cuz seems like there's some old drivers in the system32 folder already that it is automatically installing. :S

    The serial number is BDH10CA27037.
    FCC ID: PKW-WPC54G-2.
  8. HennieM

    HennieM Network Guru Member

    If you can somehow get the drivers unpacked somewhere on your HDD, you can update the driver by telling XP you "Have disk...", and then browse to where you unpacked the driver. XP will find something like BCMWL5.INF, which refers to the actual driver BCMWL5.SYS. This way you install just the driver, without all the perephenalia that comes with the driver.

    This is assuming your card has the Broadcom chipset. I have a WPC54GS ver. 2, and it uses those drivers, so I would think the G uses the same drivers.
  9. HiSpeed

    HiSpeed Network Guru Member

    With BDH1xxxxxxxx you card is a v1.1 !
    It is sometime difficult to install the Broadcom drivers.
    If the HennieM's suggestion doesn't work, uninstall completely the card, delete all the BCMWL5.SYS and BCMWL5.INF files under Windows directory and try to reinstall with the new couple of files...
  10. Devileyezz

    Devileyezz LI Guru Member

    Have tried that. Just doesn't wanna work. When it upgrades the driver, it asks for reboot.

    When I reboot, I see it as half-installed in the device manager (yellow exclamation icon on it)

    And when I pull out and plug the card back in, it gives the half device sound, lol.. like a double half beep.

    You sometimes get that sound when you put in a device that is USB2.0 in a USB1.1 slot.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice