WPC54G v2 & AES

Discussion in 'Other Linksys Equipment' started by Anonymous, Mar 5, 2005.

  1. Anonymous

    Anonymous Guest

    After purchasing the WPC54G v2, I was disappointed to notice that it evidently doesn't support AES. I'm using the Linksys Network Monitor v2.1 (also tried Funk Odyssey), and driver v6.0.0.18.
    Linksys' website has the product data sheet for this card, which lists security as: WEP, AES, TKIP, 802.1x. The user guide, that came with the card, as well as the user guide posted to the website, speaks about AES as a selection. And the Network Monitor application, prompts you to choose, "from either TKIP or AES," only that AES is not listed in the drop down list.
    From my reading posts, it appears that v2 doesn't support AES, while some other WPC54G versions do. The problem is that Linksys makes it very unlikely that you'll realize this before purchasing the card. Between their website, userguide, software, as well as all their retail channel partners listing AES as a supported protocol, you're destined to purchase the card and be disappointed once you attempt to configure AES.
  2. Esquire

    Esquire Mesquire Staff Member Member

    See if there is AES support through Windows XP WZC.
  3. howardp6

    howardp6 Network Guru Member

    The Linksys driver does not support WPA-PSK, there was a Funk Odyssey Client that was supplied with the adapter. You only get WPA-PSK only with the Funk Odyssey client not the Linksys client, until Linksys updates it client to support WPA-PSK. This is true for the latest WPC54GX also,
  4. clavel

    clavel Network Guru Member

    I don't see AES as an option through Windows XP WZC, only TKIP.

    The Linksys driver that I referred to in my original post does support WPA-PSK (TKIP), as that's what I'm using now. When I attempted AES through Odyssey (using the SDK version, as supplied by Linksys), no authentication took place. This is how I first realized the issue. At the time I wasn't even using the Linksys application.

    In the Network Monitor application, I was prompted to choose, "from either TKIP or AES," only that AES is not listed in the drop down list.

    I contacted Linksys and received the following response:
    "...AES is supported with the previous version which is WPC54G Version 1. There is no driver yet for the version 2 wireless-g adapter that supports AES as on the moment. Keep posted from the website for any updates with regards to the device. You can go to www.linksys.com...
    ...We don’t have yet the actual time when will the driver be release for the WPC54G to support AES. I’m sorry for the confusion it made...."

    This doesn't really manage expectations, though, leaves it likely that others may potentially experience the same confusion, and obviously disappoints me as I relied on their website's product description to make the purchase.
  5. Esquire

    Esquire Mesquire Staff Member Member

    The confirmation is unfortunate, but not unexpected from Linksys. This isn't the first time they didn't check for accuracy when updating product description on a new product version.
  6. howardp6

    howardp6 Network Guru Member

    Please download and unzip the latest driver for your WPC54G v2 from the Linksys Support Website or check the CD that contained the driver. Linksys included a Funk Odyssey Client to use. It supports WPA-PSK AES or TKIP. Do not use the Linksys WLAN client. There was a folder Utility in the driver download, if you unzipped it. Install the Odyssey client and setup a session on it with the SSID and encryption and that should give you what you want. :p
  7. earthsound

    earthsound Network Guru Member

    latest driver does not support AES

    Unfortunately, this will not work. The latest driver ( available on Linksys' web site contains only an Funk Odyssey SDK plugin, not a full client. I haven't tried the 30 day trial version of the client.

    When I ran across this problem, I received similar replies from the Linksys live chat support:

    "Thank you for waiting. The WPC54GV.2 does not support AES."
    "The previous version of WPC54G is the one that supports AES."
    "There is no driver yet for the higher version that supports AES."
    "I'm sorry about the confusion but I double check it here and we don't have a driver yet that will supports AES for the WPC54GV.2."
    "We don't have the exact time or date for the drivers. "
    "As of now there is no beta drivers."

    After speaking to Linksys level 1 tech support, they said they would email me a beta driver to test on that adapter card. I am supposed to get it within 24 hours. I'll post if it helps...
  8. earthsound

    earthsound Network Guru Member

    After waiting a few days & receiving no email, I called Linksys' technical support number, and was told, again, that a senior tech support person would email me a beta driver for this card and that it would arrive within three hours.
    It, too, never came.
    Calling yet again tonight, I spoke with level 2 tech support who confirmed that a beta for the WPC54G v2 card was available, but after being placed on hold for about an hour, I was informed that AES was not supported in versions 2 or 4 of the WPC54G cards, only version 1 supports AES encryption. I was also told that lack of AES support was not a driver issue: AES is a hardware implementation in the adapter and that is why even the beta driver does not "enable" AES.
    Unfortunately, the level 2 tech could not answer why the data sheet for version 2 of the adapter had incorrect information, and said he would forward that problem so that the data sheet (and presumably all other printed materials regarding versions 2 and 4) would be updated to reflect the fact that AES is not supported, as is currently claimed.
    Additionally, the tech could not answer why an older version of the adapter supports the better encryption algorithm but the newer versions do not. Asking what, specifically, was different in the hardware (chipsets) between versions 1 and 2/4, that resulted in the lack of AES, I was put on hold, again, and when he returned, he said that the hardware in WPC54G v1 & v4 support AES (a contradiction from his earlier statements), but that only the driver for v1 currently supports AES. He confirmed that a future driver for v4 would support AES, but reiterated that v2 does not b/c of hardware, not software, issue(s). He didn't know the chipsets used in the various versions of the adapter & told me to call during the day to speak to a level 2 tech that could answer that question (I had initiated the call just after midnight, CST & tech support is in PST).
    They offered to RMA the version 2 card for an older version 1 card in order to have AES encryption support.

    After that discussion, a quick, cursory search online shows that WPC54G v2 is based on the Texas Instruments ACX111 chipset, either TNETW1130 or TNETW1230 (I'm not 100% sure at this point)...both of which support AES in the hardware. Fishy...

    I'll call again and see where this leads.
  9. howardp6

    howardp6 Network Guru Member

    The difference was the driver from Linksys does not support WPA-PSK natively. The WPC54GX driver was released initially with only the Linksys driver and a Funk Odyessea client that provided WPA-PSK. The Linksys client did not only supported WEP. Later Linksys release a new driver for the WPC54GX and the client which supported WPA-PSK natively. It did use the Aegis Protocol 802.X. So when Linksys advertised that the WPC54G supported WPA-PSK they meant it did with the Funk client. Hopefully they will go the path of the WPC54GX and release a new driver with the Aegis Protocol 802.X in the near future.
  10. Owen_Stubbs

    Owen_Stubbs Network Guru Member

    Pardon my newbie ignorance, but is the difference between TKIP and AES a big deal? Running W2K, it does not appear that WPA is even an option for me, but my brand new WPC54G card will hopefully live long enough to find itself into an XP machine that does support it, and I would like to believe it will be capable.
  11. howardp6

    howardp6 Network Guru Member

    For the differences between TKIP and AES I would suggest you go toe the Wifi Org website or go to the Microsoft website. There are excellent whitepapers on those sites and on the web on the subject. Both are relatively secure and definitely more secure than WEP. If you have at least WEP, most people would not waste their time trying to access your wireless connection. It would not take long to break WEP encryption and it would take much longer to break WPA-PSK either TKIP or AES. As for W2K, eventually Linksys may incorporate WPA-PSK into the driver of your WPC54G, or you can get the Funk or Aegis clients. I would use 128bit WEP for now and wait for Linksys or spring for the costs of Funk or the Aegis client.
  12. earthsound

    earthsound Network Guru Member

    Aside from AES being cryptographically more secure, the tests I've seen show that it is less resource intensive than TKIP as well as resulting in (usually) higher throughput (though it differs among the various routers, gateways, adapters, of course).
  13. Owen_Stubbs

    Owen_Stubbs Network Guru Member

    Thanks for the replies.
  14. earthsound

    earthsound Network Guru Member

    Contrary to what Linksys told me earlier, all versions of the WPC54G adapter support AES in the hardware. However, only v1 has a public-release driver that enables AES support. V4 has a beta driver available, but v2 has an alpha driver that is currently being tested that will support AES. The ETA for the beta for v2 is unknown, though I am now set up to receive the beta when it becomes available...
  15. hhawkman

    hhawkman Network Guru Member

    FOUND wpc54g V2 Driver with AES

    I found this surfing the other day, and it works with a V2 Card:


    I'm using Xp with SP2, I just extracted the DRIVER subdirectory of the zip, and force installed the drivers (let me choose what driver to install), and it works fine. Interesting note. They are linksys drivers. version funny how linksys never released them. They work with WPA2, and AES. Check them out.
  16. bimbobo

    bimbobo Network Guru Member

    ..Ok you found WPA2 on this new driver, but what about the AP/Router...
    I have WAP54G and the WPC54G V 1.2 but the AP does not support WPA2 anyway....
    Can you please explain?
  17. neoyoyo

    neoyoyo Network Guru Member

    In the WRT54G (with Linksys v3.03.6 firmware), you can choose "AES" as "WPA Algorithms" in "the Wireless / Wireless Security" section.

    For the WAP54G, it's the same thing (I've read the on-line documentation ;) ).
    But in a French online shop (here), I've read that a firmware's upgrade is need to have that feature enable.

    After this, you'll have to choose the same parameter in the driver of your WPC54G.
  18. bimbobo

    bimbobo Network Guru Member

    .... :eek: forgive the very stupid question, but is WAP AES the same as WPA2? If so, I can choose WAP AES in WAP54G and WPC54G too...
    A real "NEWBIE" :)
  19. neoyoyo

    neoyoyo Network Guru Member

    This is not a very stupid question ;)
    Look at the comments of this news, because littlewhoo give us the response to this question :thumb:
  20. bimbobo

    bimbobo Network Guru Member

    ..thanks for "accepting" what I thought was a stupid question! :)
    So the original firmware 2.08 from Linksys WAP54g and the driver for WPC54G do support WPA2 alias WPA AES, as I was using it, before my AP died trying to change the firmware to a 3rd party one! :cry: :cry:
    Thanks for the info...
  21. pharma

    pharma Network Guru Member

  22. bimbobo

    bimbobo Network Guru Member

    ..I saw the link, but still cannot find a link to the WPA2 update..
    I have SP2 and all other updates on my PC...
    What about AES encryption so.. I'm getting confused a bit :(
  23. clavel

    clavel Network Guru Member

    Re: FOUND wpc54g V2 Driver with AES

    Wow, I'm happy I checked back on this thread. For me I wasn't completely clear on why AES wasn't previously supported on the v2 card-- because of drivers or at the chip level. At the time, after searching soooo many posts which concluded it as a hardware limitation, and talking on the phone with linksys, who "acknowledged" to me that it was at the hardware level that AES wasn't supported. So I gave up hope of a driver, figuring I'll just continuing using TKIP. But this didn't turn out to be true. Last night I installed the driver as instructed and it worked for WPA AES and WPA2 AES as well. Thanks hhawkman! :thumb:
  24. notedfuturist

    notedfuturist Network Guru Member

  25. neoyoyo

    neoyoyo Network Guru Member

    You're lucky : it's Christmas today too !
    You can download the file from this location : http://dl-3.free.fr/52616e646f6d495...WindowsME_Windows2000_WindowsXP__Standard.zip
    The bitrate is limited but it's 100% free and without ad ;)

    Note : If the file isn't downloaded over one 24 hours period, it will be destroyed.
  26. Nickie

    Nickie Network Guru Member

    This looks like just what I've been waiting for... But am I too late?

    I've searched everywhere for hours and cannot find another copy.

  27. neoyoyo

    neoyoyo Network Guru Member

    Yes, see my "note".....

    So I've upload this in MegaUplaod, I'm not sure of this site, but ths is the only free server that I have found
    The link is http://www.megaupload.com/?d=QESVF0L0
  28. Nickie

    Nickie Network Guru Member

    :thumbup: Thank you!!!

    It's downloading now, slooow, but steady. :) I'll see if I can get it on my server, later today.

    Would be awesome for a lot of unlucky v2 owners if we could get it hosted here at linksysinfo...

    Although, I think that all we really need is the driver folder...? That would begreat, because it's only 1.18 mb unzipped, so can be e-mailed...

    I wonder why zyxel removed it?
  29. notedfuturist

    notedfuturist Network Guru Member

    Thank you very much Neoyoyo.
  30. fozrun

    fozrun Guest

    Re: FOUND wpc54g V2 Driver with AES

    How do you force install the drivers? I'm using XP SP2. I downloaded the files and then used the hardware driver control panel and selected update and browsed to the downloaded folder. However it did not recognize the drivers. Exactly how do i force install a driver? Any help appreciated.

  31. neoyoyo

    neoyoyo Network Guru Member

    Re: FOUND wpc54g V2 Driver with AES

    I suppose that Windows does not allow you to upgrade your driver because you try to upgrade with a "Zyxel" driver while your current driver is a Linksys.
    So you can try to uninstall your Linksys driver/utility, next reboot your computer and then install your card with the Zyxel drivers.
    This is how I get my v2 work ;)
  32. spyderco

    spyderco Network Guru Member

  33. cedricseah

    cedricseah Guest

    I can't seem to access the Abocom website. Links to this driver are down, could anyone kindly re-upload / host the file somewhere if they have it?

    Thanks in advance ^^;
  34. ofbarea

    ofbarea Network Guru Member

    I wonder if these guys will release Vista x64 drivers...
  35. EneergE

    EneergE LI Guru Member

    I can't get it to work

    I've tried that latest driver posted and I can't seem to get it to work. I uninstalled the linksys driver, and the whole card powers off - which is probably what it is suppose to do.

    Whenever I install the abocom/Zyxel drivers, it never powers back on and so it never even looks for a signal. I installed by right clicking on the inf file and clicking install. I also tried to use the "add hardware" in control panel, but it says that the driver contains no information on this kind of hardware - which is why I done it the other way. I also tried installing it using the installer in the Utility folder, but that didn't power it on either. Soo...

    I've installed the CyberTAN drivers listed on windows update. That driver powers it on and everything works fine, except I can't connect to my WPA2 network (although it detects it). How exactly do you get this thing to work with WPA2? I'm exhausted and thinking about buying another card. :confused:
  36. EneergE

    EneergE LI Guru Member

    Ok, I got it now I think

    Ok, I finally got it to working good now - I think.

    What I did is I went to Windows Update in IE.
    Selected Custom Update so that it would check for hardware.
    It found CyberTAN Wirless Network Adapter
    I installed that driver.

    I open device manager and navigate to the network adapter.
    Went to properties and found out that the drivers it was using were:

    Now I went into the folder where I extracted the Zyxel drivers and went to the "Drivers" folder. I found all three of the drivers listed above in that folder. So I copy the drivers from the Zyxel "Drivers" folder to C:\windows\system32\drivers - choosing to overwrite the current files. After that, everything has worked marvelously! WPA2 fully functionally.

    Thanks for the drivers!

    PS - If you only extract the Tnet1130x.sys driver into the system32\drivers\ folder, your mouse will freeze up while connected to the network. I'm guessing the extra FwRad drivers help maintain the power settings or something like that to keep everything working correctly.
  37. EneergE

    EneergE LI Guru Member

    If you have no internet. You can also manually edit the TNET1130.inf so that you do not have to install the cybertan driver first.

    In order for this to work. You must go into device manager (devmgmt.msc). Right click on your wireless adapter and click properties. Go to the details tab. Now find your cards ID #. It will look something like: PCI\VEN_104C&DEV_9066&SUBSYS_ABA013D1

    Note it down. Now open tnet1130.inf. Scroll down to the [TexasInstruments.NT.5.1] label (about half a page down from the top). Now change one of the %TIACXBG_MINIPCI.DeviceDesc% values to your hardware's ID. Now you should be able to install the driver.

    Right click in device manager on the wireless card again, then click update driver. Select the new edited tnet1130.inf and it will install. You may have to rename a few files for it to copy everything as well. For an example: tnet.sys to tnet_xp.sys or something like that.
  38. hayes_nch

    hayes_nch LI Guru Member

    can somebody link the driver again?
  39. novice973

    novice973 Guest

    I just experienced the same problem. The router is setup to use AES and there is no option for it on the adapter. I called tech support and they said wpc54g v2 does not support AES. I need to get a different adapter. I asked if there is driver I can download to fix this and was told no. I can't find the driver you were talking about. Can someone repost it? Thanks.
  40. hayes_nch

    hayes_nch LI Guru Member

    Re: EneergE

    I have download the abocom driver at http://www.abocom.com.tw/download_count.php?id=877&file=wmg2k4_7.0.1.33.zip
    Then I tried to follow the 2 methods your mention
    In the 1st method, the abocom driver does not contain "Tnet1130x.sys"
    It only contain:
    • FwRad16.bin
    • FwRad17.bin
    • FwRad19.bin
    • t1130_9x.sys
    • t1130_XP.sys
    • tnet1130.cat
    • TNET1130.INF
    • tnetwcoinst.dll
    So the 1st cannot work with abocom driver

    In the 2nd method, I follow everything as you said. I check the card ID and it is
    do i need to put down the whole thing or just the first part??
    Also which file do i need to rename? I rename t1130_XP.sys to tnet_xp.sys but it doesn't seem to be work?

    Or can you post the Zyxel again? All the old link cannot work anymore....thx
  41. DD123

    DD123 Guest

    Active Dl Link


  42. EneergE

    EneergE LI Guru Member

    Sorry for the delay

    Here's a link to the drivers only, which is all you need: http://www.eneerge.net/downloads/wireless_driver.zip

    Make sure you're cards inserted.

    To install on my laptop just now, all I had to do was:
    - Go into device manager (devmgmt.msc)
    - Expand Network Adapters and then Right-Click on "Network Controller" that had an exclamation icon on it and select "Update Driver"

    A Hardware Update Wizard shows up:
    - Select install from a specific location (Advanced)
    - Search for the best driver; Check "Include this location in search:" and then enter the location that you extracted the drivers to.
    - Click Next.

    It begins install, and then an error will show up that says cannot copy file T1130_XP.sys. While installing it tries to locate the driver in another location, all you need to do is:
    - Re-enter the location you extracted the drivers to or click on browse and navigate to the correct folder and file.

    This should get your device working. Be sure to download the WPA2 update from Microsoft, or you can download from here. You may already have this update, but it won't hurt you to go ahead and install again.

    Also, be sure to configure your router to allow your laptop's mac address if you're using MAC filtering. This is off, by default, but if any of you turned this on don't forget about that.

    If it tells you that the file does not contain information about your hardware, you will have to edit the INF file. I posted earlier on how to locate and edit that file. I'll monitor this thread for a few more days to see if any of you are still having problems.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice