WPC54G Ver. 2 Troubles

Discussion in 'Other Linksys Equipment' started by tomwbro, Oct 26, 2006.

  1. tomwbro

    tomwbro LI Guru Member

    I have a problem that I've been trying to figure out for weeks, and Linksys' Tech Support has been no help.

    The Error Message:

    "The WLAN monitor utility and drivers for the WPC54G have already been installed." (I've seen this error posted on other threads before, but still haven't been able to resolve my issue.)

    The Computer:

    I have an IBM Thinkpad T23 that originally had Windows 2000. The Linksys WPC54G Ver. 2 Notebook Adapter was working properly under this operating system.

    What Happened:

    I decided to upgrade to XP, so I:

    1.) Uninstalled the Wireless-G notebook adapter software using "Add/Remove Programs."

    2.) Defragmented.

    3.) Installed XP from a Windows Upgrade CD-ROM.

    4.) Brought my version of XP completely up to date by downloading updates from microsoft.com.

    Then I attempted to reinstall the driver for the Linksys adapter. I popped in the CD-ROM (without the wireless card installed), clicked Install, and I got the error message stated above.

    What I've done:

    After browsing some forums, I decided I needed a registry cleaner to get a fresh installation. I asked Linksys to email me one about 6 times and they never did. So, I downloaded RegCleaner, CCleaner, AMUST, WinSysClean, and EasyCleaner. All programs found and fixed problems with the registry. With RegCleaner, I was able to select the files I wanted removed. I removed the three files I found related to Linksys.

    Now I thought I was ready to install the Linksys software. I popped in the CD-ROM, clicked Install, and I got the same error message.

    When I plug the wireless card into the computer, nothing happens. Device manager says, "The drivers for this device are not installed. (Code 28)." If I try to reinstall the driver from Device Manager, it says "The name is already in use as either a service name or a service display name."

    Many thanks for any advice you can offer.

  2. HiSpeed

    HiSpeed Network Guru Member


    WPC 54G v2 uses the driver file "tnet1130x.sys" under "windows\system32\drivers" !
    Try to check it...
  3. tomwbro

    tomwbro LI Guru Member

    Yes, I have TNET1130.sys and TNET1130x.sys files in the folder at C:\WINNT\system32\drivers. What does this mean? Should I delete these two files and try the installation again?
  4. tomwbro

    tomwbro LI Guru Member

    Ok, so I removed the two files mentioned in my previous post from the drivers folder and tried the installation again. It still didn't work. Any ideas?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice