WPC54GS Trouble!

Discussion in 'Other Linksys Equipment' started by liortal, Jun 22, 2005.

  1. liortal

    liortal Guest

    Hello all!

    A friend of mine has trouble using the WPC54GS.

    She's running a Dell laptop, put in the WPC54GC of someone and it worked flawlessly.

    After which she went to Radio Shack bought one for herself, installed it, and it doesn't work (says: "Connected to AP but can't find internet!").

    What on earth could be the cause of this??

    She tried it with the same very card before and it worked, so how come a new out-of-the-box card won't work?

    if anyone can give me some advice i'd appreciate it.

    Thank u
    Lior tal.
  2. wempie

    wempie Network Guru Member


    I ran into the same issue with my sister's Toshiba notebook, using the same setup. I didn't have the ability to swap cards however.

    What appeared to be the issue in her case was that the Linksys utility was not saving the security information correctly. After going back and correcting this it finally started to connect to the AP.

    The Linksys utility showed the same message you metioned. After about two to three minutes of letting it sit there it finally detected the internet. This is probably due to her notebook being over 5 years old, and running slow. Now the connection is running great and works everytime. She just has to wait the couple of minutes for the notebook to load everything.
  3. Eugenios

    Eugenios Network Guru Member

    The most simple answer is that your new card is not getting an IP address. It connects to the accesspoint but without an IP address you can't access the Internet. First see if you have DHCP enabled for you pccard. If so, then try using a static IP address.

    If you don't know what I am talking about get someone who knows to help you!
  4. lanwarrior

    lanwarrior Network Guru Member

    I am having the same problem with my WPC54GS, a PC-card 802.11G with Speedbooster.

    I have setup the card properly, with the latest software and correct SSID and WEP key. However, after each reboot, the software will say:

    "You have successfully connected to the access point but no internet can be found".

    I have tried setting the IP to static and use DHCP, but to no avail. In order to make the card work again, I have to either a). leave the machine in the above state for 30 MINUTES, or go to "Profiles" and edit the information with the SAME settings (WEP, SSID, etc.). After that, everything works again.

    I use a WRT54GS Linksys Router with the latest firmware. All my 4 other systems (laptop and desktop) using other Linksys Wireless card (PCI-based) and built-in Intel Wireless card (Dell, Sony, HP) works fine, EXCEPT the Linksys WPC54GS PC-Card above. I've swapped the card 3 TIMES, and the store (CompUSA), but same result.

    Any ideas?
  5. 4Access

    4Access Network Guru Member

    If you're using the Linksys utility for configuring your wireless settings try disabling the Windows Wireless Zero Configuration service. (Run -> services.msc -> Open the properties for "Wireless Zero Configuration" and set the Startup type to Disabled -> Reboot)
  6. lanwarrior

    lanwarrior Network Guru Member

    I've tried that, and it's still no go.... this is really weird... I am sure it's not a bad card, and it's probably the software, as the card can connect to the AP just find and even get an IP.
  7. Eugenios

    Eugenios Network Guru Member

    I assume you have XP on your laptop with SP2 installed (service pack 2). Otherwise you might consider doing a clean install of XP/SP2 on your laptop and the first thing you should install is the pccard. If your other wireless devices had a problem connecting to your Router/AccessPoint then the problem could be there, but since you say that the other devices work perfectly then you should try with a clean Windows installation.

    If your laptop drive has two partitions, do a Norton Ghost of your first partition and save it on the second partition. This way, if everything fails, you can restore your C drive easily! :D
  8. lanwarrior

    lanwarrior Network Guru Member

    I think I found out how to rectify the problem (for the moment): I disabled "Wireless Zero Configuration" and Linksys Wireless Utility, and I can get connection so far.

    There are probably conflicts between the 2, but I will try to find out what's the main issue here. So far, at least I am connected.
  9. 4Access

    4Access Network Guru Member

    Sometimes disabling the Linksys utility and using the Windows configuration tools instead (especially if you have SP2) works better.
  10. Eugenios

    Eugenios Network Guru Member

    Depending on the version of the Linksys PCcard you have. My PCcard is version 2 and doesn't work well with the Windows utility.
  11. lanwarrior

    lanwarrior Network Guru Member

    I think mine is Version 2. I am running Windows 2000 Pro.

    But the solution that I mentioned earlier is not a complete solution. Sometimes I have to shutdown/restart the Linksys tools more than 5 times before I get connection.

    Linksys Tech. Support is useless.. :(
  12. Eugenios

    Eugenios Network Guru Member

    Hmm, I am using XP/SP2 which is a completely different story. It's true though that Linksys support isn't good. They should be making updates on their drivers at least once a month but they just don't seem to care. My PCcard driver is dated 10 March 2004!!! They just don't care...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice