WPS54G firmware 6047 w/WPA Available Here!

Discussion in 'Other Linksys Equipment' started by jdepew, Mar 23, 2005.

  1. jdepew

    jdepew Administrator Staff Member Member

    Thanks to user cnegron we have available the latest firmware for the WPS54G Wireless-G Print Server.

    So far we know that this supports WPA-PSK.

    Unfortunately, I have the still as yet not updated WPS54GU2, so I cannot check this firmware out. If you have seen any other enhancements let us know!

    Download ver 6047 in the Downloads Section -> HERE.

    NOTE: This firmware is NOT for the WPS54GU2

  2. howardp6

    howardp6 Network Guru Member

    Like beta version 6046 only supports WPA-PSK TKIP not AES,
  3. Bradford

    Bradford Network Guru Member

    Sorry I'm not quite clear? My WPS54G-UK has firmware 6046 with WPA-PSK/TKIP only (no AES). (It came out of the box that way.)

    Does firmware 6047 support AES? I'm inferring from howardp6's post that it doesn't.

    If not then no other obvious changes?

    Would this firmware work properly on the WPS54G-UK (United Kingdom) Printer Server anyway?
  4. howardp6

    howardp6 Network Guru Member

    There may have been problems with firmware 6046, but since there is no documentation on firmware 6047, we will not know until an official firmware release. Actual 6046 was release as a beta, even through it it was installed on some WPS54G's. You would lose channels twelve and thirteen. If you choose to do a firmware upgrade, connect the WPS54G to your network with a Ethernet cable, while you do the upgrade.
  5. mykmelez

    mykmelez Network Guru Member

    firmware flashing failed three times

    I tried to flash the firmware on this device from 6046 to 6047, but it failed three times. The first two times my browser timed out waiting to hear back from the print server, and when I went to reload the print server admin page there was no change in firmware version.

    The third time the print server actually shut down--all LEDs went dark--and I had to unplug it and then plug it back in to get it back up and running. Note that per instructions I did have the print server plugged into my router with an Ethernet cable while I did the firmware upgrade.

    The three failures don't appear to have affected print server operation, since I can still send jobs to my hp LaserJet 1012 through the print server, and they mostly print fine. The only problem I'm having is that one machine, a Mac OS X laptop, can only print one page at a time of a 13 page PDF file. If I try to print more than one page at a time the second and subsequent pages never print. The same document prints fine from my Linux laptop, though, so it's not a general problem with the print server.
  6. howardp6

    howardp6 Network Guru Member

    Re: firmware flashing failed three times

    Hopefully you unzipped the file for thw firmware and did not attempt to use the zipped version of the firmware.
  7. mykmelez

    mykmelez Network Guru Member

    Re: firmware flashing failed three times

    Yes, I did unzip it. The archive was called Appj08_6047.zip, and it contained one file, APPJ08.BIN. That's the file I uploaded to the device in an attempt to upgrade its firmware.

    Note that I did this on a Linux laptop running Firefox, which *shouldn't* make any difference, but you never know. More likely, version 6047 was never intended to replace version 6046, rather it's an upgrade for an earlier version of the firmware, and it doesn't work as an upgrade from version 6046.

    I should note that although I initially thought I needed version 6047 to do WPA, apparently version 6046 also supports it. Complaints from netizens about the lack of WPA support in these devices were based on earlier versions of the firmware. I'm not using WPA now, but I will in the future. Still, it doesn't look like I need this firmware upgrade to use it, so I'm going to stop trying to upgrade my firmware and start enjoying my new print server.
  8. howardp6

    howardp6 Network Guru Member

    I had firmware version 6046 on my WPS54G and it upgraded sucessfully. No you did not need version 6047 to get WPA-PSK it was uncluded in firmware version 6046.
  9. jdepew

    jdepew Administrator Staff Member Member


    glad to hear you found a solution that works for you!

    Let us know how you like the print server, and if you have any other problems that you encounter with it.

  10. bandido

    bandido Guest


    I upgraded to firmaware 6047 and I can't use wirelles now, only rj45. Where can I find the 6046 firmware ? Thanks.
  11. NightRage

    NightRage Guest

    semi successful upgrade

    the upgrade process went smoothly, however it didn't fix the problem i was expirencing.

    When i put in my wep keys (128 bit hex) it will only save the first key.

    I don't have that key setup as the default on my other equipment, and i don't have any intention of doing it.
  12. surfnmadness

    surfnmadness Network Guru Member

    Well, I tried to load the WPA option, screen will not stay long enough to make the changes. I tried to disable WEP and even stop the page as it loads. As soon as the Cisco logo loads at the bottom, the device seems to think it need to get rid of the WPA options. So, 6047 firmware does not seem to enable WPA just yet for me.

    *** Update - Found that WPA does work in Infrastructure mode, but no Adhoc. Option just is not there for Adhoc.
  13. jdepew

    jdepew Administrator Staff Member Member

  14. Advis

    Advis Network Guru Member

    I've got a WPS54G with 6046 firmware and am having problems updating it to 6049 as I'm getting an error message : Upgrade fail! Please make sure your upgrade file is correct. I get a similar message in Bi-Admin util. Any ideas? If anyone has the 6047 firmware binary could you get in contact as I'm thinking it might need to be upgraded to that before 6049.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice