WPS54G setup

Discussion in 'Other Linksys Equipment' started by wcrofut, Oct 17, 2006.

  1. wcrofut

    wcrofut LI Guru Member

    I can not setup HP8450 printer on Dell Inspiartion 6000 with WRT54G router and WPS54G. WPS54G works wired and I can ping the the WPS54G.
    IP addres of WPS54G is When I insert the CD and try to setup the printserver, it can not find the print server. I installed the computer driver and tried to install printer with out luck.

    Any help would be greatly appreciated

  2. Paul_T

    Paul_T LI Guru Member

    Me too:
    Linksys help tech. had me try to use the downloaded utility also in addition to the Wizard but cannot get the hardware recognized by the router/computer. In my case a WRT54g upgraded and a HP a620n amd box. This is the second WPS54g we've tried but comp. store doesn't have any more in stock. Seems like a lot of people are changing out WPS54g's a reason they're OOS. The second linksys tech asked if the box had a version nr. She also tried to find the WPS IP address in the WRT54G router/switch but the WPS is not listed in the router. The two WPS's I tried did not have version Nr's.
    The WPS power light is on, ethernet on and blinking, wireless light OFF, power on, USB ON.
    My printer a Samsung CLP-510 color laser according to Samsung tech folks should NOT have any problems.
    I'm also waiting for help.

  3. CoryB

    CoryB LI Guru Member

    I recently setup a WPS54G.

    After a lenghty call to tech support, who were looking for any reason to claim hardware incompatability we were headed towards updating the firmware when the call was dropped. They also had successfully connected to the WPS54G with the bi-admin utility at that point.

    I then proceeded to update to the current firmware on the Linksys website (6049 as of this post). That went without any problems. I then found the included CD no longer worked correctly as before the firmware update I could connect to a WPA network and afterwards the only choice was WEP. I then downloaded the setup wizard dated 7/25/2005 with a file name setupwizwpa2.zip.

    Using that setup wizard I was able to configure the WPG54G to connect to the network. I then disconnected for ethernet and was able to print from a client connected to the network by ethernet but not any of the wireless clients.

    I eventually found a setting in the router (WRT54G) that I had enabled to prevent communication between wireless clients. I turned that off and then everything could print.

    Hope that helps out anyone that runs into the same problems I did.
  4. ofbarea

    ofbarea Network Guru Member

    Another source of problem happens when you migrate to Vista. Basically linksys does not have any updated software for the plain Vista x86 or Vista x64.

    If your printer is supported under Vista (my Epson Photo R220 is using newer epson x64 Vista drivers), then the WPS54G will work using the standard TCP/IP printer ports.

    Right click your printer and go to Properties.

    Click on the Ports Tab, click on Add Port.

    Choose Create a new port and select "Standard TCP/IP Port", then click Next.

    The Add Standard TCP/IP Printer Port Wizard will popup, then click Next.

    Enter the IP address of the Print Server and click Next.

    Now select Custom and click on Settings.

    Select LPR for the protocol and type L1 or L2 (USB) for the Queue name.

    Accept the changes and exit the wizard.

    3 pc´s are using my print server, one laptop using XP SP2 (configured as lan manager print server), a Desktop using Vista Home and another desktop using Vista x64 ultimate.
  5. keesp

    keesp Guest

    Remember to switch between wired and wireless


    I have just completed setting up the WPS54G with an Epson C1100 Aculaser (I hope) on Vista and did this following this thread (especially the guide of Ofbarea). The only thing that I did not do correctly (I think) is power off/on the print server after setting up the print server using the wired connection to the router. According to the new setup utility on the linksys site you need to power off/on again when switching between wired and wireless mode. The utility that was shipped with the server does not mention this, and the fact that you will see a print server added to your network gives a false impression that all went well. So as an additional help I will just include my settings:

    1: Connect the print server to your router using a cable (wired)
    2: run the setup utility shipped with the WPS54G (the newer one did not allow me to leave the passphrase field blank in order to enter my own WEP security code)
    3: The personal settings I used were FIXED ip-address settings, even though my router assigns ip-addresses. This seems to work ok (I set my ip-address to xxx.xxx.xxx.14), where the xxxés were the default settings of the print server
    4: after setting up ping to your ip-address to check if the connection is made
    5: disconnect the cable between print server and router and power off the print server
    6: power off the printer
    7: power on the print server. Check if the wireless LED blinks every now and then. This means that the wireless connection is in operation. A steady light usually means that there is no connection (you can test this by pinging to the print server)
    8: power on the printer
    9: ping to the print server again to see if the connection through wireless works ok
    10: if so, you can now set up the printer according to the post of ofbarea.

    Hope this may help some others win the time I lost!

    Good luck
  6. ps130951

    ps130951 Guest

    WPS54G wireless printing

    Hi Guys

    I've just got myself a WPS54G and I just can't get wireless printing on it. I'm connecting to a Canon MP600 and using a Netgear WTR54G router. I've got the drivers for the printer installed and I can print via the printserver when its hardwired to the router. As soon as I remove the network cable from the print server, then I cannot see it anymore on the network and I thus cannot print to it wirelessly.
    I can see the ip as when connected to the router and I have run the Xp setup to completion. But when I try pinging the ip using wireless, I get no reply. I;m folloqing the guide but just can;t see the printserver once its not hardwired. I would think the IP would change from when its h'wired to the router to when its on wifi, is this the caseor am I meant to do the initial connection w/o connecting to a router? What is the standard IP for the printserver after resetting?

    Many thanks
  7. maplefan

    maplefan Guest


    had the same prob you have to change the ssid (standard: linksys) into the ssid of your router (maybe netgear) then it must work
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice