WPS54GU2 will not connect wirelessly

Discussion in 'Other Linksys Equipment' started by Jay911, Feb 15, 2005.

  1. Jay911

    Jay911 Guest

    Maybe I'm misunderstanding the concept of the WPS54 here - I hope I'm not! - but I thought I could connect this thing to both my wired and wireless networks at the same time and have it accept print jobs from both.

    If that's the case, will someone tell me how to enable wireless, please?

    I have given it a static address on my home LAN ( I was able to print a test page fine from my main (wired) machine. I can also print just fine from applications, as I could when I had the printer directly connected.

    I've been in the setup wizard off the CD, the Web-based setup, and the BiSetup program, and I keep trying to set my wireless connection up, to no avail. I'm using a WAP54G access point; I've tried disabling WEP, using 64bit WEP (my previous default) and now 128bit WEP, and it seems to have no effect on the outcome. I am using a non-default SSID (i.e. something other than linksys), and a non-standard channel (9). This works fine for any of the other wireless devices on my network (an HP laptop with built-in Broadcom card, etc).

    When I set up the print server in Infrastructure mode, with the right WEP key (or no key, when trying with WEP disabled), the WLAN light never lights up. The others go dark and then relight, after the server has rebooted itself, however.

    When I set up the print server in Ad Hoc mode, the WLAN light comes on immediately after the LAN light, during the print server's reboot cycle. Of course, since I am using an access point and not an ad hoc network, this doesn't help.

    I have confirmed this device has the latest firmware. I've even reflashed it with the latest just in case, to see if it needed a kick. No luck at all.

    Am I doing something wrong? Am I misunderstanding the abilities of this device? Any help will be greatly appreciated! :)
  2. howardp6

    howardp6 Network Guru Member

    Which do you have a WPS54G or a WPS54GU2? To set up the WPS54G or WPS54GU2 wirelessly , you must first connect the printer to your network and use the setup wizard to search for printservers that have not been set up , if it has not been set up previous and has the default setting or to search for printservers that have been set up. The wizard will walk you through the setup, you should set the SSID, Channel, Infrastructure or Ad-Hoc mode and the encryption. The difference between the WPS54G and the WPS54GU2, are two the first is that the WPS54G only has a USB2 printer port, while the WPS54GU2 has both a USB2 and a parallel port and can support two printers. The other difference is that the WPS54G can support WPA-PSK TKIP in addition to WEP. if it has the correct firmware. The firmware that does not support WPA-PSK TKIP is 6045, and the one that does is 6046. The earlier models shipped with 6045 and the later models shipped with 6046, which is not available for download at this time. You may be able to get a version of it if you talk to a level three support person. It is only available on request and do not say, who sent you. Is is supposed to be a beta version, but as I said before some of the newer models have it. It will not work with the WPS54GU2, which has firmware version 6032. Now after you set it up, you should power it down for a least thirty seconds and power it back up with out the Ethernet cable de-attached. At that point it is setup wirelessly and the wireless LED should blink.. The set up wizard does not support WPA-PSK TKIP and should not be used, if you use that ecryption.

    You can use the Bi-Admin Management Utillity to set it up also, but it will prompt you for a password. The default password is admin in lower case. Set up everything and initialize the printserver. Then power it down without the Ethernet cable attached for at least thirty seconds and the wireless LED should blink. The Bi-Admin Management Utility does support WPA-PSK TKIP.

    If you re-attach the Ethernet cable and power it down and up I believe it will not hook up wirelessly. That would explain the behavior you are seeing.

    Do not use the Websetup, it has some problems and I do not recommend it for setup. The WPS54GU2, also loses its setting periodically, it may be due to power spikes or something else.
  3. c-naptik

    c-naptik Guest

    I'm having another problem here. I have two WRT54G's linked via WDS, working fine. When I set up the WPS54G connected to my wired network, I can print any document fine. My printer (Brother HL-1250) is listed in the Print Server Utility. But as soon as I want to do it wirelessly (after unplugging the WPS54G and starting it again as to enable the wireless LED), the Print Server Utility can no longer detect my printer. Since it cannot be detected, I can't print anything either.
    I've tried many differents settings, changing IPs, changing AP's...either way (wired or wireless), I can ping the WPS54G fine from my computer. In the wireless mode, printing a test page from the web interface works, too.
    It seems that the Print Server Utility cannot resolve the WPS54G's name in wireless mode. Is it due to my WDS link? Or something else?
    If I plug the wire back in, restart the WPS54G, things are back to normal and the Print Server Utility sees my printer.
    What am I doing wrong, any ideas? Thanks for your input.
  4. csm101red

    csm101red Guest

    WPS54GU2 - Wireless does work!!

    Hi All, just to say thank you for these threads. I use a WPS54GU2 and confirm that wireless does indeed work with this device. I had the same issue at first in that it was set up to use the wireless network, but just didn't work (and LED not lit) - only printed when connected with ethernet cable.

    However, as I've just discovered by following the advice already given, if it is set up and working connected by cable (and it has already been configured to work wirelessly - with WEP and all other settings), it's just not working wirelessly and LED is not lit, then simply remove the Cat5 cable, then the power cord - leave for 30-60 seconds, then plug the power cord back in, but NOT the Cat5 cable.

    You'll see that after a few seconds.....the WLAN LED starts flashing!!

    (Wireless printing should now work - I use it with 128 bit WEP and its fine)

    I also have to say that as I've lost the supplied CD with the bi-admin management utility, I've only used the web interface to configure it - and had no problems at all with it (in fact it's a very simple way to set it up)

    :) Thanks again and best of luck.....
  5. clarryA

    clarryA Guest

    WPS54GU2 Not Rceognised

    I have been looking for info on getting one of these beasties to work on my home network. I bought it becasue I thought it would be easy to setup give that I have a Linksys Router WRT54GS already in use.
    I am running Windows XP-Pro on all computers on the network.
    I want to use the print server in wireless mode as all the wired ports on my Linksys router are being used.
    I have tried all kinds of things including some help from the Linksys help WWW site. But the Print Server steadfastly refuses to be found on my network. If I temporarily connected it via LAN everything works OK and my Epson R310 prints OK via the print server. Could it be that the wireless section is simply dead. It is located downstairs in my house no more than 20-feet from the upstairs router.
    The installation utilities provided on the CDROM also fail to locate the device and hence cannot complete the setup.
    I have tried connecting via my web browser by entering into the address bar but it cannot find or connect to the print server. It connects to my router OK using
    I did press the print server reset button with the USB printer connected and the printer printed a status page out. That at least told me what looks like a few default settings for the print server but none of that worked either. Says the server is on Channel 13 so I set the router to that channel also. But no good.
    Any help here will be appreciated. Linksys have given up saying that my printer is not compatible and is untested but I know it works OK when in LAN mode.
  6. howardp6

    howardp6 Network Guru Member

    If you re using encryption, try disabling it when the WSP54GU2 is connected to your LAN and disable the encryption on your router and save your settings on the printserver. Power the WPS54GU2 down after disconnecting it from your Lan, Power it back up and if the WLAN LED blinks, it should be connected to your router. It only supports WEP encryption, so if you are using WPA, you are out of luck, you need a WPS54G or a WPSM54G, the latter is supposed to support multifunction printers
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice