WRE54G V1 New official firmware 1.06.05

Discussion in 'Other Linksys Equipment' started by limesoft, Nov 9, 2005.

  1. limesoft

    limesoft Network Guru Member

    Good news for those who is having WRE54G V1!!!!!
    Linksys now release a latest firmware for WRE54G v1. It can repeat broadcom chipset's. The V2 now still in testing.

    A Division of Cisco Systems Inc.

    Firmware Version History

    11/08/2005 Firmware version 1.06.05

    1.) Broadcom Universal repeater mode supported

    2.) Updated access point and router compatability

    1/12/2005 Firmware Version 1.04.17

    1.) Official Release
  2. jdepew

    jdepew Administrator Staff Member Member

    THanks for the news - I'll get it up right away!

    Now if we can only figure out what that updated router compatibility involves.
  3. Subah

    Subah Network Guru Member

    What is that mean ? :shock:
    Please can you explane it to me ? :cheerup:
  4. howardp6

    howardp6 Network Guru Member

    It means that you cna repeat signals from any Broadcom chipset based access points or routers not just the limited Linksys products, I was able to get my WRE54G to repeate a Buffalotech access point with the older firmware.
  5. Xtreem

    Xtreem Network Guru Member

    If this is the firmware i just downloaded it also made WPA work correctly with it :cheering:
  6. ChickenMadras

    ChickenMadras Network Guru Member

    Hi there,

    I downloaded the new firmware 1.06.05 yesterday for the WPA security. I wish I hadn't!

    It's no longer possible to access the WRE54G. I've tried resetting it via the reset button, powering it off for 30 secs, then turning it on again and using auto config. I've taken WEP off my router and repeated the process, but still no joy.

    I did manage to get into it (almost) using the Setup CD, but wasn't able to access the device setup where you enter the SSID, WEP etc because it wouldn't let me past the enter password step. Neither admin nor the password I set originally would work.

    Is there any way to revert to the previous firmware? If so, how do I do it bearing in mind I can't see the darned thing via IP. The unit works because my Toshiba's wireless scanner can see the WRE54G transmitting quite happily.

    As an aside, the blue Link light is now red. Does this have any bearing on the matter?

    Many thanks in advance for any suggestions,

    All the best,
  7. ChickenMadras

    ChickenMadras Network Guru Member

    BTW, I think it's a V1 unit - manufactured 07/2005, s/n mgb005710062
  8. swallow

    swallow Guest


    Hi Chickenmadras,

    I have the same problem here, did you find a way to solve the problem ??. I upgraded my WRT54G as well
  9. ChickenMadras

    ChickenMadras Network Guru Member

    Hi Swallow,

    I "think" I've brought my WRE back to the land of the living. A very nice person at Linksys advised me to do the following:

    1. Connect to the SSID of the range expander. It should get a 169.254.xxx.xxx address

    2. Hardcode my wireless card's IP address to, subnet, default gateway

    3. Ping the WRE on

    4. Browse to

    5. When prompted to log in to the WRE, leave username blank and use 'admin' as the password

    6. Change the settings as required to suit your wireless network (IP address, SSID, WEP etc).

    7. Save settings and exit.

    I was told that both lights on the WRE would now be blue, but I've still got one red and one blue. Other than that everything is :cheering: and I'm feeling very :thumbup:

    Hopefully this will work for you too.

    All the best,
  10. rgrosz78

    rgrosz78 Guest

    I wanted to add some clarification. I had read this message, but did not know how to do the first step!

    My old WRT54G died, so I bought a new one. I spent 40 minutes on the phone with LinkSys tech support last night, and finally got my WRE54G (v1) to communicate with my new WRT54G (v5).

    1. Temporarily change the SSID and channel on the WRT54G router. This makes it easier to identify the correct network (my neighbors have several).

    2. Plug in the WRE54G range expander. Press the reset button and hold it for 30 seconds.

    3. Hold the WRE54G near the router and press the "auto configuration" button. Hold it down for 30 seconds.

    4. Move the WRE54G at least 10 feet away from the router, and plug it back in. Both lights will be a solid blue (non-blinking). This means that NO data is going back and forth. You want the activity light to blink, since that indicates data is being transferred.

    5. Turn OFF the WRT54G router, and unplug the WRE54G. Wait for 3 minutes, then plug the WRE54G in.

    6. Hardcode your wireless card's IP address to, subnet, default gateway This is a necessary step, since the WRE54G does not have a DHCP server.

    7. Now re-scan for wireless networks. You should be able to "see" the WRE54G. Connect to that network.

    Now you can continue from step 3 in the prior message.

    You must upgrade the firmware for the WRE54G. That is the only way that it will be able to communicate with the WRT54G v5 router.

    If you want to make further network configuration changes, it is a bit tricky. I wanted to change everything: SSID, SSID broadcast, IP address, security, etc.

    1. You have to make the changes one at a time
    2. Always make the change on the WRE54G first
    3. You will no longer be able to "see" the WRE54G
    4. Now make the SAME change on the router
    5. Unplug the WRE54G, wait for 60 seconds, and plug it back in. It should sync up with the router.
    6. Now do it all again for the next thing you want to change.

    Based on my experience, you MUST MAKE ANY CHANGE IN SECURIY THE LAST thing you do. The WRE54G would not let me make any changes after that - the SSID and channel kept resetting.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice