WRE54G with WRT54G

Discussion in 'Cisco/Linksys Wireless Routers' started by Cpudan80, Dec 30, 2005.

  1. Cpudan80

    Cpudan80 Network Guru Member

    Hello Everyone:

    I've just purchased a WRE54G (v 2) to extend my signal range coming off my WRT54G router (v 2 -- Firmware 4.20.6). After plugging the device in - I can't seem to get the thing to work properly, below is a list of everything I have done (in order).

    I should mention that all devices on my network use linksys wireless cards, which are all "G compatible".

    All help is appreciated, thanks!


    PS. My router is setup as follows:

    SSID: << UNIQUE >>
    Encryption: None
    SSID Broadcast: ON
    ** The MAC address of the WRE54G is in the list **

    SSID Broadcst setting on WRE54G: OFF (Per Linksys advice)

    Wireless Channel: Auto
    Starting IP Address:
    IP Address of my wireless PC:
    IP Address of my WRE54G:

    Subnet Mask:
    Gateway IP Address:


    1. Plugged in device, both lights are blue
    2. Tried to configure the device with the disk that came with it. The thing always came up with the error similar to "Cannot find a WRE54G on your network, make sure it's plugged in..."
    3. Tried to ping the WRE54G [ping] -- works fine
    4. Opened the web-utility for the WRE54G, configured it with my UNIQUE SSID, left the device IP alone, setup the subnet mask, and set the IP address of my Gateway.
    5. Saved my configuration.

    6. Lights are still blue on the WRE54G
    7. Go to my wireless PC (approx 15 ft from WRE54G; the WRE54G is approx 65 ft from the base station)
    8. Look at the signal strength via the wireless icon in the taskbar (near the clock) (Windows XP SP2), it says "low" with a speed varying from 1 - 6 MBPS. This is what I had before I installed the WRE54G; except maybe the speed part, it would always stay 1 - 2 MBPS. I would think that after installing the WRE54G at least the signal strength would say "good" or "excellent", right?

    9. Double click the wireless icon and open up the Windows XP Wireless Network list. I can see several other networks in my area, funny thing is, if I look at mine, I see that the signal strength is "good" or "excellent", but this is not reflected in the taskbar icon...

    Any ideas?
  2. Chuck_IV

    Chuck_IV Network Guru Member

    Make sure you are booting up your wireless connection near the WRE54G and not just taking an already active connection within range. It won't swap over to the better connection, on the fly. You will need to reboot and it "should" use the highest signal connection(you should see 2 of the same <UNIQUE> in the list of available networks.

    With that said tho, IMO take it back and if you can find a non V5 WRT54G router, get it(if not get a GS or even WAP54G), instead and use WDS with Tofu 11 firmware. The WRE54G was too much of a PITA for the price it costs($100).

    When I had the WRE54G, after undoing all my security, I was finally able to get the auto config button to find my network and connect. I could then get to the WRE54G's setup page( However, after my first visit and exit, I could never return until I rebooted the WRE54G. I'd get the ole "page not found". I'd unplug and replug it back in and everything would be accessible.

    After finally getting it set up with WEP security, I took it upstairs and plugged it into where I wanted it. It worked fine for a few hrs then mysteriously it would drop it's connection and the light would go red. I'd have to unplug and replug it, to get it back. It was completely flaky.

    After reading some opinions here, I went to my local Walmart and was lucky enough to find a V4 WRT54G router(open box, return but was never used and in perfect shape) for $50 and set it up to do WDS(did the trick to turn it into a GS model, and am using Thibor's firmware) and accomplished the same thing the WRE54G was doing(plus I can now use WPA security), for half the price and %100 less headaches(although I made it a pain to set up because I was using the wrong MAC ID, the unit's sticker had :16 at the end but Netstumbler ID'd it with a :18 :eek: )

    It's mindboggling they charge $100 for for the WRE54G, when it is completely flaky and you can just get another router or even the WAP54G for less money, that can do the same thing.
  3. Cpudan80

    Cpudan80 Network Guru Member

    Thanks for your reply...

    I tried to unplug my wireless card (it's an external USB one) and plug it back in. Didn't really work (it still says low signal). Then I tried to delete the whole wireless connection and re-do it (with the built-in windows stuff). That didn't work either (I still see low signal).

    You mentioned that I should see two items with the same SSID in my list of available networks, I don't. I'm thinking something isn't working right, even though it appears that the device is on - and working with my network (it has the correct IP, and both lights are blue)...

    Anything else I should try (without returning the thing?)

    Thanks again, all help is appreciated.

  4. Chuck_IV

    Chuck_IV Network Guru Member

    Within the WRE54G's setup page, make sure the SSID is the same as your router. Also make sure the gateway setting, in the WRE54G's setup, is set to your router's ip, as well. When I did the auto setup button, for some reason it didn't fill that in automatically. Also, try netstumbler( www.stumbler.net ) and check what it sees.

    When I had it, my system saw 2 of my SSID's for networks(so did netstumbler) and it would always connect to the one with the higher signal.
  5. Cpudan80

    Cpudan80 Network Guru Member


    In the WRE54G - the SSID is the same as my main router (brewingtonhouse)

    The settings for the WRE54G are as follows:

    SSID: brewingtonhouse < Same as main router >
    Subnet: < Same as main router >
    Gateway: < Same as main router >
    SSID Broadcast: OFF < Not the same, main router is ON >

    I still get the low signal, even with the settings as above. Any other ideas (return it?)

    I haven't tried the netstumbler thing (not at home at the moment) -- but I'll try it and see how it works.
  6. Chuck_IV

    Chuck_IV Network Guru Member

    Since the SSID is off, on the WRE54G, that is probably why you are not seeing it in the list of available networks(ie. seeing 2 brewingtonhouses in the list). Have you tried turning SSID on and seeing what happens?

    The way mine worked was it picked up the highest signal between the 2, when it would boot and connect. With only one showing, your system may only try to connect to that one. I may be wrong with this explanation as I'm no expert, just going by what worked for me.
  7. Cpudan80

    Cpudan80 Network Guru Member

    Hello Again:

    After being away for a while, I was able to get back and go at this some more.

    Using netstumbler, I was able to find 2 instances of my SSID in the wireless networks area. (After turning SSID broadcast ON)

    So, I try to connect to the one with the higher signal (which I know is my WRE54G -- because the MAC matches that of the device). Problem is now, when I connect to the device - it attempts to connect for about 10 seconds, then it says "Cannot associate with access point."

    After all that, my signal still says "low". What's wierd is, if I look at all the SSIDs in the list - I see both of mine - one with 26% strength, one with 52% strength. So, I'm assuming I should be associating with the 52% one... but the signal never goes up!

    I tried calling Linksys support. After talking with their tech for a while, she said "You've exceeded your time limit with me" and transferred me to her senior tech - who never picked up the phone...

    Any other ideas before I pitch this thing out the window?

    Thanks - all help is appreciated.

    PS. Per Linksys advice, I changed the channel on my WRT54G & WRE54G to channel 11. Also, using the web utility ( -- I can see that all the WRE54G's setttings (subnet, gateway, ssid...) match my WRT54G's settings.
  8. vincentfox

    vincentfox Network Guru Member

    TOSS IT OUT THE WINDOW! Or sell it or return it.

    A WRT54GS unit reflashed with HyperWRT or DD-WRT or (pick your favorite firmware) will let you do the same job better and cheaper, and easier. A WRT54GS will have a LAN port you can always connect to and poke at the device if there is a problem, unlike the steaming pile that is the WRE....
  9. Chuck_IV

    Chuck_IV Network Guru Member

    FYI, the newer WRE54G V2's have a lan port on them now. Cpudan80, if you have the V2, you can hardwire into it and and set it up. I'd try it without security first(along with your router) and see if you can connect then. Once you are able to connect, then go back to the WRE and enable security and also on your router.

    But... I agree with vincentfox, toss the thing like I did and just get another WRT54G(V4 or prior only) or WRT54GS router and load up either Tofu's or Thibor's version of HyperWRT and run WDS with them.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice