Discussion in 'General Discussion' started by Anonymous, Jun 15, 2005.

  1. Anonymous

    Anonymous Guest


    I just bought a WRE54G in a garage sale and I want to experiment with it. I couldn't find any replacement firmware for it (excluding official ones), is there any? Does the firmware for any of the other products work on it?

    I managed to connect to its webserver but I haven't messed with the settings yet. I've opened it up and it has the same broadcom chip as the WRT and an Intel flash chip.

    Any suggestions?

  2. howardp6

    howardp6 Network Guru Member

    There is no alternate firmware for the WRE54G except the official Linksys firmware.
  3. 4Access

    4Access Network Guru Member

    If you still have the option I'd suggest you return the WRE54G. I've used it and wasn't very impressed. Plus it usually costs more than a WRT54G and with custom firmware the WRT can do everything the WRE can plus MUCH more!

    Just my $0.02

    Update: Opps, the garage sale part didn't sink in when I read your post... #-o
  4. Anonymous

    Anonymous Guest

    Thanks for the replies. I've bought it cheaply to mess with it and I'm looking for suggestions. One interesting page I found was conf.asp, which had a button "Nvram" which produced a web page with address apply.cgi?action=Nvram and the content were a bunch of settings for the device. Anything to glean from that? I downloaded the firmware source from the Linksys website and I'm looking through it.

    Is this the right place for these kinds of questions?

  5. 4Access

    4Access Network Guru Member

    Can you make changes to the settings from that page?!?

    It might be interesting for reference sake if you could just post the entire contents of that page here since I did a search and didn't find an other references to either "conf.asp" or "apply.cgi?action=Nvram" in the forums here.
  6. Anonymous

    Anonymous Guest

    Below are a screenshot of conf.asp and the output of hitting show next to Nvram. I can't change any settings beyond what's shown on the conf.asp page. I tried to pass parameters to the cgi script on the browser url field without success. Maybe I don't know the syntax. I'll keep experimenting and will report here, but I welcome suggestions on what to do.



    Parameters in NVRAM

    os_ram_addr = "80001000"
    wan0_primary = "1"
    wl0_frameburst = "off"
    log_ipaddr = ""
    boardrev = "0x10"
    il0macaddr = "00:0F:66:F0:D4:CF"
    et0macaddr = "00:0F:66:F0:D4:CF"
    d11g_mode = "1"
    boot_wait = "off"
    watchdog = "1000"
    wl_phytypes = "g"
    wl0_infra = "1"
    wl0_country_code = "AU"
    et0mdcport = "0"
    SNMPCommunityOne = "public"
    fw_disable = "0"
    wl_infra = "1"
    pmon_ver = "CFE"
    restore_defaults = "0"
    ap_repeater_channel = "6"
    d11g_dtim = "3"
    http_wanport = ""
    wl0_ifname = "eth1"
    wan_netmask_1 = "255"
    wan_netmask_2 = "255"
    wan_netmask_3 = "255"
    wan_netmask_4 = "0"
    wl0_mode = "ap"
    wan_gateway = ""
    wan_ipaddr_1 = "192"
    wan_ipaddr_2 = "168"
    wan_ipaddr_3 = "1"
    os_flash_addr = "bfc40000"
    wan_ipaddr_4 = "240"
    wl0_gmode = "1"
    sromrev = "2"
    auth_mode = "disabled"
    boardtype = "0x0446"
    FilterSwitch = "0"
    wl_gmode = "1"
    wl0_auth_type = "2"
    wl_mac_index = "0"
    d11g_rate = "0"
    lan_netmask = ""
    isWAP11 = "0"
    SYSName = ""
    wl0_ssid = "linksysRf0d4cf"
    wl0_dtim = "3"
    http_username = ""
    os_date = "May 7 2004"
    FirmwareVersion = "v1.04, May 06, 2004"
    http_lanport = "80"
    wds0 = ""
    wl_plcphdr = "long"
    wds1 = ""
    wl_macmode = "disabled"
    wds2 = ""
    wds3 = ""
    wl0_key1 = ""
    wl0id = "0x4320"
    wl_phytype = "g"
    wan_netmask = ""
    wl0_key2 = ""
    wl_lazywds = "0"
    wl0_key3 = ""
    wl0_key4 = ""
    d11g_rts = "2346"
    ag0 = "255"
    http_passwd = "admin"
    lan_stp = "1"
    chk_downgrade_hdr = "Enabled"
    wl_mode = "ap"
    wl0_plcphdr = "long"
    wl0_closed = "0"
    wl0_rate = "0"
    wl0_macmode = "disabled"
    wl0gpio0 = "0"
    d11g_rateset = "default"
    wl0_radioids = "BCM2050"
    wl0gpio1 = "0"
    wl0_phytype = "g"
    wl0gpio2 = "0"
    wl0_lazywds = "0"
    wl0gpio3 = "0"
    wl0gpio4 = "0"
    wl0gpio5 = "2"
    d11g_rts_cts = "off"
    boardflags2 = "0"
    wl0_antdiv = "-1"
    cfe_version = ""
    wl_dtim = "3"
    wl_ssid = "linksysRf0d4cf"
    ap_client_wep_key = ""
    d11g_bcn = "100"
    radius_port = "1812"
    wl_mac_hwaddr = ""
    wl_passphrase = ""
    os_server = ""
    wan_proto = "static"
    wl_key1 = ""
    wl_key2 = ""
    wl0_unit = "0"
    wl_key3 = ""
    wl_country_code = "AU"
    wl_key4 = ""
    wl_hwaddr = ""
    PassphraseKeyLength = "0"
    pa0itssit = "62"
    SNMPEnable = "0"
    MyFirmwareVersion = "v1.04.03, May 06, 2004"
    ap_client_wep = "off"
    d11g_frag = "2346"
    wl0_wds = ""
    ap_mode = "2"
    wl_rate = "0"
    cctl = "0"
    log_level = "0"
    SYSLocation = ""
    lan_ifnames = "eth0 eth1"
    wl0_auth = "0"
    wl0_radius_port = "1812"
    wl_country = "Worldwide"
    pa0maxpwr = "60"
    wl_auth_type = "2"
    wl_rateset = "default"
    clkfreq = "200"
    lan_ipaddr = ""
    os_name = "linux"
    lan_proto = "static"
    aa0 = "3"
    RWEnableTwo = "0"
    wl_unit = "0"
    wl0_phytypes = "g"
    wl0_wep = "off"
    wl0_frag = "2346"
    fw_hdr = "00 90 4B 21 BC C7 00 07"
    d11g_channel = "6"
    router_disable = "1"
    sdram_config = "0x0032"
    wl0_country = "Worldwide"
    radius_ipaddr_1 = "0"
    radius_ipaddr_2 = "0"
    wl_wds = ""
    scratch = "a0180000"
    radius_ipaddr_3 = "0"
    radius_ipaddr_4 = "0"
    ccode = "0"
    wl0_rateset = "default"
    SYSContact = ""
    lan_ifname = "br0"
    boardflags = "8"
    wl0_mac = ""
    sdram_refresh = "0x0000"
    wl_auth = "0"
    sdram_ncdl = "0x2020f"
    radius_key = ""
    wl_frameburst = "off"
    wan_ipaddr = ""
    wl0_passphrase = ""
    wl0_mac_hwaddr = ""
    radius_ipaddr = ""
    wl0_rts = "2346"
    wl_ifname = ""
    wl_wep = "off"
    chk_fw_hdr = "Enabled"
    os_version = ""
    wl_gmode_protection = "off"
    wl0_wpa_gtk_rekey = "300"
    wan0_desc = "Default Connection"
    wl_frag = "2346"
    wl0_key = "1"
    RWEnableOne = "0"
    wl_maclist = ""
    et0phyaddr = "0"
    console_loglevel = "1"
    security_mode_page = "4"
    wan_ifname = "eth1"
    wl_radioids = ""
    lastpage = "1"
    wan_hostname = "Linksys WRE54G"
    wl_mac = ""
    ap_client_wep_mode = "open"
    wl0_radio = "1"
    wl_corerev = ""
    wl_channel = "6"
    d11g_hwaddr = ""
    wl0_bcn = "100"
    wl0_hwaddr = "00:0F:66:F0:D4:CF"
    wl_radio = "1"
    wl0_gmode_protection = "off"
    pa0b0 = "0x119a"
    wl0_maclist = ""
    pa0b1 = "0xfb93"
    pa0b2 = "0xfea5"
    sdram_init = "0x0002"
    wl_rts = "2346"
    wl0_mac_index = "0"
    dl_ram_addr = "a0001000"
    EnableLAN = "on"
    wpa_psk = ""
    lan_hwnames = "et1 wl0"
    wan0_unit = "0"
    SNMPCommunityTwo = "private"
    ap_repeater_mode = "stop"
    wl0_corerev = "7"
    wl_key = "1"
    wl0_channel = "6"
    flag_MAC = "1"
    curpage = "1"
    wl0_auth_mode = "disabled"
    wpa_gtk_rekey = "300"
    wl_closed = "0"
    wan_gateway_1 = "192"
    boardnum = "1024"
    log_ipaddr_1 = ""
    wan_gateway_2 = "168"
    ap_repeater_mac = ""
    ap_repeater_ssid = ""
    log_ipaddr_2 = ""
    wan_gateway_3 = "1"
    wl_bcn = "100"
    log_ipaddr_3 = ""
    wan_gateway_4 = "1"
    log_ipaddr_4 = ""
    wl_antdiv = "-1"
  7. davidsonf

    davidsonf Network Guru Member

    Wow, that is really interesting! And frustrating...

    Last time I had looked at the Linksys web page, there was no source code for the WRE54G. So when I saw this thread, I figured it would be fairly interesting to see if I'd be able to compile a new binary for a WRE54G and maybe include a telnet daemon to make it possible to login and look at what's there.

    However, I'm on a dialup Internet connection, with an 8 hour timeout. I can't download a 175Mb file unless the download can be restarted. It seems Linksys has changed something, because while I was able to do that some time back to get the source code and the toolchain for the WRT54G, the source code for the router won't let me restart the download!

    Has anyone compiled the code yet? How much RAM does a WRE54G have? Regardless of being able to compile the source code, is busybox one of the programs included? That would probably be in a directory .../release/src/router under the top directory of the software distribution.

    If this looks like it can be done, I game to risk sacrificing a WRE54G in an effort to generate a new binary that gives access via telnet. But given the effort that it is clearly going to require for me to download it, I'd like to hear more about what is in the source code release first.
  8. Anonymous

    Anonymous Guest


    Busybox is included in the source. I've made a gzipped tarball of the release directory of the source (since you already have the toolchain) and is available here[web:c7cdcbd968]http://www.ma.utexas.edu/users/voloch/Exe/release.tar.gz[/web:c7cdcbd968].
    It's 60MB so hopefully it will be easier for you to download. As I said above, I'm willing to experiment with my WRE so if you compile a firmware with telnet, I'll be happy to try it.


    p.s. I've no idea if my webserver allows interrupted downloads. If you have trouble, let me know and we'll look for an alternative.
  9. Felipe

    Felipe Network Guru Member

    Sorry, I made a mistake in setting links in the above post and the file would automatically download (bad thing for a 60MB). Hopefully I'll get it right this time. Here is the link to it:release source 60MB

  10. davidsonf

    davidsonf Network Guru Member

    Great. Unless this little beastie is so cramped for space that it can't fit in, we should be able to recompile busybox with the telnetd daemon enabled.


    However, I don't know what was going on to start with (probably the web browser was still connected when I tried to restart it with wget), but I tried it again later on, and darned if it didn't start right up and jump to the end of the
    existing file.

    Unfortunately... lots of times a restart will be corrupted and this one was. So I'm starting it all over again. I'll probably have to wait another 12 hours to know... :-(

    It will be interesting to see what differences there are in a number of things compared to the WRT54G sources. Differences in the tool chain for example! And in the Linux kernel. I'm hoping this is just a WRT54G board with the bridge and the vlan hardware deleted.

    This may take awhile, but we'll get there...
  11. davidsonf

    davidsonf Network Guru Member

    Okay... some amount of progress! It compiles.

    I short circuited the second down load, since the corruption was right at the start of the file. Rather than grab the whole 185,000,000 byte file, I used the unix "split" utility to divide it into parts, downloaded just enough to get the same size split file on the new file, and cat'd them all together again. It worked!

    One point that is unsettling, when I compile it I get a different sized binary than the one that Linksys has available on their web site. My uClibc library has been modified slightly, but that should have added a few bytes. Instead I get a smaller binary.

    I haven't tried to upload it to a WRE54G though.

    In poking through the code, there are several things obvious. One is that they use an old version of busybox, and it does not even have the telnetd daemon in it! Not to worry, on my WRT54G firmware I replaced the telnetd in busybox with the BSD telnetd code, so I've got a drop in replacement. It will add a few bytes more, but not as many as the difference in file sizes. Later we might look at using the latest busybox and see if it is smaller or larger than the old version they us.

    They used the minix shell, msh, instead of ash, to save about 30K. That suggests this thing is really tight on on RAM. It also has ntpclient in the load, though it was not started by rc. Note that it has wget, but not tftp.

    Before I try uploading a test binary, and before suggesting that anyone else try it either, I need to have a look at the hardware to see if "debricking" is as easy as it is with a WRT54G. Obviously anyone who tries this is eventually going to load a binary that doesn't work, and getting out of it may be difficult. Hopefully it has either or both of the same flash ram chip as the WRT54G (where shorting pins is easy enough) and JTAG capability.

    More tomorrow.
  12. Felipe

    Felipe Network Guru Member

    The difference in size from the latest firmware available on the Linksys website is because this is the previous version of their firmware (1.14 instead of 1.17?). My WRE has firmware 1.04 installed and I wanted to see what was in it, so I downloaded the closest available. I could download the latest one and have a look, if you think might help in any way.
  13. davidsonf

    davidsonf Network Guru Member

    I mean compared to the binary of 1.17 that they had on their web site at one time, which is what I've got running on my WRE54G. (It no longer seems to be available.)

    Here's the size that /bin/ls says their binary has:

    ... 1458185 Nov 8 2004 LinksysWRE54G_1.04.17-hdr.trx

    Here's what I got by compiling their source code:

    ... 1449984 Jun 19 21:31 linux.trx

    The basic problem is that Linksys (Cisco) still has apparently not figured out what the GNU GPL says and what it means. They are releasing various binaries and various source code trees... but they don't match. And that is a violation of the GPL, which says that for each and every binary they distribute the must distribute the source code. It doesn't say "some source code that is almost the same".

    That said however, they may well have it all on the CD that they say they'll send for a small fee to anyone who asks. If they do, they're covered legally, and the half hearted effort on the web page (and much less on their ftp server) is just something they do us as a favor, which we can't be overly critical of.
  14. davidsonf

    davidsonf Network Guru Member

    One more addition, and this appears to be a show stopper.

    A binary of the same version as this source code was available for awhile on the Linksys web page. That file, LinksysWRE54G_1.04.17-hdr.trx, was dated Nov 8, 2004.

    The source code distribution includes an image file, dated March 20, 2005, which won't load either. Same error message as the image that I compiled. The Nov 8 image does load as expected. As noted previously, it isn't the same size as images from this source code.
  15. Felipe

    Felipe Network Guru Member

    Are you having trouble loading the firmware? I don't recall you mentioning this earlier in the thread. Do you want me to try loading it on mine?
  16. davidsonf

    davidsonf Network Guru Member

    The problem is that the binary distributions from Linksys load just fine, but a binary built from the source code distribution will not load. That is not just the binary that I compile, but the one that comes with the source code distribution.

    The source code is munged.

    I sent an email to Linksys support asking about it. Specifically I asked if they have all of the source code on the CD they sell for $10.

    My reason for asking that is that they do not have correct source code for each and every binary distribution on their web page. If it is not on the CD, they are in violation of the GPL. I didn't mention that in my first email, but if the answer is not appropriate I certainly will in any followups.
  17. thanatos2k

    thanatos2k Network Guru Member

    Any further news on this? Is Linksys being helpful?

    My buddy works pretty high up in BestBuy's GeekSquad, and he has some corp contacts at Linksys. If you cant get the real souce I could have him get it, or at least fix the source on their site.
  18. davidsonf

    davidsonf Network Guru Member

    The kind folks at support@linksys.com responded that the question was out of their range, and told me to send email to opensource@linksys.com. I got no response from that email address.

    Note that since I posted my previous message Linksys has updated their ftp archive, and now does provide source code for the other WRE54G binary releases. However, the same results. ;-) The binary that comes with the source code distribution is different than the one that can be downloaded as a binary distribution, and it will not load when an upgrade is attempted.

    Note that I have not checked the Linksys ftp archive for several days, so the status I'm reporting was as of a couple weeks ago.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice