WRK54G crashes when streaming audio/video

Discussion in 'Networking Issues' started by ispartacus75, Mar 5, 2006.

  1. ispartacus75

    ispartacus75 Guest

    Hi everyone Im a noob here.

    I have a WRK54G wireless router with an Xbox hardwired to the back. I have an Acer laptop with built in wireless G and a pocket pc with wireless B.

    I am a fan of US baseball and subscribe to watch or lsiten to the games live over my 2mb cable connection.

    I tried streaming wirelessly to my laptop, but everytime I did it my Linksys router would crash before the stream started. When I say crash I mean that my internet connection would be dropped, I couldnt access any more sites, MSN messenger would logout and I would have to reboot my router to get connection back again.

    I tried wiring my laptop to the back of the router so that it had a 100mb connection but it was still doing the same.

    The only way I am able to access my streams is to directly connect my laptop to my cable modem and therefore disable to wireless router, kinda pointless getting it then.

    I spoke to Linksys who told me that the router cannot cope with the baseball stream at 350kb/sec and thats what is crashing the router.

    Does this sound right?

    If this is the case I need to find a way to connect my laptop and my router to my modem at the same time so that my laptop can have a hardwired connectio to the internet when I need it and when I dont I can run it over the wireless connection. Dont even know if this is possible.

    And advice or comments would be appreciated.
  2. kingvj

    kingvj Network Guru Member

    If you're router is having firmware 1.55.02, then you have no options AFAIK. If it is 1.58.03, there's a beta 1.58.00 to fix it.
  3. chemical

    chemical LI Guru Member

    as many i have a wrk54g, that crashes very often to.

    There is something funny going on with 'streaming' media.
    Seems the uPNP settings have something to do with it. Havent put my finger on it yet. I get the feeling if there are to many ports mapped, the FW blocks all access. a power off/on resolves the problem for a short time.

    Tried to downgrade the firmware, but it wont let me. So i doubt 1.58.00 wont do any good since im on 1.58.03
  4. chemical

    chemical LI Guru Member

    tested some things

    in combo with windows FW very unstable UPnP, manually added portrange forwarding for windows media player, seemed to do 'some' good.

    Also reduced the MTU to 1492 brought a longer 'up' time!
  5. chemical

    chemical LI Guru Member

    still went belly up, had a chat with their support, thay send me the 1.58.00 beta, its up and running for now.
  6. chemical

    chemical LI Guru Member

    still running, some minor interruptions, but didnt have to resart the router to get reconnected again.

    seems 1.58.00 is the way to go!
  7. kingvj

    kingvj Network Guru Member

    one more confirmation..!!! thx mate..!!
  8. wycf

    wycf Network Guru Member

    I have the same router and it has 1.58.03 firmware. Where can I get the 1.58 beta version?

  9. SHO NUT

    SHO NUT LI Guru Member

  10. ghandchi

    ghandchi Guest

    here is my workaround

    I used the last firmware posted last on this page and
    I did the following workaround, then it all worked for me:

    1. I used static IP for the two wireless PCs I have on my network (they both run XP).
    2. I used dynamic IP for the third PC which connects to the
    Ethernet port (which runs Vista).

    It is all working fine now.

    It seems to me that previously in my case
    the third PC was causing the router
    disconnects where I would need to reboot the router
    to get it working again.

    Now my guess is that either the problem is because
    of compatibility with Vista (or other OS's as others
    have reported on this page) or that the
    part of firmware code handling the Ethernet
    side does not work well with the part handling
    the Wireless side.

    I did not have the time to troubleshoot further
    but assigning static IP for the wireless stations
    and dynamic IP for the Ethernet station has
    somehow isolated the two parts of the network
    from each other.

    I did not change anything in the default setup
    for the DHCP addressing assignment and all
    addresses above the address are
    used for dynamic IP addresses and I used the
    addresses below that for static address assignments
    ( and

    Hope this helps you folks. I used the information
    on this thread a lot and thought to leave this
    note in case it may help others. Indeed, a very
    helpful thread to get my Linksys WRK54G working.
    Thank you all.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice