Wrong Shibby Version, Bricked WRT54GL

Discussion in 'Tomato Firmware' started by jambarama, Jul 29, 2014.

  1. jambarama

    jambarama Network Newbie Member

    I have a long serving WRT54GL that has been running Tomato 1.28 for ages and it has been great. Recently, I decided to add ad blocking capabilities which involved updating firmware. I read around and decided the shibby version was active and had what I wanted. I saw shibby suggest tomato-K26-1.28.RT-MIPSR1-XXX-Mini would work on my WRT54GL. So I downloaded the file, went into firmware admin panel to update, uploaded the file and everything looked good until the router rebooted. Then, to my horror, I discovered I'd actually just updated with tomato-K26-1.28.RT-MIPSR2-XXX-Mini.

    The symptoms: The power light flashes without stopping, the DMZ light never even blinks, and the ethernet lights are solid green. The web gui does not come up. It will not assign IP addresses. I t doesn't respond to pings during the boot process or thereafter.

    What I've tried: 30-30-30 power cycling. Power cycling, holding and releasing the reset button at various intervals, with an ongoing ping command (always "Request timed out."). Cannot get it into management mode either. I ran through everything here and all the links here except jtag/serial.

    What I have NOT tried: I have not tried to telnet in, since it won't respond to pings. I have not tried jtag or serial adapter methods, I don't have the cables for it or a soldering iron. I have not tried to pin short the router, in hopes the router may be recoverable.


    Sadly, I'm ready to junk it. But I thought I'd ask to see if there is something specific to try out, given I know what bricked the device. Just in the off chance the MIPSR2 v. MPISR1 mistake had been made before.
  2. M0g13r

    M0g13r LI Guru Member

    Last edited: Jul 29, 2014
  3. jambarama

    jambarama Network Newbie Member

    That looks like the same link I included in my original post, so I think I'm down to JTAG as an option. Thanks, just thought I'd ask because you never know if there's some trick or exploitable and known behavior for installing the wrong build.
  4. Siff

    Siff Serious Server Member

  5. jambarama

    jambarama Network Newbie Member

    Yeah, I ran across that page from this page I linked earlier. The router never put up the web GUI. It may be a router specific fix, I don't know.
  6. Siff

    Siff Serious Server Member

    I don't think that you'll get the Web interface working since I don't think that the "GL" CFE has it, but the post I linked describes that the poster got ping working which, if you make it work as well, might allow you to tftp the original Linksys firmware and revive the router...

    Anyway, if you have tried it and it didn't work, I guess your next option is serial or JTAG. Good luck!
  7. Bird333

    Bird333 Network Guru Member

    It's been a long time since I had a bricked router. From memory timing can be crucial for getting a ping. Have you connected a switch between the router and your computer so the link is live before you power up the router? Also, manually set the network connection to an ip address in your router's subnet (i.e. 192.168.*.*) so Windows doesn't try to automatically detect it. I had one router that the ping was live only probably 1 sec. Through trial and error, I had to tftp right as link light on the router came on after boot up. I actually think I started it .1 of a second before it lit up. :) Like I said a lot of trial and error. I finally got it recovered. Good luck
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice