WRT300N stoped functioning after firmware upgrade

Discussion in 'Cisco/Linksys Wireless Routers' started by prohelp, Sep 3, 2006.

  1. prohelp

    prohelp LI Guru Member

    I upgraded the WRT300N rev2 firmware to a new one by following the two stepped process. What happened was that after the first stage things stopped working. I was not able to connect to the original IP-address or the default one The WLAN AP is not either visible anymore nor does it try to acquire any IP-address.

    The AP is not blinking the power-light and the AP looks normal but nothing works. I got some activity when I powered up the AP and simultaneosly pressed the reset-button. This put the AP into such mode that the power-light started blinking and the AP started to send gratuitous ARPs, which revealed that the AP has taken IP-address and this can also be verified by using ping. So even though nothing seems to work, the basic IP-connectivity is there and waiting something to happen. This is probably some kind of Atheros internal recovery-mode.

    After this I have tried to push new firmware image via using TFTP, FTP and trying to connect via web-access but AP does not seem to want to do anything like that.

    I was wondering if any of you would have any past experience how I could reapply the firmwares using this recovery mode. Any suggestions are very welcome.
  2. Toxic

    Toxic Administrator Staff Member

    firstly what was the "two step process" you talk about?

    what firmware did you upgrade from and too?
  3. prohelp

    prohelp LI Guru Member

    I was referring to two step process that people have been using and what is some what weirdly mentioned in the firmware release. I was upgrading from 2.00.08. Below are the notes that I was following. First wrt300n.bin and basically here it stopped.

    Firmware upgrade for all previously released versions

    - To upgrade from previous firmware versions
    1) Upgrade using firmware: wrt300n.bin
    2) Upgrade using firmware: New_2.00.13_wrt300n.bin

    General Notes:
    - This firmware is only for usage in Europe
    - Disconnect all wireless clients from the router during
    the upgrade process. Make sure no wireless clients
    attempt to associate with the router until the upgrade
    process is complete.
  4. icemann77

    icemann77 LI Guru Member

    where did you bought your router at europe? because it can only support the firmware for the atheros chip.those sold in the US is in the broadcom chip.so if you have done it roght then im afraid either return it to the store or back to linksys.:thumbup:
  5. PascalKoster

    PascalKoster LI Guru Member

    Pascal Koster

    We also have the same problem as described.
    After the first firmware upload the router resets and is dead.
    We used the same version upgrade to 2.00.13 and were following the exact upgrade rules as described in the text-file.The router was bought in the Netherland (Europe) and not America.

    Please Help.
  6. PascalKoster

    PascalKoster LI Guru Member

    Do not upgrade to 2.00.13

    As descibed we have the same problem as the initiator of this treath,
    but after making a chat session we came to the conclusion.

    DO NOT UPGRADE TO 2.00.13....

    We are sending the device back to our supplier because its completely DEAD.
    The Linksys engineer coudnt make it alive also. First it thought we were dummies, (put the cable in another switchport) but as an IT professional with more than 15 years working IT experience I held on playing dummy.

    So the device is dead, after 4 hours being unpacked from the original box.
    It will be shipped next week.

  7. T9000

    T9000 LI Guru Member

    Yes, I had the same problem.. I bought it on Saterday, unpacked the box, placed the router..installed; everything up and running; then firmware upgrade (you need to upgrade for full performance) and bammm dead:) and I tried everyhting.. conclusion; next day..went to the store after linksys contact; I got a new one right away.. I will wait for the update; bought it in the netherlands (paradigit, Amsterda)
    conclusion; don't upgrade and wait for a better, logic firmware.
  8. Intratech

    Intratech LI Guru Member

    I did the 2.00.13 firmware upgrade successfully but the firmware is faulty. It didn't kill my router. I then upgraded to the 2.00.14 firmware and now it works brilliantly.
  9. alphred72

    alphred72 LI Guru Member

    Where did you find the 2.00.14 firmware??? All I can see on Linksys pages is the 2.00.13 (ETSI) firmware.
  10. Toxic

    Toxic Administrator Staff Member

    2.00.14 is on our downloads. you need v2.00.13 to be loaded first of all. there is a v2.00.8 to v2.00.14 as well i'll grab that today sometime.
  11. toibs

    toibs Guest


    Did you ever get the v2.00.8 to v2.00.14 version at all. Also, is there any info as to what this f/w adds/changes on the router at all??

  12. Paul Claessen

    Paul Claessen LI Guru Member

    I only found 2.00.14 .. do you have link for me to the older versions (specifically 2.00.13)? (European version!)

    Much appreciated!

    Paul Claessen
  13. Intratech

    Intratech LI Guru Member

    2.00.13 is available on the Linksys-uk website.
  14. auban

    auban LI Guru Member

    I guess by know you threw that router away or something. I managed however todo the same as you yesterday.. Failing to upgrade the firmware that is... Also found the arp packages pointing me to , did a portscan and found out that port 9000 seem to be open. If telnet:ing to this the power led starts blinking faster. If pressing 'ctrl + c' a text apperar saying something like "User abort, executing boot script in 2 seconds" and then the router no longer listens to that IP (Power led yellow). That's all life sign I've managed to get. Not sure but perhaps this is hole where to press the new firmware through, don't know what protocol to use though.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice