WRT320N - From tomatousb back to original firmware

Discussion in 'Tomato Firmware' started by mischief, Jan 9, 2011.

  1. mischief

    mischief Networkin' Nut Member

    Hello. I hope someone on this board can help me.

    I had a problem with a tenant of ours using up a lot of our bandwidth. Someone told me that a router with dd-wrt or tomato might be able to help with this, so I recently bought a refurbed wrt320n. As soon as I got it, I put in dd-wrt, but I couldn't access my security cameras from the browser. After reading a little bit about tomatousb, i made the change over. Now the problem is that my computer can't get an ip from the router. I can log into the tomato gui, but now it won't connect to the internet. After poking around a bit on the tomato gui, i decided to just change the firmware back to the original, and stop messing with the router. Problem is, I can't seem to find a tutorial on how to do that. Is it as simple as getting the original firmware from linksys and updating the firmware thru the gui? I ask because from dd-wrt to tomato, i needed to telnet into the router and get the password, so I'm wondering are there any extra steps to take if I go from Tomato back to the original firmware?
  2. Toastman

    Toastman Super Moderator Staff Member Member

    "Poking around" with things usually won't accomplish much nor will it cure the problem you have with your tenant. Why not ask for help in fixing your connection problem instead? Describe what kind of connection you have to your ISP, what settings you have tried to use to make it work, etc. I'm sure help will be forthcoming.
  3. mischief

    mischief Networkin' Nut Member

    Well, the problem after I installed tomato was that after the firmware update, it did the reboot, and I was able to log onto the gui with the password i got from doing the telnet into the router earlier. At this point, my internet connection just went dead. I tried resetting the modem. I did a 30/30/30 on the router. I rebooted my computer. Nothing. My network icon shows No Internet access. I did i ipconfig /release & renew which resulted in nothing. I disconnected my wrt320n, and put back my old d-link and my network was up again.

    OS: Windows 7
    Connection: Cable via Roadrunner

    Oh, and before i unplugged the wrt320n, i noticed that the blue power light just kept blinking. I pressed the reset button on the back for 10 secs, and nothing happened. Not sure if this is a symptom.
  4. Ronnie_USA

    Ronnie_USA Networkin' Nut Member

    I have an E3000, not a 320, but I do have Roadrunner for internet, and have had no problems getting on the net with it. Try unplugging your cable modem, and let it reboot, see if you get an IP address then.
  5. mischief

    mischief Networkin' Nut Member

    Ok, problem solved.

    I just reflashed using the same tomato firmware and checked the box "After flashing, erase all data in NVRAM memory", and after a minute or so, it came back on with life! :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice