WRT350N and 1.03.7 firmware experience

Discussion in 'Cisco/Linksys Wireless Routers' started by forensicslab, Dec 28, 2007.

  1. forensicslab

    forensicslab Guest

    Just wanted to relay my experience with the WRT350N that I just recently bought. Actually the first one I bought from the store was already bricked (power led constantly blinking, couldn't ping it). So I had to go back and exchange for a new one the next day.

    The new one came up fine with firmware 1.03.2. I had read a few posts on the forums and all said to use the tftp method to update the firmware. So I went to Linksys site and downloaded the latest firmware for 1.03.7. Initially I tried the tftp method to update the firmware but it would not work. So I figured what the hell, try using the web interface to update the firmware. Like many users I got to about 84% of the way then the router reports that it failed. Tried it again, and it failed again. So I had also read that after resetting the router from this point the router would be bricked. So I called Linksys tech support while I still had a web interface that I could access on the router.

    Linksys tech support was pretty much useless. The tech was basically trying to walk me through the steps that I had already done, including downloading the latest firmware from Linksys site, again. Ridiculous. Finally, she had me hold the reset button for 30 seconds and unplug the router for 20 seconds. When the router booted, I no longer had a web interface that I could access, and constant blinking power led. Then she told me that this was a sign that it was defective and to take back to the store and exchange for a new one. Thanks.

    I noticed I could still ping the router so I tried to tftp the firmware up to it and it took instantly. I waited approximately 2-3 minutes, the router reset itself and viola, the web interface could be accessed, firmware 1.03.7 displayed. Upgrading the firmware should not be this crazy. So far basic networking and wireless appear to be fine (i have not tried the storage link) but then again my uptime is less than a day right now.

    I hope this helps others with similar experiences.

  2. Toxic

    Toxic Administrator Staff Member

    afaik Linksys Tech Support does have access to v1.03.9 Beta now. I dont know what changes are in it however.
  3. Toink

    Toink Network Guru Member

    I tried to ask Linksys tech Support for 1.03.9 BETA. Apparently, only 1.05.8 (old BETA prior to v1.03.7) is available from them...:knock:

    Perhaps, you Toxic, or anyone who has an insider contact can ask for it for our consumption?

    I really need to know if at least some of the glitches have been fixed... Now that Thibor has officially posted his no intention of making a firmware for this model, I really think I'm stuck waiting for official firmwares until the glitches are fixed.... No, I don't like any other 3rd party firmware other than Thibor's :)

    Or I may as well send my WRT350N to Thibor for him to work on the firmware - Heh! :biggrin::rockon:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice