WRT350N Storage Link Storage Flop?

Discussion in 'Cisco/Linksys Wireless Routers' started by LinkCloud, Feb 18, 2007.

  1. LinkCloud

    LinkCloud LI Guru Member

    I've worked around networks for longer than I care to remember and have finally come to a point to set my pride aside and ask for help. I’m adding NAS to my current network. The culprits are:

    WRT350N v1.03.2 Wireless-N Gigabit Router with Storage Link
    WDG2T10000N WD My Book 1TB Premium Edition II

    I can connect any other USB and it can be detected. The My Book can be read and used on my computer no problem. I have gone from a 1TB NTFS format to a 100GB FAT32, 900GB FAT32 partition with no change in detection. I have returned both devices to the store thinking maybe it was a bad luck of the draw to no prevail. I am running Windows XP Pro on the computer setting the network up. The My Book can not be detected at all. I was unaware of any limit to the NAS and I also have read that it should support NTFS. Please help in any way you can. If you need any more information let me know.

  2. metal monkey

    metal monkey LI Guru Member

    Its a bit hard to understand, but if im right and you have the my book formatted in ntfs you need to make sure you have updated the wrt350n's firmware for it to work properly with the ntfs so check that before you go any further.
  3. LinkCloud

    LinkCloud LI Guru Member

    Firmware version is v1.03.2 as stated above. It is the most current with NTFS support.

    The HDD will not work as NTFS format or FAT32. I have tried both.
  4. Toink

    Toink Network Guru Member

    @metal monkey
    v1.03.2 is the only (latest) firmware version available for this right now.

    Is it just me or has anyone successfully accessed their drive connected to this router from a Windows Vista box? Is it also possible to access my files/folders from the internet? How? Thanks!
  5. metal monkey

    metal monkey LI Guru Member

    sorry i must have missed the bit where you mentioned the version number.

    No news on vista but using the storage drive via the internet is fine. if you go to the storage link tab and choose the ftp option.

    just enable the ftp option and then open go to the status tab. check the internet ip address. if you then enter your web browser and type ftp:// followed by the internet ip address.
  6. Toink

    Toink Network Guru Member

    I already enabled the FTP option in the router - even the internet access.I set the Port to 21 (default). No luck accessing my files using ftp://my ip address. I keep getting "operation timed out"...

    Here's my setup:
    80G Seagate Momentus (NTFS) in a Philips USB enclosure
    Dynamic IP (I made sure I got the current IP address before I accessed the drive)
    Port is set to 21

    What is it I'm doing wrong? :(
  7. noelabc

    noelabc Network Guru Member

    Can you access the USB drive locally? try mapping it first "\\"
  8. Toink

    Toink Network Guru Member

    Yes. I could access them locally, though.

    I can also confirm that the storage link just wont work locally via Windows Vista (Ultimate). The Username/password windows pops up and then it just times out and I will get "page cannot be displayed. I made sure that my firewall is turned off....

    Also, with the USB drive attached, the router hangs, or I get disconnected from the net if I was transferring a large file. I have to reboot the WRT350N.... bummer!:sick: :guns:
  9. morrison22

    morrison22 LI Guru Member

    A solution is here:

    1. Create shares on your router, to create chares please follow these steps:
    a. Access the router’s setup page, open your Internet explorer, type, leave the username blank and type admin or your router’s password on the password field box then click ok.
    b. Click on the storage tab and click on the disk sub-tab
    c. Click on the create share button, type any name under the share name field, click on the select partition button and select your hard drive after that click on create share
    2. Create groups and users on your router
    a. To create a group, click create new group. It will ask for the name of the group then click create group.
    b. To create a user, click on create new user. It will ask for the name of the user, password and the group name where this user will be included then click create user.
    3. Go back to the share sub-folder, click on the modify button under share access column. From this point you can specify if a certain user will have a read/write access or read only access, after setting this configuration you can click on save settings then close the window.
    4. Please change these following settings on your computer to allow your log-in to map certain address
    a. Click on the windows logo, type secpol.msc under start search and press enter.
    b. Double-click on the local policy, go to security option, open network security LAN manager, on the drop-down arrow select set to send LM & NTLM- use NTLM v2 and click ok all the way out.
    5. You can now try to map your network drive, click on the Windows logo, type run under start search and press enter. On the run box type or the router’s IP address (incase you are not using the router’s default IP address) and click ok.
    6. On this part the computer will ask you for your username and password use the username and password that you added on the router’s web interface and it should allow you to view your shared files. If you will open a certain share, right click on the share and select map network drive, after that click on ok on the next screen and it should allow you to view all the files saved on the disk.


    I hope that helps you, now on to my problem:

    I have the following:

    HP DV9020t CTO F.15 firmware
    Windows Vista Ultimate
    Linksys WRT350n
    (v1.03.2 firmware; has a usb port for network attached storage)
    Western Digital My Book Essential 500 GB
    (formatted to NTFS)

    I have managed to get a lot of my problems resolved on my own, however there are 2 major things (and many minor things) that I cannot figure out:

    1) After mapping the NAS (network attached storage) to "Computer" I am able to click on the drive and view the contents. I am only able to execute come files, like .txt, and I am not able to execute others, like .exe, mp3, pdf. I get an error saying the file path is invalid make sure you typed the name correctly.. etc.. This is an odd error because, at the same time, I can copy the file and paste it to my desktop without a problem. I can also hook the drive up to my notebook directly and execute the file.

    2) I cannot delete a folder on the NAS unless it is empty. If there are files in it I need to delete all the files first, then I can delete the folder. Why is this? Can this be fixed? Is it a setting in vista?

    3) Incorrect wireless information: Wireless signal is always 3 bars no matter where I go in my house, (even next to the router).

  10. noelabc

    noelabc Network Guru Member

    NTLM v2 (used by Vista) is not compatible with SAMBA 2.x (Storage Link).

    Here is the workaround

    Step 1: Go to Local Security Settings by opening secpol.msc.

    Step 2: Go to Local Policies> Security Options> Network Security LAN Manager authentication level> Properties.

    Step 3: Change Network Security LAN Manager authentication level to Send LM & NTLM –use NTLMv2 session security if negotiated.

    Hope this helps
  11. Toink

    Toink Network Guru Member

    Thank you morrison22 and noelabc! I will try your suggestions :)

    It does appear that a newer firmware is in-fact necessary for this router to work flawlessly (at least) with Vista....
  12. noelabc

    noelabc Network Guru Member

    You're welcome. Just let us know what happens and keep us updated.

    Thank you.
  13. MajorGlory

    MajorGlory LI Guru Member

    I've got a similar yet strange issue.

    If I go to \\\DATA (the name of my share) from my vista ultimate machine all I get is an empty folder. From and XP machine I can see the data in the share, but not from vista.

    If I map a drive to the share from my vista machine I can see the files and folders.

    Problem is that Media Center doesn't support mapped drives so I can't add any of my media to my library.

    Problem is resolved after installing the WRT350N 1.05.8 beta
  14. servotron

    servotron Guest

    Hi guys, I have a similar problem. I've hooked up my Fat32 formatted MyBook 500 gb and it sees it, and works fine until I come across too large of a directory... in which case the file server pretty much just croaks. I can no longer access the "Storage" part of the web admin, but everything else works fine. It's quite annoying! Should I try the 1.05.8 beta as well? Other than the storage link problem I am happy with the network performance.
  15. jgdiaz

    jgdiaz LI Guru Member

    I was able to access my Tera Byte USB HDD from Vista Ultimate on both my HP Laptop and Desktop PC as well for the litle time the router worked, right now it is just collecting dust in my closet as I am using a Netgear WRN834M that allow my Toshiba X205-9349 and Sony VGN-FZ180E laptops to connect at 144bps all the time. So until linksys if ever decides to put out a good firmware upgrade the WRt350N will remain in the closet go on sale at Ebay or in the trash recycling bin soon.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice