WRT350N-v1 BETA firmware 1.05.8

Discussion in 'Cisco/Linksys Wireless Routers' started by Toink, Apr 27, 2007.

  1. Toink

    Toink Network Guru Member

    I got a BETA firmware from Linksys support just the other day it's WRT350N_1.05.8beta_US_code around 5.95mb and in .bin format.

    So far so good.

    PS. To the mods, if my post is against the forum rules, please just delete/edit it. Thanks!
  2. Toink

    Toink Network Guru Member

    Some 50 hits and I'm just curious if those that updated to the BETA firmware has issues with their USB attached drives?
  3. Gripweed

    Gripweed LI Guru Member

    I haven't re-attached my USB drive yet to the router yet. I had to remove it previously since it kept losing it and locking up with firmware 1.03.2. I'll try to re-attach later today. In the meantime, I haven't seen any problems with the router itself working in wired mode. Haven't checked the wireless yet.

    Did they give any indications as to what was supposedly fixed in this beta?
  4. ilkevinli

    ilkevinli Network Guru Member

    I have rried flashing with this firmware and it failed twice at around 72%. I would advise everyone against using this firmware.
  5. Gripweed

    Gripweed LI Guru Member

    I had it fail the first time as well. What I did was download the 1.03.2 version from Linksys and re-installed that first. My second attempt at loading 1.05.8 then loaded in with no problem.
    It wasn't until I started loading the 1.05.8 the first time that I realized that the router doesn't seem to have a way to save your existing firmware to a .bin file prior to an upgrade. When it went directly into the upgrade (without offering to save the firmware first) and then failed I thought I was going to have a brick on my hands. It wasn't. Feeling still adventureous but cautious, I downloaded the 1.03.2 firmware to have it handy in case of disaster. I decided to give that a try loading first to make sure that the upgrader worked. Turns out that although I received the router from the factory with the 1.03.2 version on it, the upgrade program told me that the downloaded version was different from the built-in one. That loaded fine and then I loaded 1.05.8 in which also appears to be working fine. I still haven't tested out the Wi-Fi or the USB drive again though. My main reason for getting the 350N was the gigabit network with the USB drive being a secondary benefit. I rarely use the Wi-Fi in my situation.
  6. ilkevinli

    ilkevinli Network Guru Member

    The fact that it failed once for you and twice for me would make me stay far away from that firmware. There are obviously some issues with that firmware.

    Thankfully I was smart enough to run the 1.03.2 updater after the updates failed or im sure my router would be a door stop right now.
  7. Gripweed

    Gripweed LI Guru Member

    I finally gave up on it after it lost my gigabit link and locked up on me twice in a 24 hour period. I agree with you, something's not right with it.

    As for the failed firmware updates, that happens sometimes. It doesn't really scare me away totally. Firmware updaters are a lot more intelligent now. You really need to work hard to brick something now. For the most part if you have a copy of the old firmware and an external updater, you can recover. Wasn't like that in the past. I lost 2 motherboards (temporarily until I was shipped out a new BIOS chip) to firmware updates in the distant past.
  8. skorianez

    skorianez LI Guru Member

    Hi, any one here have wrt350n firmware version 1.03.2 in bin format?
    I can't download it from linksys site, only a .exe that is useless for me, because a brick my router and I will try to recover with a jtag cable.
  9. ilkevinli

    ilkevinli Network Guru Member

    I have 1.00.0 in bin format if that will help.

  10. Toink

    Toink Network Guru Member

    Sorry about your router. Here's the link for 1.03.2 bin
  11. MajorGlory

    MajorGlory LI Guru Member

    Hi Toink,

    Any chance of another method of getting hold of this firmware (the beta)? All the RS slots are full.

    I could put it on a FTP then to make it easier for PPL to get.
  12. Toink

    Toink Network Guru Member

    Hey MajorGlory! Try this YouSendIt link

    Note: The link will be disabled exactly after 7-days of this post. Thanks!
  13. MajorGlory

    MajorGlory LI Guru Member

    Thanks Toink!!
    Much appreciated.

    I've mirrored the files here to ease distribution and included the current firmware BIN in case someone needs to revert.

    Linksys firmware BIN file:

    Linksys 1.05.8 Beta firmware:

    Installed the firmware and it feels almost like a new router. Storage link speeds are much better for a start and it solved my problem where I couldn't browse shares on the NAS from vista.
  14. posthaste

    posthaste Network Guru Member

    Glad to know you're having success with it, but the beta bricked my WRT350N. Everyone should beware of the danger before deciding to flash...

  15. ilkevinli

    ilkevinli Network Guru Member

    What method did you use to update your router with the beta firmware ?

  16. MajorGlory

    MajorGlory LI Guru Member

    I flashed it from vista. I had some issues to start with where the flash wouldn't complete, so I reset the router, reapplied the original firmware using the exe from linksys and then did the upgrade.

    I can access the NAS share by doing a \\nas\sharename now rather than having to map a drive to see the date. Storage link seems faster, but it flakes out after a while and I can't access the nas share. pretty much the same problem as with the previous firmware to be honest. Also, when this happens, I can access all the pages of the management site for the router except for the storage page. I dunno. I'm almost ready to give DD-WRT a go to try working round the issue.
  17. GAH1068

    GAH1068 LI Guru Member

    I upgraded yesterday and no problems. Storage speed with the beta build is nearly twice as fast as I was getting on current release.

    My unit shipped with latest 1.3.02 build but like others reported I had to run linksys tftp utility to go back to the "Web" released version. It would fail at 12% everytime I tried to upgrade. After running linksys version it flashed the first time.

    No issues to report. Seems much more stable to me. Connecting at 270mb on my Wireless-N card and so far so good.
  18. Linkyguy

    Linkyguy Network Guru Member

    Anyone have any more positive results from upgrading to this beta? Reluctant to install it if it causes problems. Also, anyone know when an "official" update is coming?
  19. posthaste

    posthaste Network Guru Member

    The beta bricked my router, so I'd avoid it and wait for the release.
  20. lamabile

    lamabile Network Guru Member

    The beta bricked my router as well. Flashed back to v1.03.2 and then updated to 1.05.8 beta with no problems. I tested it again and for some reason the beta update fails if your router is not set to defaults prior to flashing. It's reproducible everytime.
  21. lamabile

    lamabile Network Guru Member

    Did you manually change the wireless radio band settings to WIDE? I left mine set at AUTO and the radio band stays at STANDARD and never changes even though I am connecting with N devices.
  22. GAH1068

    GAH1068 LI Guru Member

    Yes, I set mine to Wide.
  23. ZinToledo

    ZinToledo Guest

    How did you flash it back to 1.03.02? I flashed mine to 1.05.8 and it promptly locked up. I've reset and rebooted everything, but I am not able to connect to the router and get back to the console screen. Luckily I still have reliable WRT54GS!

  24. Gripweed

    Gripweed LI Guru Member

    Try this... Disconnect all your cables and your power jack. While pressing the reset button plug in the power. Hold the reset in for about 30 seconds or so until all the lights stop flashing and you are left with a solid power light on and maybe 1 or 2 other lights on solid. Release the reset and let it settle down for a bit and then pull the power plug. Plug in just your ethernet cable and then plug in the power. Hopefully the router will respond to your computer again.
  25. GAH1068

    GAH1068 LI Guru Member

    I haven't touched or rebooted my 350N in weeks and everything is workig. No problems with my WD250 My Book hooked up to Storage link either. Beta has been very stable for me still for those sitting on the fence waiting for official release from linksys.
  26. Neoistheone2000

    Neoistheone2000 LI Guru Member

    I just installed the Beta "10 minutes ago to be exact" so fare so good, dose any one have a list of changes this firmware has?

    Also dose this fix the problem where if the power is lost, the internet connection will not come back till its reseted to defaults? I'm too scared to pull the plug and find out...

    Also, It installed with out ANY PROBLEMS, I was using Windows Vista, with Firefox when I updated it...
  27. DAH54

    DAH54 Guest

    Did you reset your router to factory defaults before the upgrade? I have found that removing the power, holding the reset button down for at least 30 seconds, and the re-entering all settings works best for me. If after the upgrade your wrt350n remembers anything chances are it will fail on the first power cycle. Auto N dual channel appears not to work. :eek:( You must select a channel and enable it.
  28. windage

    windage Network Guru Member

    I tried to connect to my router using any of the firmware releases and can only connect to it when it is on channel 6. As soon as I change channels on the router both my laptops won't connect to it. I turned off wide channel and I am only using g cards. My neighbor has a wireless n router as well and he is running it in "n" mode so I am kind of wandering if he could be causing the problem. But I have put the router right beside the laptops and got the same result. Is there a setting I am missing in the wireless laptop cards? The one card is dell 1350 mini and the other is a dlink g650 air plus. I am seriously looking into buying the new buffalo dual band gigabit router since my nieghbor's router probably will give me grief in the 2.4gig frequencies in the near future.
  29. wmar

    wmar Guest

    Do you have any further update of WRT350N firmware version 1.0 router? I can't find any further news about the V1 hardware update. Everything is V.2 hardware now...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice