WRT350N V2 custom firmware (inside)

Discussion in 'Cisco/Linksys Wireless Routers' started by sconk, Aug 5, 2007.

  1. sconk

    sconk Network Guru Member


    i ordered the wrt350n to use with dd-wrt and found out that it doesnt work witht the ver2 DAMMIT...

    i also have a d-link dns-323 nas box and that can be hacked with a small script in the share folder so i started playing around with the wrt and got a telnetd compiled in to the router :)

    if you like to test it you can download it from here.

    it boots up and starts a telnetd on port 23 with NO LOGIN!

    i will extend the firmware to have dropbear later on by using the usb port to put files in.

    And please do not send me a private msg i do not read them!
    25 oktober 08 update link to latest fw only whit telnetd right now.
  2. Rekoil

    Rekoil LI Guru Member

    Nice work there mate! Finally something fun for the V2 owners :).
  3. RobertHW

    RobertHW Network Guru Member

    Well very interesting, looked at the gpl code 2.00.17 for the WRT300N this morning, unpacked the lot and build it with the included toolchain. Seems to build without errors but ended up with a wrt300n.bin file 500Kb smaller then the original 2.00.17 firmware ? Still looking into it, not going to upload this firmware :) But the first thing I want is telnet daemon with a cli. Looked at the 350n gpl code and all seems very similar as with the 300N so maybe we can benefit from each other.

    I can see that telnetd is build within busybox and put in /usr/sbin. Seems to me that an trivial /usr/sbin/telnetd & in rcS (root fs) is enough to get telnetd going. Is this what you did perhaps ?
  4. sconk

    sconk Network Guru Member

    u got utelnetd from somewhere compiled it an put in /sbin starting it from /etc/rcS i just found out that there are some problems downloading the file i uploaded looks like its working now.
  5. RobertHW

    RobertHW Network Guru Member

    If still no login you might want to add the option /usr/sbin/telnetd -l /bin/sh to get a shell. And with the 350N source the passwd and group file is a .bak file in etc. You might want to rename these, because for busybox telnetd it's a prerequisite.

    Also you might want to state if you are providing a 350N v1 or V2 build before someone bricks his device :)
  6. sconk

    sconk Network Guru Member

    There is NO telnetd build in.

    and WRT350N V2 custom firmware (inside) in the title says v2...
  7. grimlock1970

    grimlock1970 Guest

    I'm so unhappy with this device... It crashes nearly 1-2 times within 24h. Is there a soulution to this with a custom fw??? Im still stuck with the 2.00.10 Euro. Any advice would be nice.
  8. riceboi

    riceboi Guest

    i've just recently purchased a 350n myself, but have found that it is version 2.
    as i already know, the cpu in this version does not supprt dd-wrt.

    what exactly does this custom built firmware do ?
    can someone elalborate a little more about it?

    i was really keen on using dd-wrt for this router but find it a little impossible to find a v1 router.

  9. Watha

    Watha LI Guru Member

  10. sconk

    sconk Network Guru Member

    right now its only a telnetd that is added.

    plan to make i support ext3 so i can extend it whit files on the usb.
  11. Aratar

    Aratar LI Guru Member

    There's a 2.00.16 GPL available now, what's changed?
  12. Watha

    Watha LI Guru Member

    Mostly bugfixes, particularly for UPnP, NAT/connection tracking and disk paritioning. Also a bunch of BusyBox documentation was removed from the tarball. The format they are using for "$Id: sqlite3ext.h,v 2007/04/10 05:41:09 terry_liu Exp $" changed (it now uses - instead of / in the date), causing a bunch of spam in the diff.
  13. Aratar

    Aratar LI Guru Member


    thanks for the answer :) I still noticed a lot of bugs with 2.00.16 though. Predominantly with the storage and UPnP functions, I started filing these bugs hehe... if I should ever get to talk to a competent tech rep I'd send the list to him. hehe
  14. Aratar

    Aratar LI Guru Member

    There's a history file available when you look for the V2 firmware at the european linksys website now.
  15. RobOz

    RobOz LI Guru Member

    Just a quick questions, where could I find a binary of 2.00.16 for my Linksys WRT350N V2?
    I can see a
    WRT350N-EU-ETSI-2.00.16.bin and
    Which one do I update to?
  16. Aratar

    Aratar LI Guru Member

    img. But it's unneccessary that you use that version now, linksys meanwhile updated their firmware page so it is available as a regular firmware release too.
  17. Aratar

    Aratar LI Guru Member

    I wonder if there's newer firmware than 2.00.17 available. 2.00.17 doesn't really fix any issues of this device. Doubt any custom firmware will ever support WRT350N-EU
  18. sconk

    sconk Network Guru Member

    im working on building the 2.00.17 whit a torrent client and ext2/3 support

    i have a fw 17 whit telnet and basic ext2 support if someone like to play whit it.
  19. marcheloo

    marcheloo LI Guru Member


    The device hangs every 4-5 hours, I've upgraded to 2.00.17 but still the problem persists.
    Is there any problem with the device or firmware ?
  20. sconk

    sconk Network Guru Member

    try reset it mine is rock stabel budt i only use it as a AP whit no WAN connected.
  21. marcheloo

    marcheloo LI Guru Member

    I reset many time, but no progress !
  22. thedavix12

    thedavix12 LI Guru Member

    Tell me, do you where able to have a stable firmware with the ext2 support?
    I recently bought a 350n v2, and it would be great to have a firmware with ext2 support :0)
  23. sconk

    sconk Network Guru Member

  24. thedavix12

    thedavix12 LI Guru Member

    Ho thanks I did not see the other post :)
    What type of partition does it support? ext2, ext3? hfs+ (I would like to use time machine, with the hard drive connected to the router.) ?
  25. sconk

    sconk Network Guru Member

    ext2 and ext3 pritty sure that works whit timemachine it works on my nas that runs ext2.

    im right now running the usb disk on a 128 mb usb stick so can not text timemachine budt let me compile hfs+ in to see if that works.
  26. thedavix12

    thedavix12 LI Guru Member

    You are very kind, thank you so much.
    I will wait for your feedback
  27. sconk

    sconk Network Guru Member

  28. thedavix12

    thedavix12 LI Guru Member

    Alright! Thanks :) I'll try the firmware tonight.
    Do I have to do anything special before installing your firmware?
    Probably just a stupid question for you but, is the "telnetd on port 33 WHIT NO LOGIN!" that comes with your firmware a security issue? I don't anderstand very well what it is for.
  29. sconk

    sconk Network Guru Member

    if you have random users on your network playing arround yes. they can change alot in the router.
  30. thedavix12

    thedavix12 LI Guru Member

    No not in my network, it's at home so from inside it's okay, but from outside? can someone connect by using telnet to my router if they know my ip address?
  31. sconk

    sconk Network Guru Member

    no its only open on the lan the rest is firewalled off
  32. thedavix12

    thedavix12 LI Guru Member

    Great :0)
    I'll give you my feedback tonight, thanks again!
  33. thedavix12

    thedavix12 LI Guru Member

    So I updated the firmware, but in Storage -> Disk, I still only have the NTFS partition, I cannot see the ext2 or ext3 partition.
    I also did a reset to factory defaults.
    Did I miss something?
  34. sconk

    sconk Network Guru Member

    have you looked in the share on it ?

    Else telnet to the router (telnet IP 33) and write
    echo p |fdisk /dev/sda

    and paste the output whit the line /dev/sda......
  35. thedavix12

    thedavix12 LI Guru Member

    Here is the output
    # echo p | fdisk /dev/sda
    The number of cylinders for this disk is set to 60801.
    There is nothing wrong with that, but this is larger than 1024,
    and could in certain setups cause problems with:
    1) software that runs at boot time (e.g., old versions of LILO)
    2) booting and partitioning software from other OSs
       (e.g., DOS FDISK, OS/2 FDISK)
    Command (m for help):
    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
       Device Boot    Start       End    Blocks   Id  System
    /dev/sda1               1       25497   204804621   83  Linux
    /dev/sda2           25498       60801   283579380   83  Linux
    Command (m for help): Command (m for help): Command (m for help):
    got EOF thrice - exiting..
  36. sconk

    sconk Network Guru Member

    thats a linux disk you will have SDA1 shared on ftp og windows sharing
  37. thedavix12

    thedavix12 LI Guru Member

    I am really sorry, but I don't anderstand your explanations.
    When I go to the menu Storage -> disk, I have "Blank Disk 1" with no partitions.
    And when I try to set up a ftp server I have no partition to select.
  38. bartajk5

    bartajk5 LI Guru Member

    Is it possible to connect the WRT350N V2.0, over WDS, with an WRT54GL (DD-WRT)???

    Do I need a special Firmware?
  39. sconk

    sconk Network Guru Member

    try on mac press command k and write smb://<ip> or windows start -> run \\<ip> i can see there is a small bug whit the ftp.
  40. sconk

    sconk Network Guru Member

    not right now i have orded a other router for that while im learing how to do it whit the wrt350n
  41. thedavix12

    thedavix12 LI Guru Member

    So if anderstand correctly in the administration of the router I cannot see the partitions but I can access the first partition directly with the ip address? (I was able to see the folder sda1), is it correct?
    But How can I access the second partition?
  42. sconk

    sconk Network Guru Member

    yes the webinterface is broken and yes SDA1 is the first the 2. is comming im working on a script to mount more folders and drives.

    if you have a fat32 i will be happy if you can plug that to and make a
    nvram show > /share/nvram.out upload some where (just check for passwords first, its a txt file)
  43. thedavix12

    thedavix12 LI Guru Member

    I have nothing yet on my harddrive you want me to make some partition in a specific way?
    ex: partition 1 ext2, partition 2 fat32, partition 3 ntfs ?
    Because currently on the harddrive I just have 2 partitions the first one ext2 and the second one ext3
  44. bartajk5

    bartajk5 LI Guru Member

    @ sconk

    It would be perfect if you can integreat a WDS conection in your FW.

    For the moment i use your 2.00.17 FW, great job.
    So i stay tuned

  45. sconk

    sconk Network Guru Member

    yes please try whit
    partition 1 ext2, partition 2 fat32, partition 3 ntfs
  46. luke-san

    luke-san LI Guru Member

    Hi Sconk,

    I created a single EXT2 partition on a 120GB HD with partition magic and attached that to the WRT350N V2.
    If I check using telnet then I see SDA1 -> linux, but that's how far things go and I cannot seem to share anything on the network.
    Is there anything that I am missing?
  47. sconk

    sconk Network Guru Member

    its shared in the all partisions folder on the network share.

    you can not create a share for it in the webinterface.

    im waiting on a usb disk so i can try to get that part working.
  48. luke-san

    luke-san LI Guru Member

    mm weird, thought I tried that yesterday and I could only see a 'standard' 20MB but I couldn't write anything on that.
    Integration on the webinterface would be great.
    Also been able to format in EXT2 or EXT3 in the interface would be nice.
    I just can't understand why the Linksys developers have not done this in the first place.
    The NAS200 can do this but the speed plainly ... euhm sucks.

    I've also done some NTFS tests and found out that as soon as you write a 'bigger' file the device goes bananas and locks up.

    I also wonder if it is possible to change the attrib settings somehow or does this have something to do with the version of the samba?
  49. SirDuduk

    SirDuduk Guest

    Hi all and thank you sconk for your work. Today i uploaded the image and successfully telnet-ed to it. I wanted to change my TTL mangling cause my ISP is setting it to 1 and i can't use my router to access internet from internal stations. So i executed this:
    iptables -t mangle -A PREROUTING -j TTL --ttl-set 64
    but got:
    iptables: Unknown error -1

    No matter whether i specify network interface to iptables I'm getting the same error. I was using an WRT54GL before without any problems but now i am stuck with this 350N v2. Does anyone else met such problem? Any help will be appreciated.

    Merry Christmas to all btw:biggrin:
  50. sconk

    sconk Network Guru Member

    -j TTL --ttl-set 64 is the problem i will try to se if i can find some info about it budt right now im on my way to vacation home to my parrants.
  51. tszyman1

    tszyman1 Network Guru Member

    Hi All,

    Sconk - you did a great job - really. I would like to help a bit. I don't have any tools yet. What should I have to be able to compile and modify the firmware?
  52. sconk

    sconk Network Guru Member

    a linux box and the gpl source from linksys all works out of the box.
  53. Magnusart

    Magnusart Guest

    sconk: Great that someone is hacking these firmwares at last. I would like to replicate what you did for WRT300N v2.

    But I can't find the source code for what you did (I thought it would be easier for me to just start out with adding the same stuff you added). I know the the whole toolchain is big but could you add a diff or something at least? This is GPL code after all.

    I just want to see how you approached it. I don't want to brick my router if I can avoid it.
  54. sconk

    sconk Network Guru Member

    start downloade the gpl source from link sys get that working then get utelnetd and find out how to compile it (pritty easy just change the Makefile in apps dir and you got telnetd after you start it.

    budt start just getting the stockfirmware to compile and give me a "call" :)
  55. inphinity

    inphinity Guest

    Mounting the shared folder All_Partitions on Linux, and other stuff

    Hey dude, first of all I want to say: great job.

    I found a pair of problems when using your firmware. Therefore, I'd be keen on contributing to what you started to fix them.

    First of all there's a problem when mounting the shared resource All_Partitions, since SDA is a link to /mnt/HD_a2. My system will say that the link is broken, since /mnt/HD_a2 doesn't exist.

    Second is the BitTorrent client. MLdonkey is well known for its bad implementation when it comes to BitTorrent, so I'd suggest to offer different alternatives.

    Finally I find problems with permissions when accessing the partition (ext3). Sometimes it's mounted as read only (even by telnet can't write anything), and some other times it won't let me write even if i'm logged in as admin (when I can by telnet).

    Therefore I'll get the source code compiled and stuff, but it would be great if we could access some kind of repository (CVS, subversion) to access the changes you've performed and have a starting point.

    Hope to hear from you soon.

  56. sconk

    sconk Network Guru Member

    yes the mldonkey is damm buggy.

    the only thing i have done is to compile utelnetd add this to etc/rcS
    /sbin/utelnetd -d -l /bin/sh &
    and enable the filesystems in the kernel.
  57. jetmcquack

    jetmcquack Guest

    bumb, any news? where can i download it, the link is not working!
  58. sconk

    sconk Network Guru Member

  59. Does this firmware support IPv6? If not, is there any IPv6 firmware for WRT350 v2?
  60. X3lectric

    X3lectric LI Guru Member

    WRT350N v2 beta firmware


    I think (Im sure) media server does not work with xbox360 or vista ultimate sp1 nor with anything else on my network using that firmware I posted

    Able to browse but not to play, xbox360 just displays (\) overlay over all media regardless if it reads it from its own drive or from Vista ultimate. very odd.

    NTFS usb formated drives the samba share stops responding more so if a fat32 drive is inserted. but Im able to browse and use any media insideon any pc on my network

    Very buggy still this firmware there should be a place rather than linksys chat to place these bug reports staright to Brussels.

    If anyone is reading form those labs there please reply...

    Anyone experiencing these issues or any other that wanna share theire views please do...
  61. coolmak1

    coolmak1 Guest

    you guys should take a close look at this thread at forum.openwrt.org


    i (mindbender) posted about the progress regarding vanilla kernel support for Marvell 88F5xx81 based routers...there is also a kernel with built in initramfs to show that this kernel works and boots to the initramfs where you can connect via telnet.

    just try to load http://downloads.foonas.org/foonas-em/alpha/kuropro/uImage_2.6.24 via telnet..

    this kernel of course has the wrong flash mapping, but hey, it boots.

    based on successfully loading of this 2.6.24 kernel + initramfs watha and DavidKra started to work a little on the kernel.....read the thread, 99 % already has been done.

    help them to get openwrt and therefore also dd-wrt support for this boxes.
  62. Davidkra

    Davidkra Guest

    Here's the link to my git repo: http://repo.or.cz/w/wrt350n-kernel.git .

    Any information you can provide can help me adding more functionality to my -setup.c file (I lost my USB-to-TTL cable so I can't boot my kernel on my own WRT350Nv2...)

  63. sconk

    sconk Network Guru Member

  64. sconk

    sconk Network Guru Member

  65. joelang6126

    joelang6126 Addicted to LI Member


    Hi Guys

    Using the hack v2.00.19 firmware recently posted I tried to install Twonky media server on to my WRT350n v2. The Twonky installer reports that it installs successfully and that the server has been started however the web interface for the server wont load (the twonky one). Also during the installation it reports that /bin/sh: wget: not found multiple times.

    I need to get this server up and running in so my brother can stream video to his Xbox 360. Can somebody help me to do this please?
  66. sconk

    sconk Network Guru Member

    Im relly busy whit my work and that firmware so i dont have time right now.

    budt if you try to read about the opt-ware you might get wget and other to work.
  67. sanderb

    sanderb Addicted to LI Member

    Work around 4GB file size limit

    I mailed Linksys tech support with my problem to upload files bigger than 4GB to my USB disk. They told me I that I can only use FAT32 (NTFS is not supported for writing).

    In this thread, I got the impression that people got ext3 going using a hacked firmware. I just installed the hacked v2.00.19 firmware. I have also created two ext3 partitions on my USB disk. But this is the point where I am stuck. How do I get sharing of the two partitions working with FTP and Windows sharing?

    I connected to the router using telnet, and fdisk tells me that the disk can be found:
    Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
    255 heads, 63 sectors/track, 121601 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sda1 1 115498 927737653+ 83 Linux
    /dev/sda2 115499 121601 49022347+ 83 Linux

    Who can help me setting up?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice