WRT350N v2 - How to unbrick if I can't ping it

Discussion in 'Cisco/Linksys Wireless Routers' started by C.K., Dec 19, 2007.

  1. C.K.

    C.K. Guest

    I think the topic says nearly everything I want to know. I wanted to flash the router with the latest official firmware from Linksys using Firefox. The browser stopped the action 4 % and told me to abort the dialog or stop the script. I stopped the script und after that I didn't get an answer from the router. I tried to unplug it. Nothing. I resetted it a few times. Nothing. Before I resetted it the first all LED's for internet, wireless, security and the computer were on. Now only power and the LED for the connected computer is on.
    When I ping ist on or on my old setting I get no answer. Windows tells me that it has connectivity problems and that I may not be able to use the LAN connection. But when I run the dos box and use ipconfig /all I see that the PC has the IP
    Maybe someone can tell me how I can turn this brick back into a running system.
  2. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    You need to set a static IP on your computer's network card to something in the subnet like Open a command prompt window and enter "ping -t" without the quotes and presss enter. Press and hold the reset button for 5 seconds and watch the ping window to see if it responds. If it does, setup a TFTP client to send the image as soon as you see a response and hit reset again. This should allow you to send a flash image during the "boot wait" period which is roughly 5 seconds.

    If all else fails you should hold the reset button for 30 seconds which should reset the firmware to defaults which might allow you to try the TFTP method again. Its pretty much the same process as the WRT54G/GS models.

    You can use a TFTP client like Tftpd32 to load the firmware image again
  3. Molot

    Molot LI Guru Member

    I know it's old thread, but I have just that problem, and the instructions above dont works for me.

    After powering device on, power led is solid green. After powering it with reset pushed, it's green-amber blink. After keeping it that way some time, it's off, but device is still a brick.

    All states are final (waiting ~3 hours and no change, tested).

    What could I do?

    It's v2.1, if it makes any difference.
  4. relghuar

    relghuar Addicted to LI Member

    Hello everyone. I have exactly the same problem as Molot. No ping on the device, no tftp update, regardless of how long I hold the reset button at reboot (or later), or if I do it immediately after the power-up or 10 minutes later, or if I use 192.168.1.x net or 192.168.0.x (my original one). Power led behavior is also exactly the same as he described, even the lan-port leds are behaving as they should (green/orange light for the right port based on link speed). Any idea what could be wrong and how could we fix it?
    I've disassembled my unit and found a serial port connector, I'll try to put a cable together and get to the console. Hopefully that will give me a clue as to what's going on in the blinking brick... I'll let you know if I find out something interesting.
  5. relghuar

    relghuar Addicted to LI Member

    Hello again. I've managed to assemble a USB->serial cable yesterday, and to connect to a serial console on my router. I discovered the problem there - rootfs section of flash memory was corrupted somehow, so the kernel started OK but couldn't mount rootfs and ended in Kernel Panic. Holding down the reset button by power-up to get the power led blinking orange/green only started some strange egiga mode that probably tried to load firmware from network. Unfortunately I have no idea how that works and where did it try to get the firmware from, so I gave up trying. Now this is where my problems started - u-boot in wrt350n-v2 obviously can't flash new firmware, it can only flash the bootloader itself. Loading kernel through tftp from my notebook didn't work, because again it crashed on mounting rootfs. Instead of getting kernel to mount root from USB, i tried to get u-boot to flash new roofs, and by playing around with u-boot commands I don't really know, I managed to overwrite the u-boot itself somehow. So, now my router doesn't even blink after power up. That's my reward for being clever and careful :)
    Next round: JTAG adapter! But I have to get one for USB first, as I have no parallel ports on the notebook. Again I'll let you know how that went.....
  6. krasnoff

    krasnoff Addicted to LI Member

    Same problems with WRT350N ver. 2.1, upload beta firmware 2.00.19 -> brick.
    Reset 5sec, 30 sec, power + reset - no ping (with a static IP on computer). Any ideas? Help, please!
  7. krasnoff

    krasnoff Addicted to LI Member

    I need your help, please...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice