WRT54-GL V1.1 Flash failed (locked?)

Discussion in 'Cisco/Linksys Wireless Routers' started by bowiemie, Nov 26, 2006.

  1. bowiemie

    bowiemie LI Guru Member


    I have just bought three new WRT54-GL V1.1 and tried them flash them with DD-WRT or OpenWRT software. The units refuse the 3rd party software upload.

    I have opened up the unit with serial nbr CL7B1F855002 and came up with the following hardware contents:

    WRT54-GL V1.1 Hardware

    === CPU/Processor BCM5352EKPBG ===

    Broadcom AirForceâ„¢ 802.11g Router System-on-Chip with BroadRangeâ„¢ Technology


    The BCM5352EL integrates a high-performance MIPS32 processor, IEEE 802.11 b/g MAC/PHY, SDRAM controller, and a configurable five-port Fast Ethernet (FE) switch. The BCM5352EL provides wireless LAN connectivity supporting data rates of up to 125 Mbps that is backward-compatible with standard 802.11 b/g.

    The BCM5352EL supports a WAN connection via its configurable media interfaces. The per-port programmable four-level priority queues enable QoS (IEEE 802.1p) for guaranteed bandwidth applications, DiffServ/TOS, and L2/L3 IGMP snooping. The IEEE 802.1Q VLAN allows flexible implementation of VLAN grouping and WAN port segregation.

    * 200-MHz MIPS32® CPU core with 16-KB instruction cache, 8-KB data cache, and 256-B prefetch cache and a Memory Management Unit (MMU) for high-level Real-Time Operating System (RTOS) support
    * Interfaces to BCM2050, a 2.4-GHz direct conversion radio
    * The BCM5352EL is a low-cost, high performance system-on-chip (SoC) for residential and small office, home office (SOHO) markets.
    * Time-to-market is significantly reduced through stable Linux® and VxWorks® kernels, board support packages (BSPs), drivers, and toolchains.

    === Flash Memory JS28F320 ===

    Intel® Advanced Boot Block 32M Flash Memory


    Parameter Blocks

    The B3 flash memory device architecture includes parameter blocks to facilitate storing frequently
    updated small parameters (such as data traditionally stored in an EEPROM). The word-rewrite
    functionality of EEPROMs can be emulated using software techniques. Each flash memory device
    contains eight parameter blocks of 8 Kbytes/4 Kwords (8192 bytes/4,096 words) each.

    Main Blocks

    After the parameter blocks, the remainder of the flash memory array is divided into equal-size main
    blocks (65,536 bytes/32,768 words) for data or code storage..
    • The 32-Mbit memory device contains 63 main blocks.

    ===RAM Memory 128M ===

    SDRAM HY 5D U 28 18 22 ETP-J

    HY Hynix memory
    U VDD = 2.5V & VDDQ = 2.5 V
    28 128MB 4k refresh
    18 Organisation x 18 ?
    2 4 Banks
    2 Interface SSTL_2
    E 6th generation

    T TSOP package
    J DDR333 2.5 3.3

    I suspect that they have changed the CFE bootloader and will need to unlock the unit with solution found on:


    Has anybody else experienced this problem...

    Recommendations and suggestions are more than welcome !


  2. snooze7555

    snooze7555 Network Guru Member


    You can try to wake the router up with tftp.

    1. make the computer
    2. go to cmd and put on the command line ping -t
    3. Put the wrt54gl on and look if there is an replay, when there is an replay put with tftp the last linksys formware . Rename it to code.bin

    Mybe it works,
  3. Toxic

    Toxic Administrator Staff Member

  4. Paradis

    Paradis Guest

    Sorry, but I have to ask.

    I followed this guide http://www.linksysinfo.org/forums/showthread.php?t=47259

    But i dont know what I would do now. I am here:
    The router is now in failsafe mode and is waiting on you to tftp a firmware image to it. Find any good firmware image for your router
    and upload it. In linux it might go something like this:

    This is under linux
    $ cd /home/voidmain/firmware
    $ ls
    $ tftp
    tftp> bin

    tftp> put OpenWrt_b3.bin
    The following is for windows
    $ cd "to direcotry of bin file"
    $ tftp -i PUT "name of bin".bin
    Just make sure you transfer the file in binary mode (that's what the "bin" command did). Once the firmware has uploaded, your router should automatically reboot.
    If you uploaded the OpenWRT firmware like I did above you can then telnet into your box (telnet If you uploaded the stock Linksys
    firmware you should be able to get to your router with your web browser (

    I am using windows XP SP2. I remowed the screwdriver and loaded WRT54gl.4.30.5 with TFTP 1.255. What is the next step? I dont understand what I should do now :/

    ooh! SO HAPPY :biggrin: :biggrin: I hold the reset botton in 30 seconds. And then tried to connect to the router in by browser ( and it worked! :D So sorry for my bad english:redface:, but thanks to you!
  5. bowiemie

    bowiemie LI Guru Member

    Unlock the 4.30.7 firmware PROBLEM SOLVED

    The WRT54-GL units came with ROM version 4.30.7

    and this version does not accept any 3rd party software flash, except dd-wrt.v23_micro_generic.bin !!!

    (TFTP does not help, the TFTP process locks up or sends an error back)

    Downgrading to v4.30.5 does not realy seem to solve the problem but it seems to avoid some issues of the unit becoming unresponsive after flashing with the === dd-wrt.v23_micro_generic.bin === image. (But this can be solved with cold reboot or 30s reset of the unit.)

    In any case after flashing with the dd-wrt.v23_micro_generic.bin image the unit requires a === push of the reset button for at least 30s === (watch the ping response) to get the web interface functioning correctly (telnetting to the unit functions correctly after the flash however)

    Once the DD_WRT image loaded you can flash with any other 3rd party software.

    Many thanks for the help everyone : THE PROBLEM IS SOLVED

    cheers and have fun...:thumbup:
  6. Mastec

    Mastec Network Guru Member

    Just a quick note... You need to flash with the dd-wrt mini before flashing the micro. The mini prepares the router to accept other larger file size firmware.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice