WRT54G 1.0 Downgrade from v4.00.7 , Apr 26 2005

Discussion in 'Cisco/Linksys Wireless Routers' started by pauldy, Aug 24, 2005.

  1. pauldy

    pauldy Network Guru Member

    Ok I made the mistake of bricking my router. After removing the cover and forcing a checksum error I was able to get the latest firmware from linksys installed. The problem now is that this is the most persistent firmware I've ever run across. Even tftp loading of other firmware will not work. What would help me out a great deal is if anyone knows of an easy way to downgrade this firmware so I can replace the firmware with the version I would like to run.

    Things I have tried thus far. Forcing checksum error again and tftping Alchemy pre7 to the router. Using the update feature of the firmware returns "Upgrade are failed."
  2. pauldy

    pauldy Network Guru Member

    The fix at hand. While reading through these forums I noticed dd wrt had a release based off the newer codebase from linksys. I downloaded the latest firmware from their site did the update via the web interface and it worked fine. From there I was able to restore the previous version of firmware I was running and now everything is back to normal. No more demonic firmware that won't die.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice