WRT54G 1.0 MAJORLY bricked (linksys says give up)

Discussion in 'Cisco/Linksys Wireless Routers' started by Burns, Mar 3, 2005.

  1. Burns

    Burns Network Guru Member

    Somehow I managed to brick my WRT54G 1.0 so bad that I can't ping it. The power light comes on but the diag light stays solid (not flashing, just on, permanently). I tried shorting pins 15/16 and 16/17 and nothing changed. I don't even know if those are the right pins to short since the 1.0 version has a different chip than the later versions that I've read about using the short method. Does anyone have any input on how to unbrick this thing?
  2. Toxic

    Toxic Administrator Staff Member

  3. Burns

    Burns Network Guru Member

    Um, thanks for the reply toxic, but did you read my post before posting or just my subject line? I already tried shorting the pins. Like I said in my post above, I have a 1.0 version that does not have the intel chip and these instructions are for 1.1 that does.

    Anyone who can help me, I'd appreciate it.
  4. Toxic

    Toxic Administrator Staff Member

    thanks for your reply however you did not read the article then

    Cons: I suppose you could make your WRT54G even deader than it already is, although I have not actually heard of anyone who has done this. The pictures in this tip are for people who have the v1.1 hardware. It works for the 1.0 and 2.0 versions as well but the board layout is a little different in the other hardware versions. You'll just have to find your flash chip.


    The WRT54G with the miniPCI card is the revision 1.0 WRT54G.

    The AMD flash is on the main board, labeled "BANK0" - it's located right above or sort of under the miniPCI card.

    If you're looking at the board, there's a little triangle to one corner of the AMD flash - that's pin 1. The pin you want to short to ground is pin 16, I believe. (It might be easier to count from the end away from pin 1 - count about 9 back.)

    Instead of shorting pins together, short pin 16 to ground. On the 1.0, the most convenient ground is at a position labeled XTAL1. It's a big silver pad where it looks like a component belongs, but isn't one there. There's 3 holes there - use the center one in the middle of the silver pad.

    Short those while plugging it in. The LED lights should come on... flash the firmware at that point to an older firmware using Linksys' auto-upgrade utility. (Remember to put your PC into a static IP in the network.)
  5. HillJack

    HillJack Network Guru Member

    That method Toxic describes works perfectly (almost) for me. I had solid green power and solid red diag and absolutely no other leds lit.

    Unfortunately, and it could just be my situation, my 1.0 worked following his steps, but if I unplug it (dont want to reassemble it plugged in ;) or hit the reset button, back to a brick she goes (solid red diag and solid green power). Repeating those steps brings it back to life, but unplug or reset and boom, brick.

    Any suggestions?
  6. jagboy

    jagboy Network Guru Member

    did you try tftp. the problem that i findt that most people have is that they do not start the tftp program at the start of the wrt54g. they do not start it fast enought. the whole point of boot_wait is that is gives you 5 sec time frame at the start to load a firmware. but most people miss this time frame. and they forget to give their compters a static ip and lower the speed of the nic to 10mbps half duplex.
  7. HillJack

    HillJack Network Guru Member

    Hmm, I did everything you suggest, even the 10mb half-duplex, except the tftp within the first 5 seconds. I will try that tomorrow and if it works will post my results.

  8. HillJack

    HillJack Network Guru Member

    Well, tftp doesn't do anything. It always times out, regardless if I launch it 1 second after it boots, or 1 minute. I tried the Linksys Auto-Updater, and it DOES do what it's supposed to, but will not survive resets/power cycles.

    However, I tried something slightly different and did get things working...

    This is how I did it (and it now survives hard resets and power-cycles):

    1. Set NIC to ( subnet mask).
    2. Set NIC gateway to, no DNS servers.
    3. Set NIC speed to 10MBit half-duplex (don't know if this is really needed).
    4. Plug CAT5 into any of the 4 ports on the WRT54G (I used port 2).
    5. Short ping 16 to XTAL1.
    6. Plug the WRT54G in: red diag will start blinking quickly. Remove the pin 16-to-XTAL1 short. Wait for diag to blink slowly (give it 10-15 seconds).
    7. Run the LinkSys auto-updater: WRT54GV3.0_3.03.6_US_code.exe is what I used. It should be successful, but DO NOT POWER OFF OR RESET at this point - it'll rebrick.
    8. Load the web management interface ( and goto Management -> Firmware Upgrade and upload HyperWRT_2.1b1_G.bin (or I guess whatever firmware you want to use, I used this).

    Once the upload was complete, everything appeared to work, so I tested a power-cycle (unplugged the WRT54G for a few seconds and plugged it back in) and it survived! So I then tried a hard-reset (holding the reset button for 8 seconds or so) - it survived that too!

    Thanks to Toxic for the headstart!

    Now I just have to figure out what to do with it, since I replaced it with a v2.2 when it first died :)
  9. splashd

    splashd Guest

    Wow, I was ready to call you all liars--I had no luck doing the pin short, ping, tftp thing, until today. I just now un-bricked a v2 and v1--woohoo!

    My v2 finally pin-shorted correctly when I shorted pin 16 with the antena ground with a paper clip :)

    I got a ping, but was unable to tftp a bin, until I did a power on 5 second reset , followed by finally correctly setting my ethernet to 1/2 duplex 10 Mb.

    Once working I quickly dusted off my v 1 brick, and shorted pin 16 with the xtal (silver square) center hole I'd read about. Finally I had ping (not the Chinese duck, either).

    Worth noting is that after you tftp you must be patient--the wrt54g will reboot itself eventually--wait for it.

    thanks to all who helped

  10. JacksonBrown

    JacksonBrown Network Guru Member

    Yes, this is an old thread, but I just have to thank HillJack!
    I recently got my hands on a v1 router, and in the course of playing around, I killed it. I looked all over for how to debrick a v1 router and I finally came across this thread.
    Thank you :cheering:
  11. pauldy

    pauldy Network Guru Member

    For those interested the method I used to debrick mine was to use a small flat head screw driver and short the pins in the vacinity of the hole by the exposed side of the flashchip. I started about 2 or three above the hole and moved down unplugging the power and plugging it in. I did this until the pings lasted more than 8 replies. Once I had this I tried flashing many times getting a timeout. After renaming the files to the same name of the linksys files however they would act like they uploaded. Only when I actually did a linksys firmware did everything work as expected.

    A couple of things I noticed not in any tutorials on version 1.0 were that this flash chip is located under the wi-fi card. The file names I was flashing had to have a specific format like the files you see in the zip files from linksys. Also after flashing to configure I had to change the ports from the lan to wan port to reset defaults then the lan ports worked again. The 1.0 router has some oddities I followed all the tuts I could find and in the end I thought I was sitting with a dead router. So I decided to improvise I had even gotten to the point of soldering a header to the JTAG connector thinking as a last resort I would use that to reflash the device. In the end however I was successful in getting the flash to work but simply forcing a checksum error on the flash/cmos chip..

    Something to keep in mind with the flash chip after reading the docs is that by raking the pins about the worst you can do is force the chip enable not to enable at bootup and force a fault on the device that will be gone when you reboot it. I was unable to see anything on the chip itself that had a voltage that would do anything to the device itself. On the flip side probing any other part of the router esp around the antenna can most certainly fry the flash chip.

    One last tip, if you are unable to ping the device try the wan port and lan port. If neither work on try the ip address last set on the router. I tried using the reset switch and lan wan cable tricks to reset the router, none worked. I wasn't getting a reply on after a couple of tries I did some broadcast pings on subnets and found the device sitting on it's old ip.
  12. riox

    riox Guest

    Power supply

    Hi all, my WRT54G also stopped working with the symptoms described above (ie. power light comes on but the diag light stays solid) even though I haven't been messing around with firmware updates... One day it just stopped.

    So, I tried some of the tricks with shorting the pins, etc, however in the end it turned out that the router was fine, but the power supply was busted. The DC output should be about +5V and mine was only getting it up to +4.8V which was enough for WRT54G to spit the dummy. Once I plugged in another (compatible) power supply everything started working again.

    Long story short, before you start voiding the warranty, poking the circuitry or buying another router, it might be worth testing your power supply.
  13. jagboy

    jagboy Network Guru Member

  14. vibe666

    vibe666 Network Guru Member

    yeah, and it got me so far, but not any further.

    everyone keeps talking about tftp but i have no idea what it is. i've tried googling, but all i get is little command line apps that seem to be the right thing, but no idea how to actually use it to reflash the router.

    i'd been running hyperwrt for months with no problems, when during a reboot it just wouldn't come back on.

    no IP address, no pings no nothing.

    I was getitng a rapid flashing (green) power light and the LAN port I was using seemed to be working (green with the odd flash of activity) but that was it.

    eventually, after much messing, (shorting 15-16 didn't work) i used the grounding pin 16 trick which got me pings again.

    i was able to flash it using the linksys firmware upgrade utility, but even after a hard reset the router only responds to pings and there's no web interface or other activity.

    i have a tftp.exe DOS app, and the latest hyperwrt firmware .bin file, but no idea how to get it onto the router. i just can't find any guides that include that elusive bit of info. right now, I have about 15 pages of wrt54g de-bricking info open on my PC, and I'm none the wiser.

    can anyone tell me what to do to get this thing up and running again?

    thanks in advance.
  15. Goodguy_mark

    Goodguy_mark Guest

    WRT54G Diag led always on

    Thanks Riox! Here's what I have posted elsewhere, but relevant to this topic. It was Riox who got me in the right direction...

    I had a constantly on Diagnostic ( Diag ) and power led

    "The storm probably killed your power supply. A storm did mine. Check your power supply o/p voltage UNDER LOAD i.e when the router is attached to the power supply. You will find that a. you don't have a brick and b. you need a new power supply.
    It is not enough to check your power supply without load (router unattached) It must have at least 1A drawn from it.
    My router's power supply was 4.8V under load, which was not enough to power the router properly.
    My new power supply gives 4.95V when 1.1A is drawn from it.This powers my v1.0 WRT54G Fine.
    Mine is a 5v model which draws 1.1A there are some 12v ones out there too. Check and make sure. Good luck."
  16. crawdaddy

    crawdaddy Network Guru Member

    well, I have a v3 model. I tried the pins 15-16 trick, I tried the pin 16 to ground trick, I set a manual ip, 10mb half duplex, the works. since I bricked it, it has responded to ONE ping, and that is it. my only other option I guess is jtag, but I don't have the parts right now to build the jtag adapter. Any non-jtag thoughts on how to debrick this b*tch? I just spent 65 bucks on it and I'm pissed I bricked it so fast.
  17. cgondo

    cgondo Network Guru Member

    I have tried various things as well in my V2 and the only thing left to try is JTAG. I am in the process of building it now hoping that it will revive my router.
  18. lou3622

    lou3622 Network Guru Member

    how can i determine if its my power supply. By power supply you do mean the power cord correct? And finally if it is the power cord, is it proprietary to Linksys for a version 1?
  19. crawdaddy

    crawdaddy Network Guru Member

    to determine if the power supply is to blame, I would suggest getting a voltmeter and putting it across the terminals on the power cord. As far as I can think of, there isn't any way to test the power adapter under load except by voiding your warranty and breaking open the WRT to measure voltage on the lugs for the jak the power cord attaches to. You should get 12v DC. However, I think some of the older WRTs had 5v DC power suppiles. Best of luck
  20. lou3622

    lou3622 Network Guru Member

    i have a version1 and its a 5volt.
  21. crawdaddy

    crawdaddy Network Guru Member

    refer to the battery operated router thread in the modding section, and you will notice that the WRT can run off of voltages from 5VDC to 20VDC. The trick is if u have a 12 volt powersupply, when u plug it into the router, does the voltage drop? that would signify a bad powersupply, since it can't keep the voltage up under load.
  22. crawdaddy

    crawdaddy Network Guru Member

    I tried to use the JTAG method to debrick my V3 router, and I get a chip id of 00000000000000000000000000000. It isn't recognizing the chip. What did I do wrong? Please help.
  23. Urgentemente

    Urgentemente Guest

    Re: Power supply

    Thanks to you and Goodguy_mark for being thorough with the info there riox instead of just "PSU fixed it" , I think you just answered a post I was about to make.
    I got a bricked V1.0 off ebay last week, same symptoms, constant green power LED and red Diag, no blinking,
    After reading the various de-bricking tutorials I've been trying to no avail to get it in failsafe mode.
    Then I remembered seeing a post about power supply voltage. Tested mine last night power jacks inside the router and was only getting 4.40V, while testing just the supply at the connector gave me slightly over 5V, so from your post it sounds like thats more than enough for my V1.0 to not want to play !
    Can I ask what you used for a replacement supply? did you buy one specifically, or had one lying around? Would you mind posting a make&part number if poss?
  24. ptomic

    ptomic Network Guru Member

    I have other problem.

    Destination host unreachable.
    Reply from bytes=32 time=1ms TTL=64
    Reply from bytes=32 time<1ms TTL=64
    Reply from bytes=32 time=132ms TTL=64
    Reply from bytes=32 time=267ms TTL=64
    Reply from bytes=32 time=402ms TTL=64
    Reply from bytes=32 time=537ms TTL=64
    Reply from bytes=32 time=671ms TTL=64
    Request timed out.
    And it's repeat. 4 time timed out, than this, and again.
    I get this when hold reset button.
    I don't have constantly or flashing red light.
    I just have request timed out.
    Is my WRT54G V.1.0 bricked or what ??
    I think that he CAN be pinged while in some kind of "rescue mode", few seconds.

    But here come whole story:
    It work OK with official 4.20.7.
    I wish to put DD-wrt, and I do. All was ok, but I have constant RED light. I can go to web interface, but I can't telnet. Say wrong password.
    I was thinking to get back OLD official, and start auto-update.
    It was go OK, but I CAN'T open any more ?!!?
    Try hard reset, nothing. Try connecting 15-16, nothing. Try connect 16 with XTAL1, but I'm not sure any more did I do that right !?
    My router work(lights), but I can't access, I don't have red lights !?
    Can someone to help me ??!
  25. ptomic

    ptomic Network Guru Member

    Just for record. I did it again. :sad:
    I try to put CAT5 in WAN port, and it worked. :)
    There was LinkSys 4.20.7
    Then I try to put dd-wrt.v23_mini_generic.bin via web interface, and [grand finale] I press continue too early !!! :eek:
    Now I can't access via LAN ports and via WAN port !!! :sadbye:

    What to do ??
  26. MarkInDavis

    MarkInDavis Network Guru Member

    I had a similar situaution after putting DD-WRT mini on a 54G ver 1. It killed my wired access, but amazingly I could access it wirelessly. I upgraded firmware via wireless (generally not a good idea - but I had no other access), did an "erase nvram;reboot" after that and I was back in business.

    With regards to tftp, if you go to ftp://ftp.linksys.com/pub/network/tftp.exe

    you can download this version of tftp from linksys that lets you put in your router's password - it is probably admin. This allows you to tftp new firware outside the boot wait period.

    Good luck and let us know.
  27. ptomic

    ptomic Network Guru Member

    What firmware you upload ??
  28. MarkInDavis

    MarkInDavis Network Guru Member

    I uploaded HyperWRT - tofu 9 at the time. Now I would suggest HyperWRT - tofu 11. Either one should be fine.
  29. ptomic

    ptomic Network Guru Member

    I was succesuful when I try to connect via CAT5. How I don't know.
    I start .exe from Linksys(4.20.7). And it was successuful.
    When I go to it was too. :)
    But when I try to do SES enabled I get constant power and red LED light.
    I was connected via CAT5 and WiFi from same computer. Is that a problem ??

    Did I brick'em ?? :eek:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice