WRT54G 1.1 + DHCP + WEP

Discussion in 'Cisco/Linksys Wireless Routers' started by sig9, Jun 2, 2005.

  1. sig9

    sig9 Network Guru Member

    Hi everybody.

    I'm having a problem with the Linksys WRT54G v1.1 router when using DHCP and WEP. When I try to connect with a client computer to the router, the connection procedure jams when the host tries to acquire the address from the DHCP server. I have checked the keys many times and tried different keys and so on. However, if I turn on the WPA encryption, the host computer acquires an IP address just fine. I cannot use WPA on the network since I have a couple of older 802.11b devices, which do not support WPA.

    I have an internal DHCP server, which serves the addresses for machines, but I have also tried to enable the router's own DHCP server. No effect.

    I have tried different firmwares on the router, but it does not have any effect. Might this be a client-side problem?

    Any ideas? Thanks in advance.
  2. sig9

    sig9 Network Guru Member

    Found a solution!

    Ha! After a while of research I found a working solution.

    I had to type the whole WEP key instead of the passphrase in hex form to the WEP password prompt in Windows. Now the connection works and the host acquires an address ok from the dhcp server.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice